summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/log4c/log4c/0001-Use-the-API-properly-in-the-example-format-security-.patch26
-rw-r--r--meta-oe/recipes-support/log4c/log4c_1.2.4.bb4
2 files changed, 29 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/log4c/log4c/0001-Use-the-API-properly-in-the-example-format-security-.patch b/meta-oe/recipes-support/log4c/log4c/0001-Use-the-API-properly-in-the-example-format-security-.patch
new file mode 100644
index 000000000..9ff9d7002
--- /dev/null
+++ b/meta-oe/recipes-support/log4c/log4c/0001-Use-the-API-properly-in-the-example-format-security-.patch
@@ -0,0 +1,26 @@
1From 97f0b7b25474fab25f5757f7c50a77e20be5d05b Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Franti=C5=A1ek=20Dvo=C5=99=C3=A1k?= <valtri@civ.zcu.cz>
3Date: Mon, 7 Sep 2015 15:00:48 +0200
4Subject: [PATCH] Use the API properly in the example (format security error
5 fixed).
6
7---
8 examples/helloworld1/mylog.h | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/examples/helloworld1/mylog.h b/examples/helloworld1/mylog.h
12index 280f3dc..57e5369 100644
13--- a/examples/helloworld1/mylog.h
14+++ b/examples/helloworld1/mylog.h
15@@ -39,7 +39,7 @@ static LOG4C_INLINE int mylog_fini(){
16
17 static LOG4C_INLINE void mylog_msg(char *catName,int a_priority, char *msg){
18 #ifndef WITHOUT_LOG4C
19- log4c_category_log(log4c_category_get(catName), a_priority, msg);
20+ log4c_category_log(log4c_category_get(catName), a_priority, "%s", msg);
21 #else
22 printf(msg);
23 #endif
24--
252.12.0
26
diff --git a/meta-oe/recipes-support/log4c/log4c_1.2.4.bb b/meta-oe/recipes-support/log4c/log4c_1.2.4.bb
index a028f2b7f..ef7ad847a 100644
--- a/meta-oe/recipes-support/log4c/log4c_1.2.4.bb
+++ b/meta-oe/recipes-support/log4c/log4c_1.2.4.bb
@@ -4,7 +4,9 @@ LICENSE = "LGPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5 5
6SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \ 6SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
7 file://fix_configure_with-expat.patch" 7 file://fix_configure_with-expat.patch \
8 file://0001-Use-the-API-properly-in-the-example-format-security-.patch \
9 "
8 10
9SRC_URI[md5sum] = "0d94919136e1d16b68427562e74cb3dd" 11SRC_URI[md5sum] = "0d94919136e1d16b68427562e74cb3dd"
10SRC_URI[sha256sum] = "5991020192f52cc40fa852fbf6bbf5bd5db5d5d00aa9905c67f6f0eadeed48ea" 12SRC_URI[sha256sum] = "5991020192f52cc40fa852fbf6bbf5bd5db5d5d00aa9905c67f6f0eadeed48ea"