summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch25
-rw-r--r--meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb6
2 files changed, 1 insertions, 30 deletions
diff --git a/meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch b/meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch
deleted file mode 100644
index 82cdc36ac..000000000
--- a/meta-networking/recipes-daemons/igmpproxy/igmpproxy/0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From a557651a08e21e3c7c7f5eca9f5405f86624903f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 14 Jul 2017 22:42:51 -0700
4Subject: [PATCH] src/igmpproxy.h: Include sys/types.h for u_short/u_init
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 src/igmpproxy.h | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/src/igmpproxy.h b/src/igmpproxy.h
12index 4dabd1c..4454729 100644
13--- a/src/igmpproxy.h
14+++ b/src/igmpproxy.h
15@@ -46,6 +46,7 @@
16 #include <stdbool.h>
17
18 #include <sys/socket.h>
19+#include <sys/types.h>
20 #include <sys/un.h>
21 #include <sys/time.h>
22 #include <sys/ioctl.h>
23--
242.13.3
25
diff --git a/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb b/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb
index c99ebe0e9..db96d487b 100644
--- a/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb
+++ b/meta-networking/recipes-daemons/igmpproxy/igmpproxy_0.2.1.bb
@@ -4,12 +4,8 @@ HOMEPAGE = "http://sourceforge.net/projects/igmpproxy/"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=432040ff3a55670c1dec0c32b209ad69" 5LIC_FILES_CHKSUM = "file://COPYING;md5=432040ff3a55670c1dec0c32b209ad69"
6 6
7SRC_URI = "https://github.com/pali/igmpproxy/releases/download/${PV}/igmpproxy-${PV}.tar.gz \ 7SRC_URI = "https://github.com/pali/igmpproxy/releases/download/${PV}/${BP}.tar.gz"
8 file://0001-src-igmpproxy.h-Include-sys-types.h-for-u_short-u_in.patch \
9"
10SRC_URI[md5sum] = "3a9c2cb42c1f5ee0cb769a4884545641" 8SRC_URI[md5sum] = "3a9c2cb42c1f5ee0cb769a4884545641"
11SRC_URI[sha256sum] = "d351e623037390f575c1203d9cbb7ba33a8bdef85a3c5e1d2901c5a2a38449a1" 9SRC_URI[sha256sum] = "d351e623037390f575c1203d9cbb7ba33a8bdef85a3c5e1d2901c5a2a38449a1"
12 10
13inherit autotools pkgconfig 11inherit autotools pkgconfig
14
15CFLAGS += "-D_GNU_SOURCE"