summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/nmon/nmon/0001-lmon16g.c-Adjust-system-headers.patch46
-rw-r--r--meta-oe/recipes-support/nmon/nmon_16g.bb (renamed from meta-oe/recipes-support/nmon/nmon_13g.bb)16
2 files changed, 55 insertions, 7 deletions
diff --git a/meta-oe/recipes-support/nmon/nmon/0001-lmon16g.c-Adjust-system-headers.patch b/meta-oe/recipes-support/nmon/nmon/0001-lmon16g.c-Adjust-system-headers.patch
new file mode 100644
index 000000000..e8debe56a
--- /dev/null
+++ b/meta-oe/recipes-support/nmon/nmon/0001-lmon16g.c-Adjust-system-headers.patch
@@ -0,0 +1,46 @@
1From d977b5170027926eb97ab9742ddc51d2a5555a34 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 14 Jul 2017 10:06:49 -0700
4Subject: [PATCH] lmon16g.c: Adjust system headers
5
6fstab.h is unused
7errno.h is in /usr/include
8defines from sys/cdefs.h is used
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 lmon16g.c | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/lmon16g.c b/lmon16g.c
16index cb27e09..d2a11c5 100644
17--- a/lmon16g.c
18+++ b/lmon16g.c
19@@ -63,7 +63,7 @@ static char *SccsId = "nmon " VERSION;
20 #include <fcntl.h>
21 #include <math.h>
22 #include <time.h>
23-#include <sys/errno.h>
24+#include <errno.h>
25 #include <sys/types.h>
26 #include <sys/stat.h>
27 #include <sys/ioctl.h>
28@@ -71,6 +71,7 @@ static char *SccsId = "nmon " VERSION;
29 #include <sys/time.h>
30 #include <sys/socket.h>
31 #include <sys/wait.h>
32+#include <sys/cdefs.h>
33
34 /* Windows moved here so they can be cleared when the screen mode changes */
35 WINDOW *padwelcome = NULL;
36@@ -576,7 +577,6 @@ struct procsinfo {
37 int isroot = 0;
38
39 #include <mntent.h>
40-#include <fstab.h>
41 #include <sys/stat.h>
42 #include <sys/statfs.h>
43 #include <net/if.h>
44--
452.13.3
46
diff --git a/meta-oe/recipes-support/nmon/nmon_13g.bb b/meta-oe/recipes-support/nmon/nmon_16g.bb
index 1f7518972..e77faa30a 100644
--- a/meta-oe/recipes-support/nmon/nmon_13g.bb
+++ b/meta-oe/recipes-support/nmon/nmon_16g.bb
@@ -4,23 +4,25 @@ SECTION = "console/utils"
4LICENSE = "GPLv3" 4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/Documentation.txt;md5=dbb13658cf55d687c4f2ff771a696d4a" 5LIC_FILES_CHKSUM = "file://${WORKDIR}/Documentation.txt;md5=dbb13658cf55d687c4f2ff771a696d4a"
6DEPENDS = "ncurses" 6DEPENDS = "ncurses"
7PR = "r2" 7DEPENDS_append_libc-musl = " bsd-headers"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/nmon/lmon13g.c;name=lmon \ 9SRC_URI = "${SOURCEFORGE_MIRROR}/nmon/lmon${PV}.c;name=lmon \
10 ${SOURCEFORGE_MIRROR}/nmon/Documentation.txt;name=doc \ 10 ${SOURCEFORGE_MIRROR}/nmon/Documentation.txt;name=doc \
11 file://0001-lmon16g.c-Adjust-system-headers.patch \
11" 12"
12 13SRC_URI[lmon.md5sum] = "246ccfc74d5af55d992601fc4d3d4a72"
13SRC_URI[lmon.md5sum] = "b1b8e6c0123ad232394991f2d4f40494" 14SRC_URI[lmon.sha256sum] = "da82dd693b503b062854dfe7dbb5d36b347872ab44a4aa05b97e9d577747f688"
14SRC_URI[lmon.sha256sum] = "456ab2a342b31d1a352d0d940af5962fa65a12ae8757ff73e6e73210832ae8b5"
15SRC_URI[doc.md5sum] = "dbb13658cf55d687c4f2ff771a696d4a" 15SRC_URI[doc.md5sum] = "dbb13658cf55d687c4f2ff771a696d4a"
16SRC_URI[doc.sha256sum] = "1f7f83afe62a7210be5e83cd24157adb854c14599efe0b377a7ecca933869278" 16SRC_URI[doc.sha256sum] = "1f7f83afe62a7210be5e83cd24157adb854c14599efe0b377a7ecca933869278"
17 17
18CFLAGS += "-D JFS -D GETUSER -Wall -D LARGEMEM" 18CFLAGS += "-D JFS -D GETUSER -Wall -D LARGEMEM"
19LDFLAGS += "-ltinfo -lncursesw" 19LDFLAGS += "-ltinfo -lncursesw -lm"
20ASNEEDED_pn-nmon = "" 20ASNEEDED_pn-nmon = ""
21 21
22S = "${WORKDIR}"
23
22do_compile() { 24do_compile() {
23 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/lmon13g.c -o nmon 25 ${CC} ${CFLAGS} ${LDFLAGS} lmon${PV}.c -o nmon
24} 26}
25 27
26do_install() { 28do_install() {