summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch28
-rw-r--r--meta-oe/recipes-devtools/libubox/libubox_git.bb28
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch b/meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch
new file mode 100644
index 000000000..02117fa8d
--- /dev/null
+++ b/meta-oe/recipes-devtools/libubox/libubox/0001-version-libraries.patch
@@ -0,0 +1,28 @@
1diff --git a/CMakeLists.txt b/CMakeLists.txt
2index 57804cf..1aa7f27 100644
3--- a/CMakeLists.txt
4+++ b/CMakeLists.txt
5@@ -18,6 +18,7 @@ ENDIF()
6 SET(SOURCES avl.c avl-cmp.c blob.c blobmsg.c uloop.c usock.c ustream.c ustream-fd.c vlist.c utils.c safe_list.c runqueue.c md5.c kvlist.c ulog.c base64.c)
7
8 ADD_LIBRARY(ubox SHARED ${SOURCES})
9+SET_TARGET_PROPERTIES(ubox PROPERTIES VERSION 1.0.1 SOVERSION 1)
10 ADD_LIBRARY(ubox-static STATIC ${SOURCES})
11 SET_TARGET_PROPERTIES(ubox-static PROPERTIES OUTPUT_NAME ubox)
12
13@@ -46,6 +47,7 @@ find_library(json NAMES json-c)
14 IF(EXISTS ${json})
15 ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
16 TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})
17+ SET_TARGET_PROPERTIES(blobmsg_json PROPERTIES VERSION 1.0.1 SOVERSION 1)
18
19 ADD_LIBRARY(blobmsg_json-static STATIC blobmsg_json.c)
20 SET_TARGET_PROPERTIES(blobmsg_json-static
21@@ -55,6 +57,7 @@ IF(EXISTS ${json})
22 TARGET_LINK_LIBRARIES(jshn blobmsg_json ${json})
23
24 ADD_LIBRARY(json_script SHARED json_script.c)
25+ SET_TARGET_PROPERTIES(json_script PROPERTIES VERSION 1.0.1 SOVERSION 1)
26 TARGET_LINK_LIBRARIES(json_script ubox)
27
28 INSTALL(TARGETS blobmsg_json blobmsg_json-static jshn json_script
diff --git a/meta-oe/recipes-devtools/libubox/libubox_git.bb b/meta-oe/recipes-devtools/libubox/libubox_git.bb
new file mode 100644
index 000000000..3e886b766
--- /dev/null
+++ b/meta-oe/recipes-devtools/libubox/libubox_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "C utility functions for OpenWrt"
2SECTION = "libs"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "\
5 file://avl.c;endline=39;md5=00810155fed3d604816ec5814523d60a \
6 file://avl-cmp.c;endline=15;md5=1603e6094b432a5f3f320877a06f41b5 \
7 file://base64.c;endline=61;md5=51fdff010d45b0086ac0a6e035693dc0 \
8 file://blobmsg.c;endline=15;md5=7ed64c1570e8c9b46c4fc6fbd16c489e \
9 file://list.h;endline=28;md5=2d5f5475fbd0f08741354c5a99c2e983 \
10 file://md5.h;endline=39;md5=048bf9f68963c207a0c2b3a94c9d2aaa \
11 file://md5.c;endline=51;md5=0a448eea0bcbc89e3c7e6608f2d119a0 \
12 file://usock.h;endline=18;md5=f0dfdc8de858e66d66d74036611bba14 \
13"
14
15SRC_URI = "\
16 git://git.openwrt.org/project/libubox.git \
17 file://0001-version-libraries.patch \
18"
19
20SRCREV = "136a5196266d03d537f822c4e67d2fde2ed59505"
21
22S = "${WORKDIR}/git"
23
24inherit cmake
25
26DEPENDS = "json-c"
27
28EXTRA_OECMAKE = "-DBUILD_EXAMPLES=OFF -DBUILD_LUA=OFF"