summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-connectivity/python-mprpc/python-mprpc.inc17
-rw-r--r--meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb19
-rw-r--r--meta-python/recipes-connectivity/python-mprpc/python3-mprpc_0.1.13.bb2
3 files changed, 21 insertions, 17 deletions
diff --git a/meta-python/recipes-connectivity/python-mprpc/python-mprpc.inc b/meta-python/recipes-connectivity/python-mprpc/python-mprpc.inc
new file mode 100644
index 000000000..3a1c0bea1
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-mprpc/python-mprpc.inc
@@ -0,0 +1,17 @@
1SUMMARY = "A gevent based messagpack rpc library"
2DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \
3It is based on gevent for handling connections and enabling concurrent connections."
4HOMEPAGE = "https://github.com/studio-ousia/mprpc"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
7DEPENDS += "${PYTHON_PN}-gevent"
8RDEPENDS_${PN} += "${PYTHON_PN}-gevent ${PYTHON_PN}-msgpack ${PYTHON_PN}-gsocketpool"
9
10SRC_URI_append = " \
11 file://0001-fix_setup_py.patch;patch=1;pnum=1 \
12"
13
14SRC_URI[md5sum] = "449e6239eb5ff07b9cceb86e1ab0c2ee"
15SRC_URI[sha256sum] = "5881cc7fbb8de814e2b4aa5958bfe147c5c301e46749190f0e6abf373cf56d82"
16
17inherit pypi
diff --git a/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb b/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb
index 78df00af2..6b2ea2193 100644
--- a/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb
+++ b/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb
@@ -1,17 +1,2 @@
1SUMMARY = "A gevent based messagpack rpc library" 1require python-mprpc.inc
2DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \ 2inherit setuptools
3It is based on gevent for handling connections and enabling concurrent connections."
4HOMEPAGE = "https://github.com/studio-ousia/mprpc"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
7DEPENDS += "python-gevent"
8RDEPENDS_${PN} += "python-gevent python-msgpack python-gsocketpool"
9
10SRC_URI_append = " \
11 file://0001-fix_setup_py.patch;patch=1;pnum=1 \
12"
13
14SRC_URI[md5sum] = "449e6239eb5ff07b9cceb86e1ab0c2ee"
15SRC_URI[sha256sum] = "5881cc7fbb8de814e2b4aa5958bfe147c5c301e46749190f0e6abf373cf56d82"
16
17inherit pypi setuptools
diff --git a/meta-python/recipes-connectivity/python-mprpc/python3-mprpc_0.1.13.bb b/meta-python/recipes-connectivity/python-mprpc/python3-mprpc_0.1.13.bb
new file mode 100644
index 000000000..837d604ed
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-mprpc/python3-mprpc_0.1.13.bb
@@ -0,0 +1,2 @@
1require python-mprpc.inc
2inherit setuptools3