diff options
6 files changed, 2 insertions, 197 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch deleted file mode 100644 index f6147cbf3..000000000 --- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From 5af6dec8764375ca4f13bd9fed96af090228351a Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary S. Robertson" <gary.robertson@linaro.org> | ||
3 | Date: Mon, 11 Aug 2014 11:06:04 -0500 | ||
4 | Subject: [libhugetlbfs][PATCH] Extend arm32 support to include BE variants | ||
5 | |||
6 | This patch applies the same technique used by Koen Kool in the following patch | ||
7 | which was accepted by the libhugetlbfs project: | ||
8 | |||
9 | [0a4f6] Add aarch64_be_support 2014-03-31 10:52:37 | ||
10 | |||
11 | It modifies the libhugetlbfs Makefile to mark all 32-bit arm architectures | ||
12 | as supported by the libhugetlbfs build. Builds and successful functional | ||
13 | tests have been performed for armv7a LE and BE runtime platforms. | ||
14 | |||
15 | This patch replaces and renders obsolete the following patch: | ||
16 | arm32-support.patch submitted by: Chunrong Guo <B40290@freescale.com> | ||
17 | |||
18 | Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> | ||
19 | --- | ||
20 | Makefile | 2 +- | ||
21 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/Makefile b/Makefile | ||
24 | index 91502e1..ba79607 100644 | ||
25 | --- a/Makefile | ||
26 | +++ b/Makefile | ||
27 | @@ -59,7 +59,7 @@ ELF32 = elf32ppclinux | ||
28 | TMPLIB32 = lib | ||
29 | CPPFLAGS += -DPPC_NO_SEGMENTS | ||
30 | else | ||
31 | -ifeq ($(ARCH),armv7l) | ||
32 | +ifneq (,$(findstring arm,$(ARCH))) | ||
33 | CC32 = $(CC) | ||
34 | TMPLIB32 = lib | ||
35 | ELF32 += armelf_linux_eabi | ||
36 | -- | ||
37 | 1.7.9.5 | ||
38 | |||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch deleted file mode 100644 index 271827511..000000000 --- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From a0166583ba5f7b6a6d2de434f633126fb12c9d29 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary S. Robertson" <gary.robertson@linaro.org> | ||
3 | Date: Wed, 24 Sep 2014 15:27:31 -0500 | ||
4 | Subject: [PATCH] Makefile: Recognize all ix86 arches | ||
5 | |||
6 | In a non-native build scenario, the makefile | ||
7 | only recognized i386 or x86_64 arches. Added support | ||
8 | to recognize i486, i586, i686. | ||
9 | |||
10 | Upstream Status: Accepted by libhugetlbfs project | ||
11 | |||
12 | Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> | ||
13 | --- | ||
14 | Makefile | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/Makefile b/Makefile | ||
18 | index 91502e1..0bfaee8 100644 | ||
19 | --- a/Makefile | ||
20 | +++ b/Makefile | ||
21 | @@ -71,7 +71,7 @@ ELF64 = aarch64elf | ||
22 | TMPLIB64 = lib64 | ||
23 | CUSTOM_LDSCRIPTS = no | ||
24 | else | ||
25 | -ifeq ($(ARCH),i386) | ||
26 | +ifneq (,$(filter i386 i486 i586 i686,$(ARCH))) | ||
27 | CC32 = $(CC) | ||
28 | ELF32 = elf_i386 | ||
29 | TMPLIB32 = lib | ||
30 | -- | ||
31 | 1.7.9.5 | ||
32 | |||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch deleted file mode 100644 index 215ae728d..000000000 --- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | Subject: [PATCH] aarch64: fix cross compilation | ||
2 | |||
3 | This patch allow to override CC and use it for aarch64 case like | ||
4 | the other architectures. | ||
5 | |||
6 | Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> | ||
7 | |||
8 | Upstream-Status: Submitted | ||
9 | --- | ||
10 | Makefile | 4 ++-- | ||
11 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/Makefile b/Makefile | ||
14 | index 91502e1..5aa1e12 100644 | ||
15 | --- a/Makefile | ||
16 | +++ b/Makefile | ||
17 | @@ -33,7 +33,7 @@ CFLAGS += -Wall -fPIC | ||
18 | CPPFLAGS += -D__LIBHUGETLBFS__ | ||
19 | |||
20 | ARCH = $(shell uname -m | sed -e s/i.86/i386/) | ||
21 | -CC = gcc | ||
22 | +CC ?= gcc | ||
23 | |||
24 | CUSTOM_LDSCRIPTS = yes | ||
25 | |||
26 | @@ -66,7 +66,7 @@ ELF32 += armelf_linux_eabi | ||
27 | CUSTOM_LDSCRIPTS = no | ||
28 | else | ||
29 | ifneq (,$(findstring aarch64,$(ARCH))) | ||
30 | -CC64 = gcc | ||
31 | +CC64 = $(CC) | ||
32 | ELF64 = aarch64elf | ||
33 | TMPLIB64 = lib64 | ||
34 | CUSTOM_LDSCRIPTS = no | ||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch deleted file mode 100644 index 4e5b7bbbb..000000000 --- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From 1ab6f7f9b34fc745451140fc21db6763dffc5785 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary S. Robertson" <gary.robertson@linaro.org> | ||
3 | Date: Thu, 25 Sep 2014 14:57:06 -0500 | ||
4 | Subject: [PATCH] ld.hugetlbfs: arm arches - fix page size and text offset | ||
5 | setup | ||
6 | |||
7 | There's 3 issues fixed: | ||
8 | * typo on MB variable (MB -> $MB) | ||
9 | * some linker variants are missing (linux and big endian) | ||
10 | - armelfb_linux_eabi | ||
11 | - aarch64elfb | ||
12 | - aarch64linux | ||
13 | - aarch64linuxb | ||
14 | * text segment offset was not specified for armv7 BE | ||
15 | |||
16 | NOTE: This patch replaces and makes obsolete the following previously | ||
17 | submitted patch: | ||
18 | |||
19 | aarch64: fix page size not properly computed | ||
20 | by: Fathi Boudra <fathi.boudra@linaro.org> | ||
21 | |||
22 | Upstream Status: Accepted at libhugetlbfs project | ||
23 | |||
24 | Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> | ||
25 | --- | ||
26 | ld.hugetlbfs | 8 ++++---- | ||
27 | 1 file changed, 4 insertions(+), 4 deletions(-) | ||
28 | |||
29 | diff --git a/ld.hugetlbfs b/ld.hugetlbfs | ||
30 | index df446dd..4417442 100755 | ||
31 | --- a/ld.hugetlbfs | ||
32 | +++ b/ld.hugetlbfs | ||
33 | @@ -87,7 +87,7 @@ elf32ppclinux|elf64ppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;; | ||
34 | elf64lppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;; | ||
35 | elf_i386|elf_x86_64) HPAGE_SIZE=$((4*$MB)) SLICE_SIZE=$HPAGE_SIZE ;; | ||
36 | elf_s390|elf64_s390) HPAGE_SIZE=$((1*$MB)) SLICE_SIZE=$HPAGE_SIZE ;; | ||
37 | -armelf_linux_eabi|aarch64elf) HPAGE_SIZE=$((2*MB)) SLICE_SIZE=$HPAGE_SIZE ;; | ||
38 | +armelf*_linux_eabi|aarch64elf*|aarch64linux*) HPAGE_SIZE=$((2*$MB)) SLICE_SIZE=$HPAGE_SIZE ;; | ||
39 | esac | ||
40 | |||
41 | if [ "$HTLB_ALIGN" == "slice" ]; then | ||
42 | @@ -96,9 +96,9 @@ if [ "$HTLB_ALIGN" == "slice" ]; then | ||
43 | |||
44 | # targeting the ARM platform one needs to explicitly set the text segment offset | ||
45 | # otherwise it will be NULL. | ||
46 | - if [ "$EMU" == "armelf_linux_eabi" ]; then | ||
47 | - HTLBOPTS="$HTLBOPTS -Ttext-segment=$SLICE_SIZE" | ||
48 | - fi | ||
49 | + case "$EMU" in | ||
50 | + armelf*_linux_eabi) HTLBOPTS="$HTLBOPTS -Ttext-segment=$SLICE_SIZE" ;; | ||
51 | + esac | ||
52 | fi | ||
53 | |||
54 | ${LD} "${args[@]}" ${HTLBOPTS} | ||
55 | -- | ||
56 | 1.7.9.5 | ||
57 | |||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch deleted file mode 100644 index 9e2a5e58d..000000000 --- a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | Subject: [PATCH 1/1] Replace lib/lib64 hardcoded values by LIBDIR32/LIBDIR64 | ||
2 | variables | ||
3 | |||
4 | Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> | ||
5 | |||
6 | Upstream-Status: Submitted | ||
7 | --- | ||
8 | Makefile | 4 ++-- | ||
9 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index 91502e1..682c0db 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -181,9 +181,9 @@ BINDIR = $(PREFIX)/share/libhugetlbfs | ||
16 | EXEDIR = $(PREFIX)/bin | ||
17 | DOCDIR = $(PREFIX)/share/doc/libhugetlbfs | ||
18 | ifdef CC32 | ||
19 | -PMDIR = $(PREFIX)/lib/perl5/TLBC | ||
20 | +PMDIR = $(LIBDIR32)/perl5/TLBC | ||
21 | else | ||
22 | -PMDIR = $(PREFIX)/lib64/perl5/TLBC | ||
23 | +PMDIR = $(LIBDIR64)/perl5/TLBC | ||
24 | endif | ||
25 | MANDIR1 = $(PREFIX)/share/man/man1 | ||
26 | MANDIR3 = $(PREFIX)/share/man/man3 | ||
27 | -- | ||
28 | 1.9.2 | ||
29 | |||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb index ce0c6af0f..a2d3922cc 100644 --- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb +++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | |||
@@ -7,21 +7,16 @@ DEPENDS = "sysfsutils perl" | |||
7 | RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource" | 7 | RDEPENDS_${PN} += "bash perl python python-io python-lang python-subprocess python-resource" |
8 | RDEPENDS_${PN}-tests += "bash" | 8 | RDEPENDS_${PN}-tests += "bash" |
9 | 9 | ||
10 | PV = "2.18" | 10 | PV = "2.19" |
11 | PE = "1" | 11 | PE = "1" |
12 | 12 | ||
13 | SRCREV = "ea3f6b273f535aab38cefae30030774457bbbfe6" | 13 | SRCREV = "426c22d65415fcb8927f68fbc5887e075a8dc40a" |
14 | SRC_URI = " \ | 14 | SRC_URI = " \ |
15 | git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \ | 15 | git://github.com/libhugetlbfs/libhugetlbfs.git;protocol=https \ |
16 | file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \ | 16 | file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \ |
17 | file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \ | 17 | file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \ |
18 | file://tests-Makefile-install-static-4G-edge-testcases.patch \ | 18 | file://tests-Makefile-install-static-4G-edge-testcases.patch \ |
19 | file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ | 19 | file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ |
20 | file://0001-aarch64-fix-cross-compilation.patch \ | ||
21 | file://0001-ld.hugetlbfs-arm-arches-fix-page-size-and-text-offse.patch \ | ||
22 | file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ | ||
23 | file://0001-Extend-arm32-support-to-include-BE-variants.patch \ | ||
24 | file://0001-Makefile-Recognize-all-ix86-arches.patch \ | ||
25 | " | 20 | " |
26 | 21 | ||
27 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |