diff options
11 files changed, 389 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch new file mode 100644 index 000000000..381a44d30 --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch | |||
@@ -0,0 +1,136 @@ | |||
1 | Index: src/configure.in | ||
2 | =================================================================== | ||
3 | --- rp-pppoe-3.8.orig/src/configure.in 2006-04-03 00:29:42.000000000 +1000 | ||
4 | +++ rp-pppoe-3.8/src/configure.in 2007-06-07 22:19:36.000000000 +1000 | ||
5 | @@ -5,6 +5,13 @@ | ||
6 | dnl pppd directory for kernel-mode PPPoE | ||
7 | PPPD_DIR=ppp-2.4.1.pppoe2 | ||
8 | |||
9 | +dnl hard code some paths | ||
10 | +PPPD=/usr/sbin/pppd | ||
11 | +ID=/usr/bin/id | ||
12 | +ECHO=/bin/echo | ||
13 | +AC_ARG_VAR(PPPD) | ||
14 | +AC_ARG_VAR(ID) | ||
15 | + | ||
16 | AC_CONFIG_HEADER(config.h) | ||
17 | |||
18 | AC_PREFIX_DEFAULT(/usr) | ||
19 | @@ -44,7 +51,7 @@ | ||
20 | AC_MSG_RESULT($ac_cv_struct_sockaddr_ll) | ||
21 | |||
22 | if test "$ac_cv_struct_sockaddr_ll" = yes ; then | ||
23 | -AC_DEFINE(HAVE_STRUCT_SOCKADDR_LL) | ||
24 | +AC_DEFINE([HAVE_STRUCT_SOCKADDR_LL], [], [Have struct SOCKADDR_LL]) | ||
25 | fi | ||
26 | |||
27 | dnl Check for N_HDLC line discipline | ||
28 | @@ -55,7 +62,7 @@ | ||
29 | ac_cv_n_hdlc=no) | ||
30 | AC_MSG_RESULT($ac_cv_n_hdlc) | ||
31 | if test "$ac_cv_n_hdlc" = yes ; then | ||
32 | -AC_DEFINE(HAVE_N_HDLC) | ||
33 | +AC_DEFINE([HAVE_N_HDLC], [], [Have N_HDLC]) | ||
34 | fi | ||
35 | |||
36 | AC_ARG_ENABLE(plugin, [ --enable-plugin=pppd_src_path build pppd plugin], ac_cv_pluginpath=$enableval, ac_cv_pluginpath=no) | ||
37 | @@ -100,13 +107,13 @@ | ||
38 | if test "$ac_cv_header_linux_if_pppox_h" = yes ; then | ||
39 | if test "$ac_cv_pluginpath" != no ; then | ||
40 | LINUX_KERNELMODE_PLUGIN=rp-pppoe.so | ||
41 | - AC_DEFINE(HAVE_LINUX_KERNEL_PPPOE) | ||
42 | + AC_DEFINE([HAVE_LINUX_KERNEL_PPPOE], [], [Have kernel PPPoE]) | ||
43 | PPPD_INCDIR=$ac_cv_pluginpath | ||
44 | fi | ||
45 | fi | ||
46 | |||
47 | if test "$ac_cv_debugging" = "yes" ; then | ||
48 | - AC_DEFINE(DEBUGGING_ENABLED) | ||
49 | + AC_DEFINE([DEBUGGING_ENABLED], [], [Debugging enabled]) | ||
50 | fi | ||
51 | |||
52 | AC_SUBST(LINUX_KERNELMODE_PLUGIN) | ||
53 | @@ -131,15 +138,8 @@ | ||
54 | AC_CHECK_SIZEOF(unsigned int) | ||
55 | AC_CHECK_SIZEOF(unsigned long) | ||
56 | |||
57 | -dnl Check for location of pppd | ||
58 | -AC_PATH_PROG(PPPD, pppd, NOTFOUND, $PATH:/sbin:/usr/sbin:/usr/local/sbin) | ||
59 | -AC_PATH_PROG(ECHO, echo, echo) | ||
60 | - | ||
61 | -dnl Check for setsid (probably Linux-specific) | ||
62 | -AC_PATH_PROG(SETSID, setsid, "", $PATH:/sbin:/usr/sbin:/usr/local/sbin) | ||
63 | - | ||
64 | dnl Check for an "id" which accepts "-u" option -- hack for Solaris. | ||
65 | -AC_PATH_PROG(ID, id, "", /usr/xpg4/bin:$PATH) | ||
66 | +dnl AC_PATH_PROG(ID, id, "", /usr/xpg4/bin:$PATH) | ||
67 | |||
68 | dnl Check for Linux-specific kernel support for PPPoE | ||
69 | AC_MSG_CHECKING(for Linux 2.4.X kernel-mode PPPoE support) | ||
70 | @@ -183,44 +183,8 @@ | ||
71 | CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -ansi" | ||
72 | fi | ||
73 | |||
74 | -dnl If we couldn't find pppd, die | ||
75 | -if test "$PPPD" = "NOTFOUND"; then | ||
76 | - AC_MSG_WARN([*** Oops! I couldn't find pppd, the PPP daemon anywhere.]) | ||
77 | - AC_MSG_WARN([*** You must install pppd, version 2.3.10 or later.]) | ||
78 | - AC_MSG_WARN([*** I will keep going, but it may not work.]) | ||
79 | - PPPD=pppd | ||
80 | -fi | ||
81 | - | ||
82 | -dnl Figure out pppd version. 2.3.7 to 2.3.9 -- issue warning. Less than | ||
83 | -dnl 2.3.7 -- stop | ||
84 | - | ||
85 | -PPPD_VERSION=`$PPPD --version 2>&1 | awk ' /version/ {print $NF}'` | ||
86 | - | ||
87 | -case "$PPPD_VERSION" in | ||
88 | -1.*|2.0.*|2.1.*|2.2.*|2.3.0|2.3.1|2.3.2|2.3.3|2.3.4|2.3.5|2.3.6) | ||
89 | - AC_MSG_WARN([*** Oops! Your version of pppd is $PPPD_VERSION, which is too old.]) | ||
90 | - AC_MSG_WARN([*** You need at least 2.3.7 (2.3.10 or newer recommended.]) | ||
91 | - AC_MSG_WARN([*** I will keep going, but it may not work.]) | ||
92 | - ;; | ||
93 | - | ||
94 | -2.3.7|2.3.8|2.3.9) | ||
95 | - AC_MSG_WARN([*** Warning. Your version of pppd is $PPPD_VERSION. You will]) | ||
96 | - AC_MSG_WARN([*** not be able to use connect-on-demand. Upgrade to pppd]) | ||
97 | - AC_MSG_WARN([*** 2.3.10 or newer if you need connect-on-demand.]) | ||
98 | - ;; | ||
99 | - | ||
100 | -2*|3*|4*|5*|6*|7*|8*|9*) | ||
101 | - ;; | ||
102 | - | ||
103 | -*) | ||
104 | - AC_MSG_WARN([*** Oops. I cannot figure out what version of pppd you have.]) | ||
105 | - AC_MSG_WARN([*** All I got back was '$PPPD_VERSION']) | ||
106 | - AC_MSG_WARN([*** I will keep going, but it may not work.]) | ||
107 | - ;; | ||
108 | -esac | ||
109 | - | ||
110 | dnl Figure out packing order of structures | ||
111 | -AC_MSG_CHECKING([packing order of bit fields]) | ||
112 | +AC_CACHE_CHECK([packing order of bit fields],rpppoe_cv_pack_bitfields,[ | ||
113 | AC_TRY_RUN([ | ||
114 | union foo { | ||
115 | struct bar { | ||
116 | @@ -245,10 +209,11 @@ | ||
117 | } | ||
118 | }], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev, | ||
119 | $ECHO "no defaults for cross-compiling"; exit 0) | ||
120 | +]) | ||
121 | |||
122 | if test "$rpppoe_cv_pack_bitfields" = "rev" ; then | ||
123 | AC_MSG_RESULT(reversed) | ||
124 | - AC_DEFINE(PACK_BITFIELDS_REVERSED) | ||
125 | + AC_DEFINE([PACK_BITFIELDS_REVERSED], [], [Reversed bitfields]) | ||
126 | else | ||
127 | AC_MSG_RESULT(normal) | ||
128 | fi | ||
129 | @@ -312,6 +277,7 @@ | ||
130 | AC_SUBST(RDYNAMIC) | ||
131 | AC_SUBST(LIBEVENT) | ||
132 | AC_SUBST(ECHO) | ||
133 | +AC_SUBST(HAVE_STRUCT_SOCKADDR_LL) | ||
134 | |||
135 | datadir_evaluated=`eval echo $datadir` | ||
136 | AC_SUBST(datadir_evaluated) | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/dont-swallow-errors.patch b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/dont-swallow-errors.patch new file mode 100644 index 000000000..81ce2db33 --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/dont-swallow-errors.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- a/src/configure.in.org 2008-01-14 21:08:38.000000000 +0200 | ||
2 | +++ a/src/configure.in 2008-01-14 21:20:09.000000000 +0200 | ||
3 | @@ -208,7 +208,7 @@ | ||
4 | return 2; | ||
5 | } | ||
6 | }], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev, | ||
7 | -$ECHO "no defaults for cross-compiling"; exit 0) | ||
8 | +$ECHO "no defaults for cross-compiling"; exit 1) | ||
9 | ]) | ||
10 | |||
11 | if test "$rpppoe_cv_pack_bitfields" = "rev" ; then | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-server.default b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-server.default new file mode 100644 index 000000000..996d57f3c --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-server.default | |||
@@ -0,0 +1,22 @@ | |||
1 | # PPPoE Server options | ||
2 | |||
3 | # Maximum segment size, not used for in kernel PPPoE | ||
4 | #MSS=1412 | ||
5 | |||
6 | # Device(s) - Space seperated list of devices to listen on | ||
7 | #DEVICES="eth1" | ||
8 | |||
9 | # Local IP | ||
10 | #LOCAL_IP=10.0.0.1 | ||
11 | |||
12 | # Starting remote IP | ||
13 | #REMOTE_IP=10.67.15.1 | ||
14 | |||
15 | # Service name | ||
16 | #SERVICE_NAME="acme" | ||
17 | |||
18 | # Maximum number of sessions, default is 16 | ||
19 | #MAX_SESSIONS=64 | ||
20 | |||
21 | # Access concentrator name, default is the hostname | ||
22 | #ACCESS_CONCENTRATOR_NAME="pppoe-rtr-1" | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-server.init b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-server.init new file mode 100755 index 000000000..21afe0be3 --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-server.init | |||
@@ -0,0 +1,59 @@ | |||
1 | #! /bin/sh | ||
2 | |||
3 | test -f /usr/sbin/pppoe-server || exit 0 | ||
4 | test -f /etc/default/pppoe-server && . /etc/default/pppoe-server | ||
5 | |||
6 | case $1 in | ||
7 | start) | ||
8 | OPTIONS="" | ||
9 | if [ -n "$MSS" ]; then | ||
10 | OPTIONS="$OPTIONS -m $MSS" | ||
11 | fi | ||
12 | if [ -n "$DEVICES" ]; then | ||
13 | for i in $DEVICES; do | ||
14 | OPTIONS="$OPTIONS -I $i" | ||
15 | done | ||
16 | fi | ||
17 | if [ -n "$LOCAL_IP" ]; then | ||
18 | OPTIONS="$OPTIONS -L $LOCAL_IP" | ||
19 | fi | ||
20 | if [ -n "$REMOTE_IP" ]; then | ||
21 | OPTIONS="$OPTIONS -R $REMOTE_IP" | ||
22 | fi | ||
23 | if [ -n "$SERVICE_NAME" ]; then | ||
24 | OPTIONS="$OPTIONS -S $SERVICE_NAME" | ||
25 | fi | ||
26 | if [ -n "$MAX_SESSIONS" ]; then | ||
27 | OPTIONS="$OPTIONS -N $MAX_SESSIONS" | ||
28 | fi | ||
29 | if [ -n "$ACCESS_CONCENTRATOR_NAME" ]; then | ||
30 | OPTIONS="$OPTIONS -C $ACCESS_CONCENTRATOR_NAME" | ||
31 | fi | ||
32 | echo -n "Starting PPPoE server: pppoe-server" | ||
33 | start-stop-daemon --start --quiet --exec /usr/sbin/pppoe-server -- $OPTIONS | ||
34 | echo "." | ||
35 | ;; | ||
36 | stop) | ||
37 | echo -n "Stopping PPPoE server: pppoe-server" | ||
38 | start-stop-daemon --stop --quiet --exec /usr/sbin/pppoe-server -- $OPTIONS | ||
39 | echo "." | ||
40 | ;; | ||
41 | status) | ||
42 | pid=$(pidof pppoe-server) | ||
43 | if [ -n "$pid" ] ; then | ||
44 | echo "Running with pid $pid" | ||
45 | else | ||
46 | echo "Not running" | ||
47 | fi | ||
48 | ;; | ||
49 | restart|force-reload) | ||
50 | $0 stop | ||
51 | $0 start | ||
52 | ;; | ||
53 | *) | ||
54 | echo "Usage: /etc/init.d/pppoe-server {start|stop|restart|force-reload}" | ||
55 | exit 1 | ||
56 | ;; | ||
57 | esac | ||
58 | |||
59 | exit 0 | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-src-restrictions.patch b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-src-restrictions.patch new file mode 100644 index 000000000..e7e1c2ee3 --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/pppoe-src-restrictions.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | Relax restrictions on the PPPoE src address, as per debian bug | ||
2 | 293811: | ||
3 | |||
4 | http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=293811 | ||
5 | |||
6 | --- rp-pppoe-3.8.orig/src/discovery.c | ||
7 | +++ rp-pppoe-3.8/src/discovery.c | ||
8 | @@ -376,8 +376,8 @@ | ||
9 | if (!packetIsForMe(conn, &packet)) continue; | ||
10 | |||
11 | if (packet.code == CODE_PADO) { | ||
12 | - if (NOT_UNICAST(packet.ethHdr.h_source)) { | ||
13 | - printErr("Ignoring PADO packet from non-unicast MAC address"); | ||
14 | + if (BROADCAST(packet.ethHdr.h_source)) { | ||
15 | + printErr("Ignoring broadcast PADO packet"); | ||
16 | continue; | ||
17 | } | ||
18 | parsePacket(&packet, parsePADOTags, &pc); | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch new file mode 100644 index 000000000..e3b048298 --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | The autoconf stuff is all in a subdirectory, which is rather annoying | ||
2 | as OE expects patches to be applied and autoconf stuff to be done in | ||
3 | S. This adds enough autoconf at the top level to allow it to be | ||
4 | called there - all it does is run a sub autoconf stuff in the src | ||
5 | directory. | ||
6 | |||
7 | Index: rp-pppoe-3.8/Makefile.am | ||
8 | =================================================================== | ||
9 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
10 | +++ rp-pppoe-3.8/Makefile.am 2007-06-08 15:58:16.000000000 +1000 | ||
11 | @@ -0,0 +1,5 @@ | ||
12 | +PACKAGE = rp-pppoe | ||
13 | +VERSION = 3.8 | ||
14 | + | ||
15 | +dnl AM_CFLAGS = -Wall -DDEBUG | ||
16 | +SUBDIRS = src | ||
17 | Index: rp-pppoe-3.8/configure.in | ||
18 | =================================================================== | ||
19 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
20 | +++ rp-pppoe-3.8/configure.in 2007-06-08 15:58:16.000000000 +1000 | ||
21 | @@ -0,0 +1,4 @@ | ||
22 | +AC_INIT(src/pppoe.c) | ||
23 | +AM_INIT_AUTOMAKE([rp-pppoe], [3.8]) | ||
24 | +AC_CONFIG_SUBDIRS(src) | ||
25 | +AC_OUTPUT(Makefile) | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/update-config.patch b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/update-config.patch new file mode 100644 index 000000000..5642e3cfe --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/update-config.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | Set the timeout to 0 since we don't want pppoe to try reconnecting, | ||
2 | we want whatever is calling it to reconnect. Lots of odd things | ||
3 | happen when you have pppoe retrying itself. | ||
4 | |||
5 | The path for the plugin is wrong, it's now part of ppp and is in a | ||
6 | ppp's plugin lib directory. If no path is specified then that's where | ||
7 | ppp looks, so that's what we do here. | ||
8 | |||
9 | Index: rp-pppoe-3.8/configs/pppoe.conf | ||
10 | =================================================================== | ||
11 | --- rp-pppoe-3.8.orig/configs/pppoe.conf 2006-04-03 00:29:41.000000000 +1000 | ||
12 | +++ rp-pppoe-3.8/configs/pppoe.conf 2007-06-08 16:02:47.000000000 +1000 | ||
13 | @@ -66,7 +66,7 @@ | ||
14 | # to connect forever after pppoe-start is called. Otherwise, it will | ||
15 | # give out after CONNECT_TIMEOUT seconds and will not attempt to | ||
16 | # connect again, making it impossible to reach. | ||
17 | -CONNECT_TIMEOUT=30 | ||
18 | +CONNECT_TIMEOUT=0 | ||
19 | |||
20 | # How often in seconds pppoe-start polls to check if link is up | ||
21 | CONNECT_POLL=2 | ||
22 | @@ -115,7 +115,7 @@ | ||
23 | FIREWALL=NONE | ||
24 | |||
25 | # Linux kernel-mode plugin for pppd. If you want to try the kernel-mode | ||
26 | -# plugin, use LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so | ||
27 | +# plugin, use LINUX_PLUGIN=rp-pppoe.so | ||
28 | LINUX_PLUGIN= | ||
29 | |||
30 | # Any extra arguments to pass to pppoe. Normally, use a blank string | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch new file mode 100644 index 000000000..120963133 --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | --- a/src/Makefile.in 2006-04-02 18:29:42.000000000 +0400 | ||
2 | +++ b/src/Makefile.in 2010-04-16 17:51:31.000000000 +0400 | ||
3 | @@ -67,16 +67,16 @@ all: $(TARGETS) | ||
4 | @echo "Type 'make install' as root to install the software." | ||
5 | |||
6 | pppoe-sniff: pppoe-sniff.o if.o common.o debug.o | ||
7 | - @CC@ -o pppoe-sniff pppoe-sniff.o if.o common.o debug.o | ||
8 | + @CC@ -o pppoe-sniff pppoe-sniff.o if.o common.o debug.o $(LDFLAGS) | ||
9 | |||
10 | pppoe-server: pppoe-server.o if.o debug.o common.o md5.o libevent/libevent.a @PPPOE_SERVER_DEPS@ | ||
11 | - @CC@ -o pppoe-server @RDYNAMIC@ pppoe-server.o if.o debug.o common.o md5.o $(PPPOE_SERVER_LIBS) -Llibevent -levent | ||
12 | + @CC@ -o pppoe-server @RDYNAMIC@ pppoe-server.o if.o debug.o common.o md5.o $(PPPOE_SERVER_LIBS) -Llibevent -levent $(LDFLAGS) | ||
13 | |||
14 | pppoe: pppoe.o if.o debug.o common.o ppp.o discovery.o | ||
15 | - @CC@ -o pppoe pppoe.o if.o debug.o common.o ppp.o discovery.o | ||
16 | + @CC@ -o pppoe pppoe.o if.o debug.o common.o ppp.o discovery.o $(LDFLAGS) | ||
17 | |||
18 | pppoe-relay: relay.o if.o debug.o common.o | ||
19 | - @CC@ -o pppoe-relay relay.o if.o debug.o common.o | ||
20 | + @CC@ -o pppoe-relay relay.o if.o debug.o common.o $(LDFLAGS) | ||
21 | |||
22 | pppoe.o: pppoe.c pppoe.h | ||
23 | @CC@ $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o pppoe.o pppoe.c | ||
diff --git a/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe_3.8.bb b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe_3.8.bb new file mode 100644 index 000000000..371d82eac --- /dev/null +++ b/meta-oe/recipes-connectivity/rp-pppoe/rp-pppoe_3.8.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | DESCRIPTION = "A user-mode PPPoE client and server suite for Linux" | ||
2 | HOMEPAGE = "http://www.roaringpenguin.com/en/penguin/openSourceProducts/rpPppoe" | ||
3 | SECTION = "console/network" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=a194eaefae2be54ee3221339b10d0581" | ||
6 | RDEPENDS_${PN} = "ppp" | ||
7 | RDEPENDS_${PN}-server = "${PN}" | ||
8 | RRECOMMENDS_${PN} = "ppp-oe" | ||
9 | PR = "r7" | ||
10 | |||
11 | SRC_URI = "http://www.roaringpenguin.com/files/download/${P}.tar.gz \ | ||
12 | file://top-autoconf.patch \ | ||
13 | file://configure_in_cross.patch \ | ||
14 | file://pppoe-src-restrictions.patch \ | ||
15 | file://update-config.patch \ | ||
16 | file://dont-swallow-errors.patch \ | ||
17 | file://use-ldflags.patch \ | ||
18 | file://pppoe-server.default \ | ||
19 | file://pppoe-server.init" | ||
20 | |||
21 | inherit autotools update-rc.d | ||
22 | |||
23 | do_install() { | ||
24 | # Install init script and default settings | ||
25 | install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d | ||
26 | install -m 0644 ${WORKDIR}/pppoe-server.default ${D}${sysconfdir}/default/pppoe-server | ||
27 | install -m 0755 ${WORKDIR}/pppoe-server.init ${D}${sysconfdir}/init.d/pppoe-server | ||
28 | # Install | ||
29 | oe_runmake -C ${S} RPM_INSTALL_ROOT=${D} docdir=${docdir} install | ||
30 | } | ||
31 | |||
32 | # Insert server package before main package | ||
33 | PACKAGES = "${PN}-dbg ${PN}-server ${PN}-relay ${PN}-sniff ${PN} ${PN}-doc" | ||
34 | |||
35 | FILES_${PN}-server = "${sysconfdir}/default/pppoe-server \ | ||
36 | ${sysconfdir}/init.d/pppoe-server \ | ||
37 | ${sbindir}/pppoe-server \ | ||
38 | ${sysconfdir}/ppp/pppoe-server-options" | ||
39 | FILES_${PN}-relay = "${sbindir}/pppoe-relay" | ||
40 | FILES_${PN}-sniff = "${sbindir}/pppoe-sniff" | ||
41 | |||
42 | pkg_postinst_${PN} () { | ||
43 | if [ x"$D" != "x" ]; then | ||
44 | exit 1 | ||
45 | fi | ||
46 | chmod 4755 ${sbindir}/pppoe | ||
47 | } | ||
48 | |||
49 | CONFFILES_${PN} = "${sysconfdir}/ppp/pppoe.conf \ | ||
50 | ${sysconfdir}/ppp/firewall-standalone \ | ||
51 | ${sysconfdir}/ppp/firewall-masq" | ||
52 | CONFFILES_${PN}-server = "${sysconfdir}/ppp/pppoe-server-options \ | ||
53 | ${sysconfdir}/default/pppoe-server" | ||
54 | |||
55 | INITSCRIPT_PACKAGES = "${PN}-server" | ||
56 | INITSCRIPT_NAME_${PN}-server = "pppoe-server" | ||
57 | INITSCRIPT_PARAMS_${PN}-server = "defaults 92 8" | ||
58 | |||
59 | |||
60 | SRC_URI[md5sum] = "0e32760f498f9cde44081ee6aafc823b" | ||
61 | SRC_URI[sha256sum] = "d916e9cfe1e62395f63a5361936fa855f6d0f0a37dc7227b394cdb725f553479" | ||
diff --git a/meta-oe/site/endian-big b/meta-oe/site/endian-big new file mode 100644 index 000000000..3a968e326 --- /dev/null +++ b/meta-oe/site/endian-big | |||
@@ -0,0 +1,2 @@ | |||
1 | # rp-pppoe | ||
2 | rpppoe_cv_pack_bitfields=${rpppoe_cv_pack_bitfields=normal} | ||
diff --git a/meta-oe/site/endian-little b/meta-oe/site/endian-little new file mode 100644 index 000000000..0bcd966ea --- /dev/null +++ b/meta-oe/site/endian-little | |||
@@ -0,0 +1,2 @@ | |||
1 | # rp-pppoe | ||
2 | rpppoe_cv_pack_bitfields=${rpppoe_cv_pack_bitfields=rev} | ||