summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
index 4e1ba1f72..81b8c0d23 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
@@ -61,20 +61,17 @@ do_install_append_class-native() {
61 # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js 61 # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js
62 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and 62 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and
63 # npm-cli.js continues to use old shebang 63 # npm-cli.js continues to use old shebang
64 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${libdir}/node_modules/npm/bin/npm-cli.js 64 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
65} 65}
66 66
67do_install_append_class-target() { 67do_install_append_class-target() {
68 sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${libdir}/node_modules/npm/bin/npm-cli.js 68 sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
69} 69}
70 70
71PACKAGES =+ "${PN}-npm" 71PACKAGES =+ "${PN}-npm"
72FILES_${PN}-npm = "${libdir}/node_modules ${bindir}/npm" 72FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm"
73RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils" 73RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils"
74 74
75PACKAGES =+ "${PN}-dtrace"
76FILES_${PN}-dtrace = "${libdir}/dtrace"
77
78PACKAGES =+ "${PN}-systemtap" 75PACKAGES =+ "${PN}-systemtap"
79FILES_${PN}-systemtap = "${datadir}/systemtap" 76FILES_${PN}-systemtap = "${datadir}/systemtap"
80 77