diff options
11 files changed, 9 insertions, 281 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch deleted file mode 100644 index 82ac5aa6e..000000000 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From c30716be9e615513fe66993fd3cdc818c3d70410 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary E. Miller" <gem@rellim.com> | ||
3 | Date: Sun, 15 Mar 2015 11:51:45 -0700 | ||
4 | Subject: [PATCH 1/3] Check for __STDC_NO_ATOMICS__ before using stdatomic.h | ||
5 | |||
6 | --- | ||
7 | SConstruct | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/SConstruct b/SConstruct | ||
11 | index adf473d..566c14a 100644 | ||
12 | --- a/SConstruct | ||
13 | +++ b/SConstruct | ||
14 | @@ -633,7 +633,7 @@ else: | ||
15 | announce("You do not have kernel CANbus available.") | ||
16 | env["nmea2000"] = False | ||
17 | |||
18 | - if config.CheckHeader("stdatomic.h"): | ||
19 | + if not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
20 | confdefs.append("#define HAVE_STDATOMIC_H 1\n") | ||
21 | else: | ||
22 | confdefs.append("/* #undef HAVE_STDATOMIC_H */\n") | ||
23 | -- | ||
24 | 2.1.0 | ||
25 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Include-stdatomic.h-only-in-C-mode.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Include-stdatomic.h-only-in-C-mode.patch deleted file mode 100644 index bc9167eee..000000000 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-Include-stdatomic.h-only-in-C-mode.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From 79f6d9133378325d70a92e66f7352c1becefbb88 Mon Sep 17 00:00:00 2001 | ||
2 | From: Gleb Smirnoff <glebius@FreeBSD.org> | ||
3 | Date: Sat, 16 May 2015 02:47:28 +0300 | ||
4 | Subject: [PATCH] Include <stdatomic.h> only in C mode. | ||
5 | |||
6 | Upstream-Status: Backport from 3.15 | ||
7 | |||
8 | Without this build with gcc-5.2 fails with: | ||
9 | | arm-oe-linux-gnueabi-g++ -march=armv4t -mthumb -mthumb-interwork -mtune=arm920t --sysroot=/OE/build/shr-core/tmp-glibc/sysroots/om-gta02 -o clock_gettime-qt.os -c -O2 -pipe -g -feliminate-unused-debug-types --sysroot=/OE/build/shr-core/tmp-glibc/sysroots/om-gta02 -Wextra -Wall -Wno-uninitialized -Wno-missing-field-initializers -Wcast-align -Wmissing-declarations -Wpointer-arith -Wreturn-type -pthread -Wmissing-declarations -g -O0 -pthread -fPIC -DUSE_QT -DQT_SHARED -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/dbus-1.0 -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/lib/dbus-1.0/include -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/qt4/QtNetwork -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/qt4 -I/OE/build/shr-core/tmp-glibc/sysroots/om-gta02/usr/include/qt4/QtCore clock_gettime.c | ||
10 | | In file included from compiler.h:50:0, | ||
11 | | from clock_gettime.c:10: | ||
12 | | /OE/build/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/lib/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/5.2.0/include/stdatomic.h:40:9: error: '_Atomic' does not name a type | ||
13 | | typedef _Atomic _Bool atomic_bool; | ||
14 | | ^ | ||
15 | .... | ||
16 | |||
17 | More info: | ||
18 | https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 | ||
19 | |||
20 | Signed-off-by: Gary E. Miller <gem@rellim.com> | ||
21 | --- | ||
22 | compiler.h | 4 ++-- | ||
23 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
24 | |||
25 | diff --git a/compiler.h b/compiler.h | ||
26 | index 837c935..03430c0 100644 | ||
27 | --- a/compiler.h | ||
28 | +++ b/compiler.h | ||
29 | @@ -66,9 +66,9 @@ | ||
30 | } while (0) | ||
31 | |||
32 | #ifdef HAVE_STDATOMIC_H | ||
33 | -#ifndef __COVERITY__ /* Coverity is confused by a GNU typedef */ | ||
34 | +#if !defined(__COVERITY__) && !defined(__cplusplus) | ||
35 | #include <stdatomic.h> | ||
36 | -#endif /* __COVERITY__ */ | ||
37 | +#endif /* __COVERITY__ || __cplusplus */ | ||
38 | #endif /* HAVE_STDATOMIC_H */ | ||
39 | |||
40 | #ifdef HAVE_OSATOMIC_H | ||
41 | -- | ||
42 | 2.5.1 | ||
43 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch deleted file mode 100644 index c4134f4b5..000000000 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | From 3c5fb3a8691ac711ea93edf8e0b42bffc62b197e Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Tue, 24 Apr 2012 11:52:35 +0200 | ||
4 | Subject: [PATCH 1/4] SConstruct: respect sysroot also in SPLINTOPTS | ||
5 | |||
6 | Upstream-Status: Inappropriate [embedded specific] | ||
7 | |||
8 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
9 | Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> | ||
10 | Signed-off-by: Peter A. Bigot <pab@pabigot.com> | ||
11 | --- | ||
12 | SConstruct | 5 ++++- | ||
13 | 1 file changed, 4 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/SConstruct b/SConstruct | ||
16 | index 14e2f59..f0cafa8 100644 | ||
17 | --- a/SConstruct | ||
18 | +++ b/SConstruct | ||
19 | @@ -1414,7 +1414,10 @@ def Utility(target, source, action): | ||
20 | # Report splint warnings | ||
21 | # Note: test_bits.c is unsplintable because of the PRI64 macros. | ||
22 | # If you get preprocessor or fatal errors, add +showscan. | ||
23 | -splintopts = "-I/usr/include/libusb-1.0 +quiet" | ||
24 | +if not env['sysroot']: | ||
25 | + splintopts = "-I/usr/include/libusb-1.0 +quiet" | ||
26 | +else: | ||
27 | + splintopts = "-I%s/usr/include/libusb-1.0 +quiet" % env['sysroot'] | ||
28 | # splint does not know about multi-arch, work around that | ||
29 | ma_status, ma = _getstatusoutput('dpkg-architecture -qDEB_HOST_MULTIARCH') | ||
30 | if ma_status == 0: | ||
31 | -- | ||
32 | 1.8.5.5 | ||
33 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch deleted file mode 100644 index 7a0679505..000000000 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | From 6ff099b1ba8de74df9ddeb61e3825264b96ef692 Mon Sep 17 00:00:00 2001 | ||
2 | From: Moritz Fischer <moritz.fischer@ettus.com> | ||
3 | Date: Tue, 22 Dec 2015 19:38:31 -0800 | ||
4 | Subject: [PATCH] libgpsd-core: Fix issue with ACTIVATE hook not being called. | ||
5 | |||
6 | In the current system session->mode seemed to ignore the | ||
7 | O_OPTIMIZE flag, leading to the ACTIVATE hook being ignored. | ||
8 | |||
9 | Another way to fix this would be to keep the session->mode | ||
10 | condition pull up the check for O_CONTINUE. | ||
11 | |||
12 | Upstream-Status: Backported | ||
13 | This patch is in upstream git | ||
14 | |||
15 | Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> | ||
16 | --- | ||
17 | libgpsd_core.c | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/libgpsd_core.c b/libgpsd_core.c | ||
21 | index 31fec2a..a84e85f 100644 | ||
22 | --- a/libgpsd_core.c | ||
23 | +++ b/libgpsd_core.c | ||
24 | @@ -543,7 +543,7 @@ int gpsd_open(struct gps_device_t *session) | ||
25 | int gpsd_activate(struct gps_device_t *session, const int mode) | ||
26 | /* acquire a connection to the GPS device */ | ||
27 | { | ||
28 | - if (session->mode == O_OPTIMIZE) | ||
29 | + if (mode == O_OPTIMIZE) | ||
30 | gpsd_run_device_hook(&session->context->errout, | ||
31 | session->gpsdata.dev.path, "ACTIVATE"); | ||
32 | session->gpsdata.gps_fd = gpsd_open(session); | ||
33 | -- | ||
34 | 2.4.3 | ||
35 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch deleted file mode 100644 index 22ee1bdcf..000000000 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From 99444b3d2c4a4f7fd7128e60461005780d0c5c83 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary E. Miller" <gem@rellim.com> | ||
3 | Date: Sun, 15 Mar 2015 12:05:15 -0700 | ||
4 | Subject: [PATCH 2/3] Add a test for C11 and check we have C11 before using | ||
5 | stdatomic.h | ||
6 | |||
7 | --- | ||
8 | SConstruct | 19 ++++++++++++++++++- | ||
9 | 1 file changed, 18 insertions(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/SConstruct b/SConstruct | ||
12 | index 566c14a..faa8651 100644 | ||
13 | --- a/SConstruct | ||
14 | +++ b/SConstruct | ||
15 | @@ -473,6 +473,20 @@ def CheckCompilerDefines(context, define): | ||
16 | context.Result(ret) | ||
17 | return ret | ||
18 | |||
19 | +# Check if this compiler is C11 or better | ||
20 | +def CheckC11(context): | ||
21 | + context.Message( 'Checking if compiler is C11 ...' ) | ||
22 | + ret = context.TryLink(""" | ||
23 | + #if (__STDC_VERSION__ < 201112L) | ||
24 | + #error Not C11 | ||
25 | + #endif | ||
26 | + int main(int argc, char **argv) { | ||
27 | + return 0; | ||
28 | + } | ||
29 | + """,'.c') | ||
30 | + context.Result(ret) | ||
31 | + return ret | ||
32 | + | ||
33 | def GetLoadPath(context): | ||
34 | context.Message("Getting system load path ...") | ||
35 | |||
36 | @@ -491,6 +505,7 @@ else: | ||
37 | 'CheckXsltproc' : CheckXsltproc, | ||
38 | 'CheckCompilerOption' : CheckCompilerOption, | ||
39 | 'CheckCompilerDefines' : CheckCompilerDefines, | ||
40 | + 'CheckC11' : CheckC11, | ||
41 | 'CheckHeaderDefines' : CheckHeaderDefines}) | ||
42 | |||
43 | |||
44 | @@ -633,7 +648,9 @@ else: | ||
45 | announce("You do not have kernel CANbus available.") | ||
46 | env["nmea2000"] = False | ||
47 | |||
48 | - if not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
49 | + # check for C11 or better, and __STDC__NO_ATOMICS__ is no defined | ||
50 | + # before looking for stdatomic.h | ||
51 | + if not config.CheckC11() and not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
52 | confdefs.append("#define HAVE_STDATOMIC_H 1\n") | ||
53 | else: | ||
54 | confdefs.append("/* #undef HAVE_STDATOMIC_H */\n") | ||
55 | -- | ||
56 | 2.1.0 | ||
57 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-SConstruct-remove-rpath.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-SConstruct-remove-rpath.patch deleted file mode 100644 index 083a6621f..000000000 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0002-SConstruct-remove-rpath.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From d090638ff983e509162d5e3b62aa4918de4aa5fa Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Tue, 24 Apr 2012 16:24:35 +0200 | ||
4 | Subject: [PATCH 2/4] SConstruct: remove rpath | ||
5 | |||
6 | * even with correct prefix (without DESTDIR) included it's redundant | ||
7 | WARNING: QA Issue: libgps: | ||
8 | /work/armv4t-oe-linux-gnueabi/gpsd/gpsd-3.5-r0/packages-split/libgps/usr/lib/libgps.so.20.0 | ||
9 | contains probably-redundant RPATH /usr/lib | ||
10 | * and with prefix from scons.bbclass it's invalid | ||
11 | WARNING: QA Issue: package libgps contains bad RPATH | ||
12 | /OE/shr-core/tmp-eglibc/work/armv4t-oe-linux-gnueabi/gpsd/gpsd-3.5-r0/image/usr/lib | ||
13 | in file | ||
14 | /OE/shr-core/tmp-eglibc/work/armv4t-oe-linux-gnueabi/gpsd/gpsd-3.5-r0/packages-split/libgps/usr/lib/libgps.so.20.0 | ||
15 | |||
16 | Upstream-Status: Inapppropriate [embedded specific] | ||
17 | |||
18 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
19 | Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> | ||
20 | Signed-off-by: Peter A. Bigot <pab@pabigot.com> | ||
21 | --- | ||
22 | SConstruct | 7 +++++-- | ||
23 | 1 file changed, 5 insertions(+), 2 deletions(-) | ||
24 | |||
25 | diff --git a/SConstruct b/SConstruct | ||
26 | index f0cafa8..ff46713 100644 | ||
27 | --- a/SConstruct | ||
28 | +++ b/SConstruct | ||
29 | @@ -1340,8 +1340,11 @@ if qt_env: | ||
30 | binaryinstall.append(LibraryInstall(qt_env, installdir('libdir'), compiled_qgpsmmlib)) | ||
31 | |||
32 | if env["shared"] and env["chrpath"]: | ||
33 | - env.AddPostAction(binaryinstall, '$CHRPATH -r "%s" "$TARGET"' \ | ||
34 | - % (installdir('libdir', False), )) | ||
35 | + if not env['sysroot']: | ||
36 | + env.AddPostAction(binaryinstall, '$CHRPATH -r "%s" "$TARGET"' \ | ||
37 | + % (installdir('libdir', False), )) | ||
38 | + else: | ||
39 | + env.AddPostAction(binaryinstall, '$CHRPATH -d "$TARGET"') | ||
40 | |||
41 | if not env['debug'] and not env['profiling'] and env['strip']: | ||
42 | env.AddPostAction(binaryinstall, '$STRIP $TARGET') | ||
43 | -- | ||
44 | 1.8.5.5 | ||
45 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch deleted file mode 100644 index 8bb0928ce..000000000 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 674c50ee54fd7cd304e8b3c4b33d3ff1272ed191 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary E. Miller" <gem@rellim.com> | ||
3 | Date: Sun, 15 Mar 2015 12:17:51 -0700 | ||
4 | Subject: [PATCH 3/3] Whoops, check for C11, not for not C11 in stdatomic.h | ||
5 | test. | ||
6 | |||
7 | --- | ||
8 | SConstruct | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/SConstruct b/SConstruct | ||
12 | index faa8651..f4ea145 100644 | ||
13 | --- a/SConstruct | ||
14 | +++ b/SConstruct | ||
15 | @@ -650,7 +650,7 @@ else: | ||
16 | |||
17 | # check for C11 or better, and __STDC__NO_ATOMICS__ is no defined | ||
18 | # before looking for stdatomic.h | ||
19 | - if not config.CheckC11() and not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
20 | + if config.CheckC11() and not config.CheckCompilerDefines("__STDC_NO_ATOMICS__") and config.CheckHeader("stdatomic.h"): | ||
21 | confdefs.append("#define HAVE_STDATOMIC_H 1\n") | ||
22 | else: | ||
23 | confdefs.append("/* #undef HAVE_STDATOMIC_H */\n") | ||
24 | -- | ||
25 | 2.1.0 | ||
26 | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch index 2ea3226a4..2ea3226a4 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-include-sys-ttydefaults.h.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-include-sys-ttydefaults.h.patch index b27c67144..f496b5e7d 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-include-sys-ttydefaults.h.patch +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0001-include-sys-ttydefaults.h.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 543f79222520cc6ab65d20f9fa356dac5c848e3b Mon Sep 17 00:00:00 2001 | 1 | From f221fa959c80b43c65426500a6836a1b5cf6fe0c Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 17 Aug 2016 02:16:12 +0000 | 3 | Date: Wed, 17 Aug 2016 02:16:12 +0000 |
4 | Subject: [PATCH] include sys/ttydefaults.h | 4 | Subject: [PATCH] include sys/ttydefaults.h |
@@ -11,14 +11,15 @@ clang-3.9: error: linker command failed with exit code 1 (use -v to see invocati | |||
11 | scons: *** [gpsmon] Error 1 | 11 | scons: *** [gpsmon] Error 1 |
12 | 12 | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
14 | --- | ||
15 | Upstream-Status: Pending | ||
16 | 14 | ||
15 | Foreward port to gpsd 3.16 | ||
16 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
17 | --- | ||
17 | gpsmon.c | 1 + | 18 | gpsmon.c | 1 + |
18 | 1 file changed, 1 insertion(+) | 19 | 1 file changed, 1 insertion(+) |
19 | 20 | ||
20 | diff --git a/gpsmon.c b/gpsmon.c | 21 | diff --git a/gpsmon.c b/gpsmon.c |
21 | index bee05b8..daed818 100644 | 22 | index ead84d0..f205cb1 100644 |
22 | --- a/gpsmon.c | 23 | --- a/gpsmon.c |
23 | +++ b/gpsmon.c | 24 | +++ b/gpsmon.c |
24 | @@ -20,6 +20,7 @@ | 25 | @@ -20,6 +20,7 @@ |
@@ -27,8 +28,8 @@ index bee05b8..daed818 100644 | |||
27 | #include <sys/select.h> | 28 | #include <sys/select.h> |
28 | +#include <sys/ttydefaults.h> | 29 | +#include <sys/ttydefaults.h> |
29 | #include <fcntl.h> | 30 | #include <fcntl.h> |
30 | #ifndef S_SPLINT_S | ||
31 | #include <unistd.h> | 31 | #include <unistd.h> |
32 | |||
32 | -- | 33 | -- |
33 | 1.8.3.1 | 34 | 2.12.0 |
34 | 35 | ||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch index 8527f0db3..8527f0db3 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch +++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.16/0004-SConstruct-disable-html-and-man-docs-building-becaus.patch | |||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb index fb02f9598..27a600f70 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb | |||
@@ -8,23 +8,16 @@ PROVIDES = "virtual/gpsd" | |||
8 | EXTRANATIVEPATH += "chrpath-native" | 8 | EXTRANATIVEPATH += "chrpath-native" |
9 | 9 | ||
10 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ | 10 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ |
11 | file://0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \ | ||
12 | file://0002-SConstruct-remove-rpath.patch \ | ||
13 | file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ | 11 | file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \ |
14 | file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \ | 12 | file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \ |
15 | file://0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch \ | ||
16 | file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \ | ||
17 | file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \ | ||
18 | file://0001-Include-stdatomic.h-only-in-C-mode.patch \ | ||
19 | file://0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch \ | ||
20 | file://0001-include-sys-ttydefaults.h.patch \ | 13 | file://0001-include-sys-ttydefaults.h.patch \ |
21 | file://gpsd-default \ | 14 | file://gpsd-default \ |
22 | file://gpsd \ | 15 | file://gpsd \ |
23 | file://60-gpsd.rules \ | 16 | file://60-gpsd.rules \ |
24 | file://gpsd.service \ | 17 | file://gpsd.service \ |
25 | " | 18 | " |
26 | SRC_URI[md5sum] = "bc7467009b99e07ba461377b5da6c039" | 19 | SRC_URI[md5sum] = "68691b5de4c94f82ec4062b042b5eb63" |
27 | SRC_URI[sha256sum] = "504fc812f3c1525a1a48e04bf4d77f9a8066c201448d98089df89d58ef53a8cb" | 20 | SRC_URI[sha256sum] = "03579af13a4d3fe0c5b79fa44b5f75c9f3cac6749357f1d99ce5d38c09bc2029" |
28 | 21 | ||
29 | inherit scons update-rc.d python-dir pythonnative systemd bluetooth | 22 | inherit scons update-rc.d python-dir pythonnative systemd bluetooth |
30 | 23 | ||
@@ -36,8 +29,6 @@ SYSTEMD_OESCONS = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'f | |||
36 | export STAGING_INCDIR | 29 | export STAGING_INCDIR |
37 | export STAGING_LIBDIR | 30 | export STAGING_LIBDIR |
38 | 31 | ||
39 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" | ||
40 | |||
41 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" | 32 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" |
42 | PACKAGECONFIG[bluez] = "bluez='true',bluez='false',${BLUEZ}" | 33 | PACKAGECONFIG[bluez] = "bluez='true',bluez='false',${BLUEZ}" |
43 | PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free" | 34 | PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free" |