summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Set-_supported_filesystems-in-BlivetGUIAnaconda-init.patch39
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.8.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Set-_supported_filesystems-in-BlivetGUIAnaconda-init.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Set-_supported_filesystems-in-BlivetGUIAnaconda-init.patch
new file mode 100644
index 000000000..25a71d4a7
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Set-_supported_filesystems-in-BlivetGUIAnaconda-init.patch
@@ -0,0 +1,39 @@
1From a7b76f783608033e449ba1e33d040c2b40c01a4d Mon Sep 17 00:00:00 2001
2From: Adam Williamson <awilliam@redhat.com>
3Date: Wed, 17 Jan 2018 10:38:18 -0800
4Subject: [PATCH] Set _supported_filesystems in BlivetGUIAnaconda init
5
6BlivetGUIAnaconda subclasses BlivetGUI, but doesn't call the
7parent class's __init__. c4b6e174 added supported_filesystems
8to BlivetGUI and set _supported_filesystems for caching during
9__init__, but this was not also added to BlivetGUIAnaconda, so
10when anything tries to use the supported_filesystems property
11of a BlivetGUIAnaconda instance, it will crash. This is causing
12all attempts to use blivet-gui in anaconda to crash since 2.1.8
13landed in Rawhide.
14
15Upstream-Status: Backport [https://github.com/storaged-project/blivet-gui]
16
17Signed-off-by: Adam Williamson <awilliam@redhat.com>
18Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
19---
20 blivetgui/osinstall.py | 3 +++
21 1 file changed, 3 insertions(+)
22
23diff --git a/blivetgui/osinstall.py b/blivetgui/osinstall.py
24index 21806ca..32ff66b 100644
25--- a/blivetgui/osinstall.py
26+++ b/blivetgui/osinstall.py
27@@ -94,6 +94,9 @@ class BlivetGUIAnaconda(BlivetGUI):
28 self.builder.set_translation_domain("blivet-gui")
29 self.builder.add_from_file(locate_ui_file("blivet-gui.ui"))
30
31+ # supported filesystems
32+ self._supported_filesystems = []
33+
34 # CSS styles
35 css_provider = Gtk.CssProvider()
36 css_provider.load_from_path(locate_css_file("rectangle.css"))
37--
382.20.1
39
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.8.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.8.bb
index 91f0dff71..5f62b9e5c 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.8.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.8.bb
@@ -10,6 +10,7 @@ B = "${S}"
10 10
11SRCREV = "a4fd427ee2acc5a8f5fb030bf7816917cee63bd8" 11SRCREV = "a4fd427ee2acc5a8f5fb030bf7816917cee63bd8"
12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \ 12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
13 file://0001-Set-_supported_filesystems-in-BlivetGUIAnaconda-init.patch \
13" 14"
14 15
15inherit distro_features_check 16inherit distro_features_check