diff options
3 files changed, 18 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyinotify.inc b/meta-python/recipes-devtools/python/python-pyinotify.inc new file mode 100644 index 000000000..285fe332b --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyinotify.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/pyinotify" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382" | ||
6 | |||
7 | RDEPENDS_${PN} += "python-threading python-io python-subprocess python-misc python-shell" | ||
8 | |||
9 | SRCNAME = "pyinotify" | ||
10 | SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406" | ||
13 | SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4" | ||
14 | |||
15 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
diff --git a/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb index 42956ce42..d1f84c3ca 100644 --- a/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb +++ b/meta-python/recipes-devtools/python/python-pyinotify_0.9.6.bb | |||
@@ -1,17 +1,2 @@ | |||
1 | DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/pyinotify" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382" | ||
6 | |||
7 | RDEPENDS_${PN} += "python-threading python-io python-subprocess python-misc python-shell" | ||
8 | |||
9 | SRCNAME = "pyinotify" | ||
10 | SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406" | ||
13 | SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4" | ||
14 | |||
15 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
16 | |||
17 | inherit setuptools | 1 | inherit setuptools |
2 | require python-pyinotify.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb b/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb new file mode 100644 index 000000000..b3bab989a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pyinotify.inc | ||