summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pexpect.inc25
-rw-r--r--meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb2
3 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pexpect.inc b/meta-python/recipes-devtools/python/python-pexpect.inc
new file mode 100644
index 000000000..47d09796d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pexpect.inc
@@ -0,0 +1,25 @@
1SUMMARY = "A Pure Python Expect like Module for Python"
2HOMEPAGE = "http://pexpect.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1c7a725251880af8c6a148181665385b"
6
7SRCNAME = "pexpect"
8
9SRC_URI[md5sum] = "3694410001a99dff83f0b500a1ca1c95"
10SRC_URI[sha256sum] = "3d132465a75b57aa818341c6521392a06cc660feb3988d7f1074f39bd23c9a92"
11
12UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16RDEPENDS_${PN} = "\
17 ${PYTHON_PN}-core \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-terminal \
20 ${PYTHON_PN}-resource \
21 ${PYTHON_PN}-fcntl \
22 ${PYTHON_PN}-ptyprocess \
23"
24
25BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb b/meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb
new file mode 100644
index 000000000..1c46b47a2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb
@@ -0,0 +1,2 @@
1require python-pexpect.inc
2inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb b/meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb
new file mode 100644
index 000000000..cf39233a3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb
@@ -0,0 +1,2 @@
1require python-pexpect.inc
2inherit pypi setuptools3