summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-perl/recipes-perl/libdevel/libdevel-globaldestruction-perl_0.13.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libdevel/libdevel-globaldestruction-perl_0.13.bb b/meta-perl/recipes-perl/libdevel/libdevel-globaldestruction-perl_0.13.bb
new file mode 100644
index 000000000..1a593cfdb
--- /dev/null
+++ b/meta-perl/recipes-perl/libdevel/libdevel-globaldestruction-perl_0.13.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Function returning \"${^GLOBAL_PHASE} eq \'DESTRUCT\'\""
2DESCRIPTION = "Perl's global destruction is a little trick to deal with \
3WRT finalizers because it's not ordered and objects can sometimes disappear."
4
5SECTION = "libs"
6
7HOMEPAGE = "https://metacpan.org/pod/Devel-GlobalDestruction/"
8
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://README;beginline=53;endline=55;md5=935dadb9423774f53548e5cd5055d41a"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/Devel-GlobalDestruction-${PV}.tar.gz"
13SRC_URI[md5sum] = "e7be00040827e204b2b6cba2f3166074"
14SRC_URI[sha256sum] = "b29824dc0d322e56da325f05185367eb443694716010b36693dd52ffbe8ec462"
15
16S = "${WORKDIR}/Devel-GlobalDestruction-${PV}"
17
18inherit cpan
19
20RDEPENDS_${PN} = " libsub-exporter-progressive-perl \
21"
22
23BBCLASSEXTEND = "native"