summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-python/recipes-devtools/python/python-pyyaml.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-pyyaml/setup.py64
-rwxr-xr-x[-rw-r--r--]meta-python/recipes-devtools/python/python-pyyaml_3.12.bb26
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-pyyaml_3.12.bb2
4 files changed, 18 insertions, 88 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyyaml.inc b/meta-python/recipes-devtools/python/python-pyyaml.inc
new file mode 100755
index 000000000..41321ca40
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyyaml.inc
@@ -0,0 +1,14 @@
1SUMMARY = "Python support for YAML"
2HOMEPAGE = "http://www.pyyaml.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
6DEPENDS = "libyaml ${PYTHON_PN}-cython-native"
7
8PYPI_PACKAGE = "PyYAML"
9inherit pypi
10
11SRC_URI[md5sum] = "4c129761b661d181ebf7ff4eb2d79950"
12SRC_URI[sha256sum] = "592766c6303207a20efc445587778322d7f73b161bd994f227adaa341ba212ab"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pyyaml/setup.py b/meta-python/recipes-devtools/python/python-pyyaml/setup.py
deleted file mode 100644
index 2ed1c94be..000000000
--- a/meta-python/recipes-devtools/python/python-pyyaml/setup.py
+++ /dev/null
@@ -1,64 +0,0 @@
1NAME = 'PyYAML'
2VERSION = '3.10'
3DESCRIPTION = "YAML parser and emitter for Python"
4LONG_DESCRIPTION = """\
5YAML is a data serialization format designed for human readability and
6interaction with scripting languages. PyYAML is a YAML parser and
7emitter for Python.
8
9PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
10support, capable extension API, and sensible error messages. PyYAML
11supports standard YAML tags and provides Python-specific tags that allow
12to represent an arbitrary Python object.
13
14PyYAML is applicable for a broad range of tasks from complex
15configuration files to object serialization and persistance."""
16AUTHOR = "Kirill Simonov"
17AUTHOR_EMAIL = 'xi@resolvent.net'
18LICENSE = "MIT"
19PLATFORMS = "Any"
20URL = "http://pyyaml.org/wiki/PyYAML"
21DOWNLOAD_URL = "http://pyyaml.org/download/pyyaml/%s-%s.tar.gz" % (NAME, VERSION)
22CLASSIFIERS = [
23 "Development Status :: 5 - Production/Stable",
24 "Intended Audience :: Developers",
25 "License :: OSI Approved :: MIT License",
26 "Operating System :: OS Independent",
27 "Programming Language :: Python",
28 "Topic :: Software Development :: Libraries :: Python Modules",
29 "Topic :: Text Processing :: Markup",
30]
31
32from distutils.core import setup
33from distutils.extension import Extension
34from Cython.Distutils import build_ext
35
36import sys, os.path
37
38
39if __name__ == '__main__':
40
41 setup(
42 name=NAME,
43 version=VERSION,
44 description=DESCRIPTION,
45 long_description=LONG_DESCRIPTION,
46 author=AUTHOR,
47 author_email=AUTHOR_EMAIL,
48 license=LICENSE,
49 platforms=PLATFORMS,
50 url=URL,
51 download_url=DOWNLOAD_URL,
52 classifiers=CLASSIFIERS,
53
54 package_dir={'': 'lib'},
55 packages=['yaml'],
56
57 ext_modules = [
58 Extension( "_yaml", ["ext/_yaml.pyx"], libraries = ["yaml"] )
59 ],
60
61 cmdclass={
62 'build_ext': build_ext,
63 },
64 )
diff --git a/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb b/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
index 0899a2ee5..6d9f3e95a 100644..100755
--- a/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
+++ b/meta-python/recipes-devtools/python/python-pyyaml_3.12.bb
@@ -1,24 +1,2 @@
1SUMMARY = "Python support for YAML" 1inherit setuptools
2HOMEPAGE = "http://www.pyyaml.org" 2require python-pyyaml.inc
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
6DEPENDS = "libyaml python-cython-native"
7
8SRC_URI = "http://pyyaml.org/download/pyyaml/PyYAML-${PV}.tar.gz \
9 file://setup.py \
10"
11
12SRC_URI[md5sum] = "4c129761b661d181ebf7ff4eb2d79950"
13SRC_URI[sha256sum] = "592766c6303207a20efc445587778322d7f73b161bd994f227adaa341ba212ab"
14
15S = "${WORKDIR}/PyYAML-${PV}"
16
17inherit distutils
18
19do_configure_prepend() {
20 # upstream setup.py overcomplicated, use ours
21 install -m 0644 ${WORKDIR}/setup.py ${S}
22}
23
24BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml_3.12.bb b/meta-python/recipes-devtools/python/python3-pyyaml_3.12.bb
new file mode 100755
index 000000000..470aca608
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyyaml_3.12.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pyyaml.inc