summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/netcf/gnulib_git.bb35
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb5
2 files changed, 38 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/netcf/gnulib_git.bb b/meta-networking/recipes-support/netcf/gnulib_git.bb
new file mode 100644
index 000000000..730f5cd78
--- /dev/null
+++ b/meta-networking/recipes-support/netcf/gnulib_git.bb
@@ -0,0 +1,35 @@
1SUMMARY = "The GNU portability library"
2DESCRIPTION = "A collection of software subroutines which are designed to \
3be usable on many operating systems. The goal of the project \
4is to make it easy for free software authors to make their \
5software run on many operating systems. Since source is designed \
6to be copied from gnulib, it is not a library per-se, as much \
7as a collection of portable idioms to be used in other projects."
8
9HOMEPAGE = "http://www.gnu.org/software/gnulib/"
10SECTION = "libs"
11LICENSE = "LGPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=e4cf3810f33a067ea7ccd2cd889fed21"
14SRCREV = "24379a9217fa4bd62685795aaaa010fd90ced9e3"
15SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \
16"
17S = "${WORKDIR}/git"
18
19# Git clone a copy of gnulib source to the staging data dir
20sysroot_stage_all () {
21 [ -d ${STAGING_DATADIR}/gnulib/ ] && rm -rf ${STAGING_DATADIR}/gnulib/
22 cd ${S}
23 git checkout master
24 git clone ${S} ${STAGING_DATADIR}/gnulib
25}
26
27do_patch[noexec] = "1"
28do_configure[noexec] = "1"
29do_compile[noexec] = "1"
30do_install[noexec] = "1"
31do_package[noexec] = "1"
32do_packagedata[noexec] = "1"
33do_package_write_ipk[noexec] = "1"
34do_package_write_deb[noexec] = "1"
35do_package_write_rpm[noexec] = "1"
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
index 93f8c70d3..6c36ce848 100644
--- a/meta-networking/recipes-support/netcf/netcf_git.bb
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -12,7 +12,7 @@ PV = "0.2.3+git${SRCPV}"
12SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \ 12SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \
13" 13"
14 14
15DEPENDS += "augeas libnl libxslt libxml2" 15DEPENDS += "augeas libnl libxslt libxml2 gnulib"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
@@ -21,6 +21,7 @@ inherit gettext autotools
21EXTRA_OECONF_append_class-target = " --with-driver=redhat" 21EXTRA_OECONF_append_class-target = " --with-driver=redhat"
22do_configure_prepend() { 22do_configure_prepend() {
23 cd ${S} 23 cd ${S}
24 ./bootstrap 24 rm -f .gitmodules
25 ./bootstrap --gnulib-srcdir=${STAGING_DATADIR}/gnulib
25} 26}
26 27