diff options
-rw-r--r-- | meta-oe/recipes-core/systemd/systemd-systemctl-native.bb | 2 | ||||
-rwxr-xr-x | meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl | 5 |
2 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb index 78eb8f36b..7ca77ae18 100644 --- a/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb +++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native.bb | |||
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" |
5 | 5 | ||
6 | PR = "r2" | 6 | PR = "r3" |
7 | 7 | ||
8 | inherit native | 8 | inherit native |
9 | 9 | ||
diff --git a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl index 6e7a05d34..ff9e6a751 100755 --- a/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl +++ b/meta-oe/recipes-core/systemd/systemd-systemctl-native/systemctl | |||
@@ -1,4 +1,5 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | echo "Started $0 $*" | ||
2 | 3 | ||
3 | ROOT= | 4 | ROOT= |
4 | 5 | ||
@@ -42,6 +43,7 @@ while [ $# != 0 ]; do | |||
42 | done | 43 | done |
43 | 44 | ||
44 | for service in $services; do | 45 | for service in $services; do |
46 | echo "Try to find location of $service..." | ||
45 | # find service file | 47 | # find service file |
46 | for p in $ROOT/etc/systemd/system \ | 48 | for p in $ROOT/etc/systemd/system \ |
47 | $ROOT/lib/systemd/system \ | 49 | $ROOT/lib/systemd/system \ |
@@ -55,6 +57,7 @@ for service in $services; do | |||
55 | echo "'$service' couldn't be found; exiting with error" | 57 | echo "'$service' couldn't be found; exiting with error" |
56 | exit 1 | 58 | exit 1 |
57 | fi | 59 | fi |
60 | echo "Found $service in $service_file" | ||
58 | 61 | ||
59 | # create the required symbolic links | 62 | # create the required symbolic links |
60 | wanted_by=$(grep WantedBy $ROOT/$service_file \ | 63 | wanted_by=$(grep WantedBy $ROOT/$service_file \ |
@@ -63,6 +66,7 @@ for service in $services; do | |||
63 | | grep '\.target$') | 66 | | grep '\.target$') |
64 | 67 | ||
65 | for r in $wanted_by; do | 68 | for r in $wanted_by; do |
69 | echo "WantedBy=$r found in $service" | ||
66 | if [ "$action" = "enable" ]; then | 70 | if [ "$action" = "enable" ]; then |
67 | mkdir -p $ROOT/etc/systemd/system/$r.wants | 71 | mkdir -p $ROOT/etc/systemd/system/$r.wants |
68 | ln -s $service_file $ROOT/etc/systemd/system/$r.wants | 72 | ln -s $service_file $ROOT/etc/systemd/system/$r.wants |
@@ -79,6 +83,7 @@ for service in $services; do | |||
79 | | sed 's,Also=,,g' \ | 83 | | sed 's,Also=,,g' \ |
80 | | tr ',' '\n') | 84 | | tr ',' '\n') |
81 | for a in $also; do | 85 | for a in $also; do |
86 | echo "Also=$a found in $service" | ||
82 | if [ "$action" = "enable" ]; then | 87 | if [ "$action" = "enable" ]; then |
83 | $0 --root=$ROOT enable $a | 88 | $0 --root=$ROOT enable $a |
84 | fi | 89 | fi |