diff options
3 files changed, 7 insertions, 57 deletions
diff --git a/meta-oe/recipes-extended/subsurface/subsurface/libm.patch b/meta-oe/recipes-extended/subsurface/subsurface/libm.patch deleted file mode 100644 index 79956089d..000000000 --- a/meta-oe/recipes-extended/subsurface/subsurface/libm.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | | /media/build1/poky/build1/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.9.0/ld: divelist.o: undefined reference to symbol 'pow@@GLIBC_2.0' | ||
2 | | /media/build1/poky/build1/tmp/sysroots/qemux86/lib/libm.so.6: error adding symbols: DSO missing from command line | ||
3 | | collect2: error: ld returned 1 exit status | ||
4 | |||
5 | Index: git/Makefile | ||
6 | =================================================================== | ||
7 | --- git.orig/Makefile 2014-07-17 20:59:03.152489041 +0000 | ||
8 | +++ git/Makefile 2014-07-17 20:59:19.020489473 +0000 | ||
9 | @@ -50,7 +50,7 @@ | ||
10 | LIBDIVECOMPUTERCFLAGS = -I$(LIBDIVECOMPUTERINCLUDES) | ||
11 | LIBDIVECOMPUTER = $(LIBDIVECOMPUTERARCHIVE) $(LIBUSB) | ||
12 | |||
13 | -LIBS = $(LIBXML2) $(LIBGTK) $(LIBDIVECOMPUTER) -lpthread | ||
14 | +LIBS = $(LIBXML2) $(LIBGTK) $(LIBDIVECOMPUTER) -lpthread -lm | ||
15 | |||
16 | OBJS = main.o dive.o profile.o info.o equipment.o divelist.o \ | ||
17 | parse-xml.o save-xml.o libdivecomputer.o print.o uemis.o \ | ||
diff --git a/meta-oe/recipes-extended/subsurface/subsurface/pkgconfig.patch b/meta-oe/recipes-extended/subsurface/subsurface/pkgconfig.patch deleted file mode 100644 index 1f294fc88..000000000 --- a/meta-oe/recipes-extended/subsurface/subsurface/pkgconfig.patch +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | Index: git/Makefile | ||
2 | =================================================================== | ||
3 | --- git.orig/Makefile 2014-07-17 20:53:23.620479788 +0000 | ||
4 | +++ git/Makefile 2014-07-17 20:56:07.992484267 +0000 | ||
5 | @@ -45,7 +45,7 @@ | ||
6 | # about it if it doesn't. | ||
7 | LIBUSB = $(shell pkg-config --libs libusb-1.0 2> /dev/null) | ||
8 | |||
9 | -LIBXML2 = $(shell xml2-config --libs) | ||
10 | +LIBXML2 = $(shell pkg-config --libs libxml-2.0) | ||
11 | LIBGTK = $(shell pkg-config --libs gtk+-2.0 glib-2.0 gconf-2.0) | ||
12 | LIBDIVECOMPUTERCFLAGS = -I$(LIBDIVECOMPUTERINCLUDES) | ||
13 | LIBDIVECOMPUTER = $(LIBDIVECOMPUTERARCHIVE) $(LIBUSB) | ||
14 | @@ -71,7 +71,7 @@ | ||
15 | $(INSTALL) $(MANFILES) $(MANDIR) | ||
16 | |||
17 | parse-xml.o: parse-xml.c dive.h | ||
18 | - $(CC) $(CFLAGS) `pkg-config --cflags glib-2.0` -c `xml2-config --cflags` parse-xml.c | ||
19 | + $(CC) $(CFLAGS) `pkg-config --cflags glib-2.0` -c `pkg-config --cflags libxml-2.0` parse-xml.c | ||
20 | |||
21 | save-xml.o: save-xml.c dive.h | ||
22 | $(CC) $(CFLAGS) `pkg-config --cflags glib-2.0` -c save-xml.c | ||
diff --git a/meta-oe/recipes-extended/subsurface/subsurface_git.bb b/meta-oe/recipes-extended/subsurface/subsurface_git.bb index fc50eb680..1edb19e35 100644 --- a/meta-oe/recipes-extended/subsurface/subsurface_git.bb +++ b/meta-oe/recipes-extended/subsurface/subsurface_git.bb | |||
@@ -4,29 +4,18 @@ LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
4 | 4 | ||
5 | DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0 gconf" | 5 | DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0 gconf" |
6 | 6 | ||
7 | inherit gtk-icon-cache | 7 | PNBLACKLIST[subsurface] = "Needs to be upgraded for compatibility with new libdivecomputer" |
8 | |||
9 | inherit gtk-icon-cache cmake | ||
8 | 10 | ||
9 | inherit gitpkgv | 11 | inherit gitpkgv |
10 | PKGV = "${GITPKGVTAG}" | 12 | PKGV = "${GITPKGVTAG}" |
11 | PV = "1.1" | 13 | PV = "4.2" |
12 | 14 | ||
13 | SRCREV = "bd275d73ac06823619230915a3aa29deddc996fb" | 15 | SRCREV = "f61ee20ba356ecfc4c5b247f548f52d588179c94" |
14 | SRC_URI = "git://subsurface.hohndel.org/subsurface.git \ | 16 | SRC_URI = "git://subsurface.hohndel.org/subsurface.git" |
15 | file://pkgconfig.patch \ | ||
16 | file://libm.patch" | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||
19 | EXTRA_OEMAKE = "CC='${CC}' \ | 19 | #FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg" |
20 | libdc-usr=${STAGING_INCDIR}/libdivecomputer/* \ | ||
21 | LIBDIVECOMPUTERINCLUDES=${STAGING_INCDIR}/libdivecomputer \ | ||
22 | LIBDIVECOMPUTERARCHIVE=${STAGING_LIBDIR}/libdivecomputer.a \ | ||
23 | " | ||
24 | |||
25 | do_install() { | ||
26 | oe_runmake install DESTDIR=${D} | ||
27 | rm ${D}${datadir}/icons/hicolor/icon-theme.cache | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg" | ||
31 | RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-iso8859-15" | 20 | RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-iso8859-15" |
32 | 21 | ||