summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/geoip/geoip-perl/run-ptest15
-rw-r--r--meta-networking/recipes-support/geoip/geoip-perl_1.45.bb38
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/geoip/geoip-perl/run-ptest b/meta-networking/recipes-support/geoip/geoip-perl/run-ptest
new file mode 100644
index 000000000..5404c247b
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoip-perl/run-ptest
@@ -0,0 +1,15 @@
1#!/bin/sh
2
3# The tests contain hard-coded relative paths and must be
4# executed from $pdir.
5#
6pdir=`dirname $0`
7cd ${pdir}
8for i in t/*.t ; do
9 perl ${i} 1>/dev/null 2>&1;
10 if [ $? == 0 ]; then
11 echo PASS: $i;
12 else
13 echo FAIL: $i;
14 fi;
15done
diff --git a/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
new file mode 100644
index 000000000..01ce11d03
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
@@ -0,0 +1,38 @@
1#
2# Copyright (C) 2014, 2015 Wind River Systems, Inc.
3# Released under the MIT license (see COPYING.MIT for the terms)
4#
5SUMMARY = "GeoIP perl API library to access location database"
6DESCRIPTION = "perl library for country/city/organization to IP address or hostname mapping"
7HOMEPAGE = "http://www.maxmind.com/app/ip-location"
8SECTION = "network"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://README;md5=b0fa745303912bd2d64430f7ae69487d"
11
12SRC_URI = "http://github.com/maxmind/geoip-api-perl/archive/v${PV}.tar.gz \
13 file://run-ptest \
14 "
15
16SRC_URI[md5sum] = "0ce57140890bf81958e0cea4fe1885b2"
17SRC_URI[sha256sum] = "c56437b1cc8887736cb1e435d0320c1c1ff3754830249516317b99137005fb23"
18
19S = "${WORKDIR}/geoip-api-perl-${PV}"
20
21DEPENDS += "geoip"
22
23inherit cpan ptest
24
25EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'"
26
27
28# perl scripts and some special small data files
29#
30do_install_ptest () {
31 install -d -m 0755 ${D}${PTEST_PATH}/t/data
32
33 install ${S}/t/*.t* ${D}${PTEST_PATH}/t
34 install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
35}
36
37FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
38