summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch (renamed from meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch)26
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.6.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.7.2.bb13
3 files changed, 31 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
index 1b6e89043..c45217a88 100644
--- a/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
+++ b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
@@ -1,17 +1,24 @@
1Fixed host contamination of include files 1From 8abf79f77d9151d6786da3c8e868117822bce6d4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 16 Apr 2021 10:48:36 -0700
4Subject: [PATCH] Fix host contamination of include files
2 5
3python3-icu-2.5-r0 do_package_qa: QA Issue: python3-icu: The compile log indicates that host include and/or library paths were used. 6python3-icu-2.5-r0 do_package_qa: QA Issue: python3-icu: The compile log indicates that host include and/or library paths were used.
4 7
5Also, don't use icu-config 8Also, don't use icu-config
6 9
7Upstream-Status: [inappropriate] OE specific 10Upstream-Status: Inappropriate [OE specific]
8Signed-off-by: Armin Kuster <akuster808@gmail.com> 11Signed-off-by: Armin Kuster <akuster808@gmail.com>
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 setup.py | 3 +--
15 1 file changed, 1 insertion(+), 2 deletions(-)
9 16
10Index: PyICU-2.5/setup.py 17diff --git a/setup.py b/setup.py
11=================================================================== 18index e647db4..abed399 100644
12--- PyICU-2.5.orig/setup.py 19--- a/setup.py
13+++ PyICU-2.5/setup.py 20+++ b/setup.py
14@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU ma 21@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU major version supported: %s)
15 22
16 CONFIGURE_WITH_ICU_CONFIG = { 23 CONFIGURE_WITH_ICU_CONFIG = {
17 'darwin': True, 24 'darwin': True,
@@ -20,7 +27,7 @@ Index: PyICU-2.5/setup.py
20 'freebsd': False, # not tested 27 'freebsd': False, # not tested
21 'win32': False, # no icu-config 28 'win32': False, # no icu-config
22 'sunos5': False, # not tested 29 'sunos5': False, # not tested
23@@ -274,7 +274,6 @@ setup(name="PyICU", 30@@ -267,7 +267,6 @@ setup(name="PyICU",
24 ext_modules=[Extension('_icu', 31 ext_modules=[Extension('_icu',
25 [filename for filename in sorted(os.listdir(os.curdir)) 32 [filename for filename in sorted(os.listdir(os.curdir))
26 if filename.endswith('.cpp')], 33 if filename.endswith('.cpp')],
@@ -28,3 +35,6 @@ Index: PyICU-2.5/setup.py
28 extra_compile_args=_cflags, 35 extra_compile_args=_cflags,
29 extra_link_args=_lflags, 36 extra_link_args=_lflags,
30 libraries=_libraries)], 37 libraries=_libraries)],
38--
392.31.1
40
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.6.bb b/meta-python/recipes-devtools/python/python3-icu_2.6.bb
deleted file mode 100644
index 58f5e563b..000000000
--- a/meta-python/recipes-devtools/python/python3-icu_2.6.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1SUMMARY = "Python extension wrapping the ICU C++ API"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c7c4bfd81a21e3b6368bdcced992bf59"
5
6DEPENDS += "pkgconfig icu"
7
8PYPI_PACKAGE = "PyICU"
9SRC_URI[sha256sum] = "a9a5bf6833360f8f69e9375b91c1a7dd6e0c9157a42aee5bb7d6891804d96371"
10
11SRC_URI += "file://fix_host_include.patch"
12
13inherit pypi setuptools3
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb b/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb
new file mode 100644
index 000000000..4c064c3d4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb
@@ -0,0 +1,13 @@
1SUMMARY = "Python extension wrapping the ICU C++ API"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://setup.py;beginline=244;endline=252;md5=3e00c41c6d04310707992b93307a224f"
5
6DEPENDS += "pkgconfig icu"
7
8PYPI_PACKAGE = "PyICU"
9SRC_URI[sha256sum] = "1382869b22d91cc99274f9b525fa7d9199b44d9007ff0036a09747839a01e9dc"
10
11SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"
12
13inherit pypi setuptools3