diff options
-rw-r--r-- | meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch | 90 | ||||
-rw-r--r-- | meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb (renamed from meta-oe/recipes-bsp/ledmon/ledmon_git.bb) | 18 |
3 files changed, 98 insertions, 40 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch b/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch deleted file mode 100644 index 09f4993a2..000000000 --- a/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | Subject: [PATCH] Don't build with -Werror to fix compile error. | ||
2 | |||
3 | | 550 | _dump_sgpio_amd(&amd_reg->amd); | ||
4 | | | ^~~~~~~~~~~~~ | ||
5 | | amd_sgpio.c: In function '_write_amd_register': | ||
6 | | amd_sgpio.c:558:18: error: taking address of packed member of 'struct amd_register' may result in an unaligned pointer value [-Werror=address-of-packed-member] | ||
7 | |||
8 | Upstream-Status: Submitted | ||
9 | https://github.com/intel/ledmon/pull/48/commits | ||
10 | |||
11 | Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | ||
12 | --- | ||
13 | configure.ac | 1 - | ||
14 | 1 file changed, 1 deletion(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 7bc20f8..7e01bd5 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -22,7 +22,6 @@ AX_AM_CFLAGS_ADD([-Werror=format-truncation=1]) | ||
21 | AX_AM_CFLAGS_ADD([-Werror=shift-negative-value]) | ||
22 | AX_AM_CFLAGS_ADD([-Werror=alloca]) | ||
23 | AX_AM_CFLAGS_ADD([-Werror=missing-field-initializers]) | ||
24 | -AX_AM_CFLAGS_ADD([-Werror]) | ||
25 | AX_AM_CFLAGS_ADD([-Werror=format-signedness]) | ||
26 | |||
27 | AC_SUBST([AM_CFLAGS]) | ||
28 | -- | ||
29 | 2.7.4 | ||
30 | |||
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch b/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch new file mode 100644 index 000000000..f1e1d6f78 --- /dev/null +++ b/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch | |||
@@ -0,0 +1,90 @@ | |||
1 | From 28fd86fb4e18af181174176530a80672de4449d2 Mon Sep 17 00:00:00 2001 | ||
2 | From: alperak <alperyasinak1@gmail.com> | ||
3 | Date: Sat, 18 Nov 2023 12:27:17 +0300 | ||
4 | Subject: [PATCH] fix build with clang | ||
5 | |||
6 | struct ibpi2value is a structure which contains 2 unsigned integers. In | ||
7 | a number of cases the code was not initializing a value for the last value | ||
8 | in the pair in struct ibpi2value ibpi_to_attention. This was raised when | ||
9 | using clang compiler. | ||
10 | |||
11 | vmdssd.c:49:27: error: missing field 'value' initializer | ||
12 | [-Werror,-Wmissing-field-initializers] | ||
13 | {LED_IBPI_PATTERN_UNKNOWN} | ||
14 | |||
15 | dellssd.c:74:27: error: missing field 'value' initializer | ||
16 | [-Werror,-Wmissing-field-initializers] | ||
17 | {LED_IBPI_PATTERN_UNKNOWN} | ||
18 | |||
19 | amd_ipmi.c:57:27: error: missing field 'value' | ||
20 | initializer [-Werror,-Wmissing-field-initializers] | ||
21 | {LED_IBPI_PATTERN_UNKNOWN} | ||
22 | |||
23 | npem.c:76:27: error: missing field 'value' | ||
24 | initializer [-Werror,-Wmissing-field-initializers] | ||
25 | {LED_IBPI_PATTERN_UNKNOWN} | ||
26 | |||
27 | Upstream-Status: Submitted [https://github.com/intel/ledmon/pull/179] | ||
28 | Signed-off-by: alperak <alperyasinak1@gmail.com> | ||
29 | --- | ||
30 | src/amd_ipmi.c | 2 +- | ||
31 | src/dellssd.c | 2 +- | ||
32 | src/npem.c | 2 +- | ||
33 | src/vmdssd.c | 2 +- | ||
34 | 4 files changed, 4 insertions(+), 4 deletions(-) | ||
35 | |||
36 | diff --git a/src/amd_ipmi.c b/src/amd_ipmi.c | ||
37 | index 726f77d..ad36e9e 100644 | ||
38 | --- a/src/amd_ipmi.c | ||
39 | +++ b/src/amd_ipmi.c | ||
40 | @@ -53,7 +53,7 @@ const struct ibpi2value ibpi2amd_ipmi[] = { | ||
41 | {IBPI_PATTERN_FAILED_ARRAY, 0x45}, | ||
42 | {IBPI_PATTERN_REBUILD, 0x46}, | ||
43 | {IBPI_PATTERN_HOTSPARE, 0x47}, | ||
44 | - {IBPI_PATTERN_UNKNOWN} | ||
45 | + {IBPI_PATTERN_UNKNOWN, 0} | ||
46 | }; | ||
47 | |||
48 | #define MG9098_CHIP_ID_REG 0x63 | ||
49 | diff --git a/src/dellssd.c b/src/dellssd.c | ||
50 | index 3c10ec7..7f02ea1 100644 | ||
51 | --- a/src/dellssd.c | ||
52 | +++ b/src/dellssd.c | ||
53 | @@ -71,7 +71,7 @@ static const struct ibpi2value ibpi2ssd[] = { | ||
54 | {IBPI_PATTERN_FAILED_DRIVE, BP_FAULT | BP_ONLINE}, | ||
55 | {IBPI_PATTERN_LOCATE, BP_IDENTIFY | BP_ONLINE}, | ||
56 | {IBPI_PATTERN_LOCATE_OFF, BP_ONLINE}, | ||
57 | - {IBPI_PATTERN_UNKNOWN} | ||
58 | + {IBPI_PATTERN_UNKNOWN, 0} | ||
59 | }; | ||
60 | |||
61 | #define DELL_OEM_NETFN 0x30 | ||
62 | diff --git a/src/npem.c b/src/npem.c | ||
63 | index c21276d..3499169 100644 | ||
64 | --- a/src/npem.c | ||
65 | +++ b/src/npem.c | ||
66 | @@ -72,7 +72,7 @@ const struct ibpi2value ibpi_to_npem_capability[] = { | ||
67 | {IBPI_PATTERN_FAILED_DRIVE, PCI_NPEM_FAIL_CAP}, | ||
68 | {IBPI_PATTERN_LOCATE, PCI_NPEM_LOCATE_CAP}, | ||
69 | {IBPI_PATTERN_LOCATE_OFF, PCI_NPEM_OK_CAP}, | ||
70 | - {IBPI_PATTERN_UNKNOWN} | ||
71 | + {IBPI_PATTERN_UNKNOWN, 0} | ||
72 | }; | ||
73 | |||
74 | static struct pci_access *get_pci_access() | ||
75 | diff --git a/src/vmdssd.c b/src/vmdssd.c | ||
76 | index 51af591..9c63d90 100644 | ||
77 | --- a/src/vmdssd.c | ||
78 | +++ b/src/vmdssd.c | ||
79 | @@ -45,7 +45,7 @@ struct ibpi2value ibpi_to_attention[] = { | ||
80 | {IBPI_PATTERN_REBUILD, ATTENTION_REBUILD}, | ||
81 | {IBPI_PATTERN_LOCATE_OFF, ATTENTION_OFF}, | ||
82 | {IBPI_PATTERN_ONESHOT_NORMAL, ATTENTION_OFF}, | ||
83 | - {IBPI_PATTERN_UNKNOWN} | ||
84 | + {IBPI_PATTERN_UNKNOWN, 0} | ||
85 | }; | ||
86 | |||
87 | #define SYSFS_PCIEHP "/sys/module/pciehp" | ||
88 | -- | ||
89 | 2.25.1 | ||
90 | |||
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb index dbfd1e7bc..d431fd9a8 100644 --- a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb +++ b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb | |||
@@ -5,28 +5,26 @@ DESCRIPTION = "The utilities are designed primarily to be used on storage server | |||
5 | " | 5 | " |
6 | HOMEPAGE = "https://github.com/intel/ledmon" | 6 | HOMEPAGE = "https://github.com/intel/ledmon" |
7 | 7 | ||
8 | LICENSE = "GPL-2.0-only" | 8 | LICENSE = "LGPL-2.0-only" |
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | 9 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
10 | " | ||
11 | 10 | ||
12 | DEPENDS = "sg3-utils udev" | 11 | DEPENDS = "sg3-utils udev pciutils" |
13 | 12 | ||
14 | inherit autotools systemd | 13 | inherit autotools systemd pkgconfig |
15 | 14 | ||
16 | SYSTEMD_SERVICE:${PN} = "ledmon.service" | 15 | SYSTEMD_SERVICE:${PN} = "ledmon.service" |
17 | 16 | ||
18 | # 0.93 | ||
19 | SRC_URI = "git://github.com/intel/ledmon;branch=master;protocol=https \ | 17 | SRC_URI = "git://github.com/intel/ledmon;branch=master;protocol=https \ |
20 | file://0002-include-sys-select.h-and-sys-types.h.patch \ | 18 | file://0002-include-sys-select.h-and-sys-types.h.patch \ |
21 | file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \ | 19 | file://0001-fix-build-with-clang.patch" |
22 | " | ||
23 | 20 | ||
24 | SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e" | 21 | SRCREV = "b0edae14e8660b80ffe0384354038a9f62e2978d" |
25 | 22 | ||
26 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" | 23 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
27 | COMPATIBLE_HOST:libc-musl = "null" | 24 | COMPATIBLE_HOST:libc-musl = "null" |
28 | 25 | ||
29 | S = "${WORKDIR}/git" | 26 | S = "${WORKDIR}/git" |
27 | |||
30 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" | 28 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" |
31 | 29 | ||
32 | # The ledmon sources include headers in ${S}/config to build but not in CFLAGS. | 30 | # The ledmon sources include headers in ${S}/config to build but not in CFLAGS. |