summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-shells/dash/dash/0001-Fix-printf-format-errors-with-clang.patch28
-rw-r--r--meta-oe/recipes-shells/dash/dash_0.5.11.bb (renamed from meta-oe/recipes-shells/dash/dash_0.5.10.2.bb)8
2 files changed, 3 insertions, 33 deletions
diff --git a/meta-oe/recipes-shells/dash/dash/0001-Fix-printf-format-errors-with-clang.patch b/meta-oe/recipes-shells/dash/dash/0001-Fix-printf-format-errors-with-clang.patch
deleted file mode 100644
index b3991faa8..000000000
--- a/meta-oe/recipes-shells/dash/dash/0001-Fix-printf-format-errors-with-clang.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 3ddf397febf47f8de9ca2805e92355ecb3ba0e9f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 8 Apr 2017 12:37:54 -0700
4Subject: [PATCH] Fix printf format errors with clang
5
6error: format string is not a string literal (potentially insecure)
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 src/jobs.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/src/jobs.c b/src/jobs.c
14index c2c2332..dcb81c1 100644
15--- a/src/jobs.c
16+++ b/src/jobs.c
17@@ -427,7 +427,7 @@ sprint_status(char *s, int status, int sigonly)
18 goto out;
19 #endif
20 }
21- col = fmtstr(s, 32, strsignal(st));
22+ col = fmtstr(s, 32, "%s", strsignal(st));
23 #ifdef WCOREDUMP
24 if (WCOREDUMP(status)) {
25 col += fmtstr(s + col, 16, " (core dumped)");
26--
272.12.2
28
diff --git a/meta-oe/recipes-shells/dash/dash_0.5.10.2.bb b/meta-oe/recipes-shells/dash/dash_0.5.11.bb
index 18566284c..b3a36651f 100644
--- a/meta-oe/recipes-shells/dash/dash_0.5.10.2.bb
+++ b/meta-oe/recipes-shells/dash/dash_0.5.11.bb
@@ -7,11 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
7 7
8inherit autotools update-alternatives 8inherit autotools update-alternatives
9 9
10SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz \ 10SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz"
11 file://0001-Fix-printf-format-errors-with-clang.patch \ 11SRC_URI[md5sum] = "027236e48b9202607b1418fee42c473e"
12 " 12SRC_URI[sha256sum] = "4dd9a6ed5fe7546095157918fe5d784bb0b7887ae13de50e1e2d11e1b5a391cb"
13SRC_URI[md5sum] = "8f485f126c05d0ab800e85abfe1987aa"
14SRC_URI[sha256sum] = "3c663919dc5c66ec991da14c7cf7e0be8ad00f3db73986a987c118862b5f6071"
15 13
16EXTRA_OECONF += "--bindir=${base_bindir}" 14EXTRA_OECONF += "--bindir=${base_bindir}"
17 15