diff options
3 files changed, 158 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview/0002-configure.ac-header-detection-of-hash_map-is-broken-.patch b/meta-oe/recipes-extended/mml-widget/gtkmathview/0002-configure.ac-header-detection-of-hash_map-is-broken-.patch new file mode 100644 index 000000000..b879d6a51 --- /dev/null +++ b/meta-oe/recipes-extended/mml-widget/gtkmathview/0002-configure.ac-header-detection-of-hash_map-is-broken-.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | From 9c226fbc6a42540cb492fcfcb81ff16fffb086d6 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Tue, 30 Aug 2016 23:24:53 +0200 | ||
4 | Subject: [PATCH] configure.ac: header detection of hash_map is broken - pin to | ||
5 | correct implementation | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
13 | --- | ||
14 | configure.ac | 31 ++++--------------------------- | ||
15 | 1 file changed, 4 insertions(+), 27 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index 4f2118e..16c09d5 100644 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -252,35 +252,12 @@ AC_SUBST(GTKMATHVIEW_SIZEOF_WCHAR_T, "$ac_cv_sizeof_wchar_t") | ||
22 | |||
23 | AC_LANG_PUSH(C++) | ||
24 | |||
25 | -AC_CHECK_HEADERS(unordered_map, | ||
26 | - [ | ||
27 | - AC_DEFINE(GMV_HAVE_UNORDERED_MAP,1,[Define if <unordered_map> is provided]) | ||
28 | - GMV_HAVE_UNORDERED_MAP_CFLAGS=-DGMV_HAVE_UNORDERED_MAP=1 | ||
29 | - ], | ||
30 | - [ | ||
31 | - GMV_HAVE_UNORDERED_MAP_CFLAGS= | ||
32 | - ] | ||
33 | -) | ||
34 | +GMV_HAVE_UNORDERED_MAP_CFLAGS= | ||
35 | AC_SUBST(GMV_HAVE_UNORDERED_MAP_CFLAGS) | ||
36 | -AC_CHECK_HEADERS(hash_map, | ||
37 | - [ | ||
38 | - AC_DEFINE(GMV_HAVE_HASH_MAP,1,[Define if <hash_map> is provided]) | ||
39 | - GMV_HAVE_HASH_MAP_CFLAGS=-DGMV_HAVE_HASH_MAP=1 | ||
40 | - ], | ||
41 | - [ | ||
42 | - GMV_HAVE_HASH_MAP_CFLAGS= | ||
43 | - ] | ||
44 | -) | ||
45 | +GMV_HAVE_HASH_MAP_CFLAGS= | ||
46 | AC_SUBST(GMV_HAVE_HASH_MAP_CFLAGS) | ||
47 | -AC_CHECK_HEADERS(ext/hash_map, | ||
48 | - [ | ||
49 | - AC_DEFINE(GMV_HAVE_EXT_HASH_MAP,1,[Define if <ext/hash_map> is provided]) | ||
50 | - GMV_HAVE_EXT_HASH_MAP_CFLAGS=-DGMV_HAVE_EXT_HASH_MAP=1 | ||
51 | - ], | ||
52 | - [ | ||
53 | - GMV_HAVE_EXT_HASH_MAP_CFLAGS= | ||
54 | - ] | ||
55 | -) | ||
56 | +AC_DEFINE(GMV_HAVE_EXT_HASH_MAP,1,[Define if <ext/hash_map> is provided]) | ||
57 | +GMV_HAVE_EXT_HASH_MAP_CFLAGS=-DGMV_HAVE_EXT_HASH_MAP=1 | ||
58 | AC_SUBST(GMV_HAVE_EXT_HASH_MAP_CFLAGS) | ||
59 | |||
60 | AC_MSG_CHECKING([whether the C++ compiler supports the standard character traits]) | ||
61 | -- | ||
62 | 2.5.5 | ||
63 | |||
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview/0003-gcc-6.0-build-fixes.patch b/meta-oe/recipes-extended/mml-widget/gtkmathview/0003-gcc-6.0-build-fixes.patch new file mode 100644 index 000000000..356274d17 --- /dev/null +++ b/meta-oe/recipes-extended/mml-widget/gtkmathview/0003-gcc-6.0-build-fixes.patch | |||
@@ -0,0 +1,93 @@ | |||
1 | From: Gert Wollny <gw.fossdev@gmail.com> | ||
2 | Date: Sun, 26 Jun 2016 13:25:00 +0200 | ||
3 | Description: gcc 6.0 build fixes | ||
4 | Bug: https://bugs.debian.org/811682 | ||
5 | |||
6 | Slightly adapted to our environment | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
11 | --- a/src/engine/common/View.cc | ||
12 | +++ b/src/engine/common/View.cc | ||
13 | @@ -291,7 +291,7 @@ | ||
14 | } | ||
15 | } | ||
16 | |||
17 | - return false; | ||
18 | + return SmartPtr<Element>(); | ||
19 | } | ||
20 | |||
21 | bool | ||
22 | --- a/src/backend/common/tfm/TFM.hh | ||
23 | +++ b/src/backend/common/tfm/TFM.hh | ||
24 | @@ -37,7 +37,7 @@ | ||
25 | unsigned char face; | ||
26 | const char* codingScheme; | ||
27 | int designSize; | ||
28 | - int checksum; | ||
29 | + unsigned int checksum; | ||
30 | unsigned int nDimensions; | ||
31 | unsigned int nCharacters; | ||
32 | }; | ||
33 | @@ -52,7 +52,7 @@ | ||
34 | struct Kerning | ||
35 | { | ||
36 | UChar8 index; | ||
37 | - int value; | ||
38 | + unsigned int value; | ||
39 | }; | ||
40 | |||
41 | struct Ligature | ||
42 | @@ -67,7 +67,7 @@ | ||
43 | UChar8 index; | ||
44 | int width; | ||
45 | int height; | ||
46 | - int depth; | ||
47 | + unsigned int depth; | ||
48 | int italicCorrection; | ||
49 | unsigned char nKernings; | ||
50 | const Kerning* kerning; | ||
51 | --- a/src/backend/common/StandardSymbolsShaper.hh | ||
52 | +++ b/src/backend/common/StandardSymbolsShaper.hh | ||
53 | @@ -32,20 +32,20 @@ | ||
54 | struct HStretchyChar | ||
55 | { | ||
56 | Char16 ch; | ||
57 | - Char8 normal; | ||
58 | - Char8 left; | ||
59 | - Char8 glue; | ||
60 | - Char8 right; | ||
61 | + UChar8 normal; | ||
62 | + UChar8 left; | ||
63 | + UChar8 glue; | ||
64 | + UChar8 right; | ||
65 | }; | ||
66 | |||
67 | struct VStretchyChar | ||
68 | { | ||
69 | Char16 ch; | ||
70 | - Char8 normal; | ||
71 | - Char8 top; | ||
72 | - Char8 glue; | ||
73 | - Char8 middle; | ||
74 | - Char8 bottom; | ||
75 | + UChar8 normal; | ||
76 | + UChar8 top; | ||
77 | + UChar8 glue; | ||
78 | + UChar8 middle; | ||
79 | + UChar8 bottom; | ||
80 | }; | ||
81 | |||
82 | protected: | ||
83 | --- a/src/backend/common/StandardSymbolsShaper.cc | ||
84 | +++ b/src/backend/common/StandardSymbolsShaper.cc | ||
85 | @@ -29,7 +29,7 @@ | ||
86 | #include "ShapingContext.hh" | ||
87 | |||
88 | struct GlyphMap { | ||
89 | - Char8 index; | ||
90 | + UChar8 index; | ||
91 | Char16 ch; | ||
92 | }; | ||
93 | |||
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb index cce352892..c693639ec 100644 --- a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb +++ b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb | |||
@@ -11,6 +11,8 @@ PV = "0.8.0+git${SRCPV}" | |||
11 | SRC_URI = "git://github.com/GNOME/gtkmathview.git \ | 11 | SRC_URI = "git://github.com/GNOME/gtkmathview.git \ |
12 | file://use_hostcxx.patch \ | 12 | file://use_hostcxx.patch \ |
13 | file://0001-include-cstdio-to-get-printf-definitions.patch \ | 13 | file://0001-include-cstdio-to-get-printf-definitions.patch \ |
14 | file://0002-configure.ac-header-detection-of-hash_map-is-broken-.patch \ | ||
15 | file://0003-gcc-6.0-build-fixes.patch \ | ||
14 | " | 16 | " |
15 | 17 | ||
16 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
@@ -21,6 +23,3 @@ do_configure_append() { | |||
21 | # avoid host polution inf pkg-config files | 23 | # avoid host polution inf pkg-config files |
22 | sed -i "s:${STAGING_DIR_HOST}::g" `find -name '*.pc'` | 24 | sed -i "s:${STAGING_DIR_HOST}::g" `find -name '*.pc'` |
23 | } | 25 | } |
24 | |||
25 | # http://errors.yoctoproject.org/Errors/Details/68615/ | ||
26 | PNBLACKLIST[gtkmathview] ?= "BROKEN: fails to build with gcc-6" | ||