diff options
-rw-r--r-- | meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch | 58 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb (renamed from meta-networking/recipes-daemons/keepalived/keepalived_2.2.1.bb) | 6 |
2 files changed, 62 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch b/meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch new file mode 100644 index 000000000..f9cadbc26 --- /dev/null +++ b/meta-networking/recipes-daemons/keepalived/keepalived/0001-layer4-Change-order-of-include-files.patch | |||
@@ -0,0 +1,58 @@ | |||
1 | From a85ca79143a87286f793957e803ee3daf03c2b57 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 6 Jul 2021 14:06:44 -0700 | ||
4 | Subject: [PATCH] layer4: Change order of include files | ||
5 | |||
6 | curent order to include standard headers first is causing an isue with | ||
7 | glibc 2.34 + kernel-headers 5.13+ where order of including netinet/in.h | ||
8 | and linux/in.h matters and it does not define __UAPI_DEF_IN_IPPROTO | ||
9 | before including linux/in.h and then later includes netinet/in.h which | ||
10 | then means lot of definitions will be defined twice and compile would | ||
11 | fail. Re-ordering the local headers to appear first solves the issue | ||
12 | amicably, and I think this is right order too | ||
13 | |||
14 | Upsteam-Status: Pending | ||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | keepalived/core/layer4.c | 21 ++++++++++----------- | ||
18 | 1 file changed, 10 insertions(+), 11 deletions(-) | ||
19 | |||
20 | diff --git a/keepalived/core/layer4.c b/keepalived/core/layer4.c | ||
21 | index 90cdc84..c122c29 100644 | ||
22 | --- a/keepalived/core/layer4.c | ||
23 | +++ b/keepalived/core/layer4.c | ||
24 | @@ -23,6 +23,16 @@ | ||
25 | |||
26 | #include "config.h" | ||
27 | |||
28 | +#include "layer4.h" | ||
29 | +#include "logger.h" | ||
30 | +#include "scheduler.h" | ||
31 | +#ifdef _WITH_LVS_ | ||
32 | +#include "check_api.h" | ||
33 | +#endif | ||
34 | +#include "bitops.h" | ||
35 | +#include "utils.h" | ||
36 | +#include "align.h" | ||
37 | + | ||
38 | #include <stdio.h> | ||
39 | #include <errno.h> | ||
40 | #include <unistd.h> | ||
41 | @@ -33,17 +43,6 @@ | ||
42 | #include <sys/time.h> | ||
43 | #endif | ||
44 | #include <linux/errqueue.h> | ||
45 | -#include <netinet/in.h> | ||
46 | - | ||
47 | -#include "layer4.h" | ||
48 | -#include "logger.h" | ||
49 | -#include "scheduler.h" | ||
50 | -#ifdef _WITH_LVS_ | ||
51 | -#include "check_api.h" | ||
52 | -#endif | ||
53 | -#include "bitops.h" | ||
54 | -#include "utils.h" | ||
55 | -#include "align.h" | ||
56 | |||
57 | // #define ICMP_DEBUG 1 | ||
58 | |||
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived_2.2.1.bb b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb index a778d2609..f0cbca1be 100644 --- a/meta-networking/recipes-daemons/keepalived/keepalived_2.2.1.bb +++ b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb | |||
@@ -10,8 +10,10 @@ HOMEPAGE = "http://www.keepalived.org/" | |||
10 | LICENSE = "GPLv2" | 10 | LICENSE = "GPLv2" |
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
12 | 12 | ||
13 | SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz" | 13 | SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \ |
14 | SRC_URI[sha256sum] = "91186f20c83ffc48d7a15a9a6e2329ed4feeb2dcb51f4aa9672c8840190ea741" | 14 | file://0001-layer4-Change-order-of-include-files.patch \ |
15 | " | ||
16 | SRC_URI[sha256sum] = "103692bd5345a4ed9f4581632ea636214fdf53e45682e200aab122c4fa674ece" | ||
15 | UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases" | 17 | UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases" |
16 | 18 | ||
17 | DEPENDS = "libnfnetlink openssl" | 19 | DEPENDS = "libnfnetlink openssl" |