summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-xxhash.inc22
-rw-r--r--meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb24
2 files changed, 22 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-xxhash.inc b/meta-python/recipes-devtools/python/python-xxhash.inc
deleted file mode 100644
index c02c29eb7..000000000
--- a/meta-python/recipes-devtools/python/python-xxhash.inc
+++ /dev/null
@@ -1,22 +0,0 @@
1SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
2SECTION = "devel/python"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5"
5
6SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0"
7SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9"
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13inherit ptest
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
diff --git a/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb b/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb
index 76bc41a11..c114a6c8b 100644
--- a/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb
+++ b/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb
@@ -1,2 +1,22 @@
1require python-xxhash.inc 1SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
2inherit pypi setuptools3 2SECTION = "devel/python"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5"
5
6SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0"
7SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9"
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13inherit pypi setuptools3 ptest
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}