diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-xxhash.inc | 22 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb | 24 |
2 files changed, 22 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-xxhash.inc b/meta-python/recipes-devtools/python/python-xxhash.inc deleted file mode 100644 index c02c29eb7..000000000 --- a/meta-python/recipes-devtools/python/python-xxhash.inc +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "BSD-2-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5" | ||
5 | |||
6 | SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0" | ||
7 | SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9" | ||
8 | |||
9 | SRC_URI += " \ | ||
10 | file://run-ptest \ | ||
11 | " | ||
12 | |||
13 | inherit ptest | ||
14 | |||
15 | RDEPENDS_${PN}-ptest += " \ | ||
16 | ${PYTHON_PN}-pytest \ | ||
17 | " | ||
18 | |||
19 | do_install_ptest() { | ||
20 | install -d ${D}${PTEST_PATH}/tests | ||
21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
22 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb b/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb index 76bc41a11..c114a6c8b 100644 --- a/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb +++ b/meta-python/recipes-devtools/python/python3-xxhash_1.4.3.bb | |||
@@ -1,2 +1,22 @@ | |||
1 | require python-xxhash.inc | 1 | SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet." |
2 | inherit pypi setuptools3 | 2 | SECTION = "devel/python" |
3 | LICENSE = "BSD-2-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5" | ||
5 | |||
6 | SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0" | ||
7 | SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9" | ||
8 | |||
9 | SRC_URI += " \ | ||
10 | file://run-ptest \ | ||
11 | " | ||
12 | |||
13 | inherit pypi setuptools3 ptest | ||
14 | |||
15 | RDEPENDS_${PN}-ptest += " \ | ||
16 | ${PYTHON_PN}-pytest \ | ||
17 | " | ||
18 | |||
19 | do_install_ptest() { | ||
20 | install -d ${D}${PTEST_PATH}/tests | ||
21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
22 | } | ||