diff options
6 files changed, 95 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-meld3.inc b/meta-python/recipes-devtools/python/python-meld3.inc new file mode 100644 index 000000000..d4e274e60 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-meld3.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "meld3 templating system used by Supervisor" | ||
2 | DESCRIPTION = "\ | ||
3 | meld3 is an HTML/XML templating system for Python which keeps \ | ||
4 | template markup and dynamic rendering logic separate from one \ | ||
5 | another. See http://www.entrian.com/PyMeld for a treatise on the \ | ||
6 | benefits of this pattern." | ||
7 | HOMEPAGE = "https://github.com/supervisor/meld3" | ||
8 | LICENSE = "BSD" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9e7581cef5645475fcefebdc15ed7abf" | ||
10 | |||
11 | SRC_URI[md5sum] = "3ccc78cd79cffd63a751ad7684c02c91" | ||
12 | SRC_URI[sha256sum] = "f7b754a0fde7a4429b2ebe49409db240b5699385a572501bb0d5627d299f9558" | ||
13 | |||
14 | PYPI_PACKAGE = "meld3" | ||
15 | inherit pypi | ||
diff --git a/meta-python/recipes-devtools/python/python-supervisor.inc b/meta-python/recipes-devtools/python/python-supervisor.inc new file mode 100644 index 000000000..beab49739 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-supervisor.inc | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "Supervisor: A Process Control System" | ||
2 | DESCRIPTION = "\ | ||
3 | Supervisor is a client/server system that allows its users \ | ||
4 | to monitorand control a number of processes on UNIX-like \ | ||
5 | operating systems." | ||
6 | HOMEPAGE = "https://github.com/Supervisor/supervisor" | ||
7 | LICENSE = "BSD" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e" | ||
9 | |||
10 | SRC_URI[md5sum] = "ac70dadd051dcaf1d03c467d51a3aac1" | ||
11 | SRC_URI[sha256sum] = "5604457da4fb89d850e78c128205fe4938c9277f87301885b33c94c60361e575" | ||
12 | |||
13 | PYPI_PACKAGE = "supervisor" | ||
14 | inherit pypi systemd | ||
15 | RDEPENDS_${PN} = "\ | ||
16 | ${PYTHON_PN}-meld3 \ | ||
17 | " | ||
18 | |||
19 | SRC_URI += "file://supervisord.conf \ | ||
20 | file://supervisor.service \ | ||
21 | " | ||
22 | SYSTEMD_SERVICE_${PN} = "supervisor.service" | ||
23 | |||
24 | do_install_append() { | ||
25 | install -d ${D}${sysconfdir}/supervisor | ||
26 | install -d ${D}${systemd_system_unitdir} | ||
27 | |||
28 | install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor | ||
29 | install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir} | ||
30 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-meld3_1.0.2.bb b/meta-python/recipes-devtools/python/python3-meld3_1.0.2.bb new file mode 100644 index 000000000..f69591629 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-meld3_1.0.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-meld3.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-supervisor/supervisor.service b/meta-python/recipes-devtools/python/python3-supervisor/supervisor.service new file mode 100644 index 000000000..e9d3f706b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-supervisor/supervisor.service | |||
@@ -0,0 +1,15 @@ | |||
1 | [Unit] | ||
2 | Description=Supervisor process control system for UNIX | ||
3 | Documentation=http://supervisord.org | ||
4 | After=network.target | ||
5 | |||
6 | [Service] | ||
7 | ExecStart=/usr/bin/supervisord -n -c /etc/supervisor/supervisord.conf | ||
8 | ExecStop=/usr/bin/supervisorctl $OPTIONS shutdown | ||
9 | ExecReload=/usr/bin/supervisorctl -c /etc/supervisor/supervisord.conf $OPTIONS reload | ||
10 | KillMode=process | ||
11 | Restart=on-failure | ||
12 | RestartSec=50s | ||
13 | |||
14 | [Install] | ||
15 | WantedBy=multi-user.target | ||
diff --git a/meta-python/recipes-devtools/python/python3-supervisor/supervisord.conf b/meta-python/recipes-devtools/python/python3-supervisor/supervisord.conf new file mode 100644 index 000000000..3fb9b492d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-supervisor/supervisord.conf | |||
@@ -0,0 +1,31 @@ | |||
1 | ; supervisor config file | ||
2 | |||
3 | [unix_http_server] | ||
4 | file=/var/run/supervisor.sock ; (the path to the socket file) | ||
5 | chmod=0700 ; sockef file mode (default 0700) | ||
6 | |||
7 | [supervisord] | ||
8 | logfile=/var/log/supervisord.log ; (main log file;default $CWD/supervisord.log) | ||
9 | pidfile=/var/run/supervisord.pid ; (supervisord pidfile;default supervisord.pid) | ||
10 | childlogdir=/var/log/ ; ('AUTO' child log dir, default $TEMP) | ||
11 | |||
12 | ; the below section must remain in the config file for RPC | ||
13 | ; (supervisorctl/web interface) to work, additional interfaces may be | ||
14 | ; added by defining them in separate rpcinterface: sections | ||
15 | [rpcinterface:supervisor] | ||
16 | supervisor.rpcinterface_factory = supervisor.rpcinterface:make_main_rpcinterface | ||
17 | |||
18 | [supervisorctl] | ||
19 | serverurl=unix:///var/run/supervisor.sock ; use a unix:// URL for a unix socket | ||
20 | |||
21 | ; The [include] section can just contain the "files" setting. This | ||
22 | ; setting can list multiple files (separated by whitespace or | ||
23 | ; newlines). It can also contain wildcards. The filenames are | ||
24 | ; interpreted as relative to this file. Included files *cannot* | ||
25 | ; include files themselves. | ||
26 | |||
27 | [include] | ||
28 | files = /etc/supervisor/conf.d/*.conf | ||
29 | |||
30 | ;[inet_http_server] | ||
31 | ;port=127.0.0.1:9001 | ||
diff --git a/meta-python/recipes-devtools/python/python3-supervisor_4.0.2.bb b/meta-python/recipes-devtools/python/python3-supervisor_4.0.2.bb new file mode 100644 index 000000000..d29e1d6b6 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-supervisor_4.0.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-supervisor.inc | ||