summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pyperclip.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb2
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyperclip.inc b/meta-python/recipes-devtools/python/python-pyperclip.inc
new file mode 100644
index 000000000..c712fdd7c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyperclip.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1ed92115c8f96b19ec34ed09df586e51"
4
5SRC_URI[md5sum] = "d2f6a3129cd6f2518b52bb0b8deeeda7"
6SRC_URI[sha256sum] = "ce829433a9af640e08ee89b20f7c62132714bcc5d77df114044d0fccb8c3b3b8"
7
8inherit pypi
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-ctypes \
12 ${PYTHON_PN}-subprocess \
13"
diff --git a/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb b/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb
new file mode 100644
index 000000000..6e93b8179
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyperclip_1.6.0.bb
@@ -0,0 +1,4 @@
1inherit setuptools
2require python-pyperclip.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-contextlib"
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb
new file mode 100644
index 000000000..ee6f88bbb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.6.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pyperclip.inc