diff options
-rw-r--r-- | meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch | 16 | ||||
-rw-r--r-- | meta-networking/recipes-support/ntimed/ntimed_git.bb | 41 |
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch b/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch new file mode 100644 index 000000000..87a7778d9 --- /dev/null +++ b/meta-networking/recipes-support/ntimed/ntimed/use-ldflags.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Obey LDFLAGS. | ||
2 | |||
3 | Signed-off-by: Christopher Larson <kergoth@gmail.com> | ||
4 | Upstream-Status: Pending | ||
5 | |||
6 | --- Ntimed.orig/configure 2015-05-30 11:57:59.927796993 -0700 | ||
7 | +++ Ntimed/configure 2015-05-30 11:58:26.143948894 -0700 | ||
8 | @@ -142,7 +142,7 @@ | ||
9 | |||
10 | echo | ||
11 | echo "ntimed-client: ${l}" | ||
12 | - echo " \${CC} \${CFLAGS} -o ntimed-client ${l} -lm" | ||
13 | + echo " \${CC} \${CFLAGS} -o ntimed-client ${l} \${LDFLAGS} -lm" | ||
14 | echo | ||
15 | echo "clean:" | ||
16 | echo " rm -f ${l} ntimed-client" | ||
diff --git a/meta-networking/recipes-support/ntimed/ntimed_git.bb b/meta-networking/recipes-support/ntimed/ntimed_git.bb new file mode 100644 index 000000000..099054178 --- /dev/null +++ b/meta-networking/recipes-support/ntimed/ntimed_git.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "Network time synchronization software, NTPD replacement" | ||
2 | DESCRIPTION = "This is a preview/early-access/alpha/buzzword-of-the-times \ | ||
3 | release of a new FOSS project written to gradually take over the world of \ | ||
4 | networked timekeeping." | ||
5 | HOMEPAGE = "https://github.com/bsdphk/Ntimed" | ||
6 | SECTION = "console/network" | ||
7 | |||
8 | LICENSE = "BSD-2-Clause" | ||
9 | LIC_FILES_CHKSUM = "file://main.c;startline=2;endline=24;md5=eda11d21005319bb76cbb6f911f0f66d" | ||
10 | |||
11 | SRC_URI = "git://github.com/bsdphk/Ntimed \ | ||
12 | file://use-ldflags.patch" | ||
13 | |||
14 | PV = "0.0+git${SRCPV}" | ||
15 | SRCREV = "db0abbb4c80f2ecef6bc5d9639bca5bea28532a2" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | EXTRA_OEMAKE = "\ | ||
20 | 'CC=${CC}' \ | ||
21 | 'CFLAGS=${CFLAGS}' \ | ||
22 | 'LDFLAGS=${LDFLAGS}' \ | ||
23 | " | ||
24 | |||
25 | do_configure () { | ||
26 | sh ./configure | ||
27 | } | ||
28 | |||
29 | do_compile () { | ||
30 | oe_runmake | ||
31 | } | ||
32 | |||
33 | do_install () { | ||
34 | install -D -m 0755 ntimed-client ${D}${sbindir}/ntimed-client | ||
35 | } | ||
36 | |||
37 | ALLOW_EMPTY_${PN} = "1" | ||
38 | RDEPENDS_${PN} += "ntimed-client" | ||
39 | |||
40 | PACKAGE_BEFORE_PN += "ntimed-client" | ||
41 | FILES_ntimed-client = "${sbindir}/ntimed-client" | ||