summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-security/bubblewrap/bubblewrap_0.7.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/bubblewrap/bubblewrap_0.7.0.bb b/meta-oe/recipes-security/bubblewrap/bubblewrap_0.7.0.bb
new file mode 100644
index 000000000..4d053b54c
--- /dev/null
+++ b/meta-oe/recipes-security/bubblewrap/bubblewrap_0.7.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Unprivileged sandboxing tool"
2HOMEPAGE = "https://github.com/containers/bubblewrap"
3LICENSE = "LGPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
5
6DEPENDS = "libcap"
7
8SRC_URI = "https://github.com/containers/${BPN}/releases/download/v${PV}/${BP}.tar.xz"
9SRC_URI[sha256sum] = "764ab7100bd037ea53d440d362e099d7a425966bc62d1f00ab26b8fbb882a9dc"
10
11inherit autotools bash-completion github-releases manpages pkgconfig
12
13GITHUB_BASE_URI = "https://github.com/containers/${BPN}/releases/"
14
15PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
16PACKAGECONFIG[manpages] = "--enable-man,--disable-man,libxslt-native docbook-xsl-stylesheets-native xmlto-native"
17PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
18PACKAGECONFIG[setuid] = "--with-priv-mode=setuid,--with-priv-mode=none"
19
20PACKAGES += "${PN}-zsh-completion"
21
22FILES:${PN}-zsh-completion = "${datadir}/zsh/site-functions"
23
24BBCLASSEXTEND = "native"