summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch23
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb11
3 files changed, 52 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto.inc b/meta-python/recipes-devtools/python/python-pycrypto.inc
new file mode 100644
index 000000000..42e31a979
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycrypto.inc
@@ -0,0 +1,18 @@
1DESCRIPTION = "Cryptographic modules for Python."
2HOMEPAGE = "http://www.pycrypto.org/"
3LICENSE = "PSFv2"
4LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
7
8DEPENDS += " gmp"
9PYPI_PACKAGE = "pycrypto"
10
11inherit pypi autotools-brokensep
12
13SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
14SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
15
16do_compile[noexec] = "1"
17
18BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch
new file mode 100644
index 000000000..712f3e8dd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch
@@ -0,0 +1,23 @@
1Index: pycrypto-2.6/setup.py
2===================================================================
3--- pycrypto-2.6.orig/setup.py
4+++ pycrypto-2.6/setup.py
5@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
6 if not os.path.exists("config.status"):
7 if os.system("chmod 0755 configure") != 0:
8 raise RuntimeError("chmod error")
9- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
10+ host = os.environ.get("HOST_SYS")
11+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
12 if self.verbose < 1:
13 cmd += " -q"
14 if os.system(cmd) != 0:
15@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
16 'ext_modules': plat_ext + [
17 # _fastmath (uses GNU mp library)
18 Extension("Crypto.PublicKey._fastmath",
19- include_dirs=['src/','/usr/include/'],
20+ include_dirs=['src/'],
21 libraries=['gmp'],
22 sources=["src/_fastmath.c"]),
23
diff --git a/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
new file mode 100644
index 000000000..06a0cc444
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -0,0 +1,11 @@
1inherit distutils
2require python-pycrypto.inc
3
4SRC_URI += "file://cross-compiling.patch"
5
6# We explicitly call distutils_do_install, since we want it to run, but
7# *don't* want the autotools install to run, since this package doesn't
8# provide a "make install" target.
9do_install() {
10 distutils_do_install
11}