summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb b/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb
deleted file mode 100644
index 811175ce8..000000000
--- a/meta-oe/recipes-multimedia/libpostproc/libpostproc_git.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1SUMMARY = "FFmpeg derived postprocessing library"
2HOMEPAGE = "http://git.videolan.org/?p=libpostproc.git;a=summary"
3SECTION = "libs"
4DEPENDS = "libav"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8PV = "52.3.0+git${SRCPV}"
9
10SRCREV = "811db3b957dfde24aef2d0f82e297e5bf552d873"
11SRC_URI = "git://github.com/lu-zero/postproc;protocol=https"
12
13S = "${WORKDIR}/git"
14
15inherit autotools lib_package pkgconfig
16
17FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math"
18BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
19
20EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
21EXTRA_FFCONF ?= ""
22
23EXTRA_OECONF = " \
24 --enable-shared \
25 --enable-pthreads \
26 --enable-gpl \
27 --enable-postproc \
28 \
29 --cross-prefix=${TARGET_PREFIX} \
30 --prefix=${prefix} \
31 \
32 --arch=${TARGET_ARCH} \
33 --target-os="linux" \
34 --enable-cross-compile \
35 --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
36 --extra-ldflags="${TARGET_LDFLAGS}" \
37 --sysroot="${STAGING_DIR_TARGET}" \
38 ${EXTRA_FFCONF} \
39"
40
41do_configure() {
42 ${S}/configure ${EXTRA_OECONF}
43}