summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-switch-to-python3.patch101
-rw-r--r--meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-use-python3-interpreter.patch28
-rw-r--r--meta-oe/recipes-support/libteam/libteam_1.31.bb2
3 files changed, 102 insertions, 29 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-switch-to-python3.patch b/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-switch-to-python3.patch
new file mode 100644
index 000000000..69276aba9
--- /dev/null
+++ b/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-switch-to-python3.patch
@@ -0,0 +1,101 @@
1From 06050e79655f0fa7d9daeda1fbd3a9a2c7736841 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 2 Dec 2021 15:08:25 +0800
4Subject: [PATCH] team_basic_test.py: switch to python3
5
6Switch the script team_basic_test.py to python3
7
8Upstream-Status: Submitted [https://github.com/jpirko/libteam/pull/63]
9
10Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
11---
12 scripts/team_basic_test.py | 28 ++++++++++++++--------------
13 1 file changed, 14 insertions(+), 14 deletions(-)
14
15diff --git a/scripts/team_basic_test.py b/scripts/team_basic_test.py
16index faabd18..0b64af2 100755
17--- a/scripts/team_basic_test.py
18+++ b/scripts/team_basic_test.py
19@@ -1,4 +1,4 @@
20-#! /usr/bin/env python
21+#! /usr/bin/env python3
22 """
23 Basic test.
24
25@@ -32,11 +32,11 @@ def usage():
26 """
27 Print usage of this app
28 """
29- print "Usage: team_basic_test.py [OPTION...]"
30- print ""
31- print " -h, --help print this message"
32- print " -c, --loop-count=NUMBER number of loops (default 1)"
33- print " -p, --port=NETDEV port device (can be defined multiple times)"
34+ print("Usage: team_basic_test.py [OPTION...]")
35+ print("")
36+ print(" -h, --help print this message")
37+ print(" -c, --loop-count=NUMBER number of loops (default 1)")
38+ print(" -p, --port=NETDEV port device (can be defined multiple times)")
39 sys.exit()
40
41 class CmdExecFailedException(Exception):
42@@ -55,15 +55,15 @@ class CmdExecUnexpectedOutputException(Exception):
43 return "Command execution output unexpected: \"%s\" != \"%s\"" % (self.__output, self.__expected_output)
44
45 def print_output(out_type, string):
46- print("%s:\n"
47+ print(("%s:\n"
48 "----------------------------\n"
49 "%s"
50- "----------------------------" % (out_type, string))
51+ "----------------------------" % (out_type, string)))
52
53 def cmd_exec(cmd, expected_output=None, cleaner=False):
54 cmd = cmd.rstrip(" ")
55 if not cleaner:
56- print("# \"%s\"" % cmd)
57+ print(("# \"%s\"" % cmd))
58 subp = subprocess.Popen(cmd, shell=True, stdout=subprocess.PIPE,
59 stderr=subprocess.PIPE)
60 (data_stdout, data_stderr) = subp.communicate()
61@@ -74,7 +74,7 @@ def cmd_exec(cmd, expected_output=None, cleaner=False):
62 if data_stderr:
63 print_output("Stderr", data_stderr)
64 raise CmdExecFailedException(subp.returncode)
65- output = data_stdout.rstrip()
66+ output = (data_stdout.rstrip()).decode()
67 if expected_output:
68 if output != expected_output:
69 raise CmdExecUnexpectedOutputException(output, expected_output)
70@@ -166,7 +166,7 @@ TEAM_PORT_CONFIG='{"prio": 10}'
71 os.removedirs("/tmp/team_test/")
72
73 def _run_one_loop(self, run_nr):
74- print "RUN #%d" % (run_nr)
75+ print("RUN #%d" % (run_nr))
76 self._created_teams = []
77 try:
78 for mode_name in self._team_modes:
79@@ -176,7 +176,7 @@ TEAM_PORT_CONFIG='{"prio": 10}'
80 cmd_exec("modprobe -r team_mode_loadbalance team_mode_roundrobin team_mode_activebackup team_mode_broadcast team");
81
82 def run(self):
83- for i in xrange(self._loop_count):
84+ for i in range(self._loop_count):
85 self._run_one_loop(i + 1)
86
87 def main():
88@@ -186,8 +186,8 @@ def main():
89 "hc:p:",
90 ["help", "loop-count=", "port="]
91 )
92- except getopt.GetoptError, err:
93- print str(err)
94+ except getopt.GetoptError as err:
95+ print(str(err))
96 usage()
97
98 btest = TeamBasicTest()
99--
1002.17.1
101
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-use-python3-interpreter.patch b/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-use-python3-interpreter.patch
deleted file mode 100644
index e27e4f329..000000000
--- a/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-use-python3-interpreter.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 571c141b434dff13494c6a3afe621f63a8e610e9 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.z@gmail.com>
3Date: Mon, 27 Jan 2020 14:29:34 +0000
4Subject: [PATCH] team_basic_test.py: use python3 interpreter
5
6Use python3 since python2 is EOL and has been removed from several
7distributions.
8
9Upstream-Status: Pending
10
11Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
12---
13 scripts/team_basic_test.py | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/scripts/team_basic_test.py b/scripts/team_basic_test.py
17index b05be9e..ad980e8 100755
18--- a/scripts/team_basic_test.py
19+++ b/scripts/team_basic_test.py
20@@ -1,4 +1,4 @@
21-#! /usr/bin/env python
22+#! /usr/bin/env python3
23 """
24 Basic test.
25
26--
272.17.1
28
diff --git a/meta-oe/recipes-support/libteam/libteam_1.31.bb b/meta-oe/recipes-support/libteam/libteam_1.31.bb
index f1cad9321..a3bed722e 100644
--- a/meta-oe/recipes-support/libteam/libteam_1.31.bb
+++ b/meta-oe/recipes-support/libteam/libteam_1.31.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://github.com/jpirko/libteam;branch=master;protocol=https \
11 file://0001-include-sys-select.h-for-fd_set-definition.patch \ 11 file://0001-include-sys-select.h-for-fd_set-definition.patch \
12 file://0002-teamd-Re-adjust-include-header-order.patch \ 12 file://0002-teamd-Re-adjust-include-header-order.patch \
13 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ 13 file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \
14 file://0001-team_basic_test.py-use-python3-interpreter.patch \ 14 file://0001-team_basic_test.py-switch-to-python3.patch \
15 file://run-ptest \ 15 file://run-ptest \
16 " 16 "
17SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158" 17SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158"