diff options
-rw-r--r-- | meta-networking/recipes-connectivity/mosquitto/files/1571.patch | 2 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch | 14 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.7.bb (renamed from meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb) | 18 |
3 files changed, 11 insertions, 23 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/1571.patch b/meta-networking/recipes-connectivity/mosquitto/files/1571.patch index 93ff6bcfa..37560f30c 100644 --- a/meta-networking/recipes-connectivity/mosquitto/files/1571.patch +++ b/meta-networking/recipes-connectivity/mosquitto/files/1571.patch | |||
@@ -11,7 +11,7 @@ Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> | |||
11 | 11 | ||
12 | --- a/lib/CMakeLists.txt | 12 | --- a/lib/CMakeLists.txt |
13 | +++ b/lib/CMakeLists.txt | 13 | +++ b/lib/CMakeLists.txt |
14 | @@ -89,6 +89,8 @@ | 14 | @@ -94,6 +94,8 @@ |
15 | OUTPUT_NAME mosquitto | 15 | OUTPUT_NAME mosquitto |
16 | VERSION ${VERSION} | 16 | VERSION ${VERSION} |
17 | SOVERSION 1 | 17 | SOVERSION 1 |
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch b/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch deleted file mode 100644 index 1397fc6a2..000000000 --- a/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | Description: Also install mqtt_protocol.h, as is done in Makefile | ||
2 | Author: Gianfranco Costamagna <locutusofborg@debian.org> | ||
3 | Bug-Debian: https://bugs.debian.org/951116 | ||
4 | Forwarded: https://github.com/eclipse/mosquitto/pull/1599 | ||
5 | Last-Update: 2020-02-15 | ||
6 | |||
7 | --- a/lib/CMakeLists.txt | ||
8 | +++ b/lib/CMakeLists.txt | ||
9 | @@ -114,4 +114,4 @@ | ||
10 | install(TARGETS libmosquitto_static ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}") | ||
11 | endif (WITH_STATIC_LIBRARIES) | ||
12 | |||
13 | -install(FILES mosquitto.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}") | ||
14 | +install(FILES mqtt_protocol.h mosquitto.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}") | ||
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.7.bb index 36bfe099f..06220327e 100644 --- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb +++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.7.bb | |||
@@ -6,22 +6,21 @@ provides a lightweight method of carrying out messaging using a \ | |||
6 | publish/subscribe model. " | 6 | publish/subscribe model. " |
7 | HOMEPAGE = "http://mosquitto.org/" | 7 | HOMEPAGE = "http://mosquitto.org/" |
8 | SECTION = "console/network" | 8 | SECTION = "console/network" |
9 | LICENSE = "EPL-1.0 | EDL-1.0" | 9 | LICENSE = "EPL-2.0 | EDL-1.0" |
10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=62ddc846179e908dc0c8efec4a42ef20 \ | 10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ca9a8f366c6babf593e374d0d7d58749 \ |
11 | file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \ | 11 | file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \ |
12 | file://epl-v10;md5=8d383c379e91d20ba18a52c3e7d3a979 \ | 12 | file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \ |
13 | file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \ | 13 | file://notice.html;md5=541f8f37af492858dab8d2c1b69ede69 \ |
14 | " | 14 | " |
15 | DEPENDS = "uthash" | 15 | DEPENDS = "uthash cjson dlt-daemon" |
16 | 16 | ||
17 | SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \ | 17 | SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \ |
18 | file://mosquitto.init \ | 18 | file://mosquitto.init \ |
19 | file://1571.patch \ | 19 | file://1571.patch \ |
20 | file://install-protocol.patch \ | ||
21 | " | 20 | " |
22 | 21 | ||
23 | SRC_URI[md5sum] = "beb8d76d6e45f1e66d711006082a631f" | 22 | SRC_URI[md5sum] = "56de4e27533ab53697245809feea95bf" |
24 | SRC_URI[sha256sum] = "548d73d19fb787dd0530334e398fd256ef3a581181678488a741a995c4f007fb" | 23 | SRC_URI[sha256sum] = "a98054f0b8161588975ef24e1d467550d3935f4c16ccee63ecb623248a28356e" |
25 | 24 | ||
26 | inherit systemd update-rc.d useradd cmake | 25 | inherit systemd update-rc.d useradd cmake |
27 | 26 | ||
@@ -29,6 +28,7 @@ PACKAGECONFIG ??= "ssl dlt websockets \ | |||
29 | ${@bb.utils.filter('DISTRO_FEATURES','systemd', d)} \ | 28 | ${@bb.utils.filter('DISTRO_FEATURES','systemd', d)} \ |
30 | " | 29 | " |
31 | 30 | ||
31 | PACKAGECONFIG[manpages] = "-DDOCUMENTATION=ON,-DDOCUMENTATION=OFF,libxslt-native docbook-xsl-stylesheets-native" | ||
32 | PACKAGECONFIG[dns-srv] = "-DWITH_SRV=ON,-DWITH_SRV=OFF,c-ares" | 32 | PACKAGECONFIG[dns-srv] = "-DWITH_SRV=ON,-DWITH_SRV=OFF,c-ares" |
33 | PACKAGECONFIG[ssl] = "-DWITH_TLS=ON -DWITH_TLS_PSK=ON -DWITH_EC=ON,-DWITH_TLS=OFF -DWITH_TLS_PSK=OFF -DWITH_EC=OFF,openssl" | 33 | PACKAGECONFIG[ssl] = "-DWITH_TLS=ON -DWITH_TLS_PSK=ON -DWITH_EC=ON,-DWITH_TLS=OFF -DWITH_TLS_PSK=OFF -DWITH_EC=OFF,openssl" |
34 | PACKAGECONFIG[systemd] = "-DWITH_SYSTEMD=ON,-DWITH_SYSTEMD=OFF,systemd" | 34 | PACKAGECONFIG[systemd] = "-DWITH_SYSTEMD=ON,-DWITH_SYSTEMD=OFF,systemd" |
@@ -59,6 +59,8 @@ PACKAGE_BEFORE_PN = "${PN}-examples" | |||
59 | 59 | ||
60 | FILES_${PN} = "${sbindir}/mosquitto \ | 60 | FILES_${PN} = "${sbindir}/mosquitto \ |
61 | ${bindir}/mosquitto_passwd \ | 61 | ${bindir}/mosquitto_passwd \ |
62 | ${bindir}/mosquitto_ctrl \ | ||
63 | ${libdir}/mosquitto_dynamic_security.so \ | ||
62 | ${sysconfdir}/mosquitto \ | 64 | ${sysconfdir}/mosquitto \ |
63 | ${sysconfdir}/init.d \ | 65 | ${sysconfdir}/init.d \ |
64 | ${systemd_unitdir}/system/mosquitto.service \ | 66 | ${systemd_unitdir}/system/mosquitto.service \ |