summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/pcp/pcp.inc2
-rw-r--r--meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch29
-rw-r--r--meta-oe/recipes-support/pcp/pcp_5.3.5.bb3
3 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/pcp/pcp.inc b/meta-oe/recipes-support/pcp/pcp.inc
index f6f111b0e..d50e7b091 100644
--- a/meta-oe/recipes-support/pcp/pcp.inc
+++ b/meta-oe/recipes-support/pcp/pcp.inc
@@ -29,4 +29,6 @@ EXTRA_OECONF:append = " --with-dstat-symlink=yes --with-infiniband=no \
29 --with-docdir=${docdir} \ 29 --with-docdir=${docdir} \
30 " 30 "
31 31
32PACKAGECONFIG[qt5] = "--with-qt=yes --with-qt3d=yes,--with-qt=no --with-qt3d=no,qtbase qt3d"
32 33
34PACKAGECONFIG ?= ""
diff --git a/meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch b/meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch
new file mode 100644
index 000000000..6fa864cd2
--- /dev/null
+++ b/meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch
@@ -0,0 +1,29 @@
1Do not pass cr option
2
3These options are already coming from builddefs
4
5Upstream-Status: Pending
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
8--- a/src/include/builddefs.in
9+++ b/src/include/builddefs.in
10@@ -167,7 +167,7 @@ OBJECTS = $(ASFILES:.s=.o) \
11
12 #NB: don't override $(MAKE); gnumake sets it well, propagating -j etc.
13 #MAKE = @make@
14-AR = @ar@
15+AR = @ar@ cqs
16 CC = @cc@
17 CXX = @cxx@
18 LD = @ld@
19--- a/src/include/buildrules
20+++ b/src/include/buildrules
21@@ -93,7 +93,7 @@ $(STATICLIBTARGET) : $(SUBDIRS) $(OBJECT
22 ifeq ($(TARGET_OS), darwin)
23 libtool -static -o $(STATICLIBTARGET) $?
24 else
25- $(AR) cr $(STATICLIBTARGET) $?
26+ $(AR) $(STATICLIBTARGET) $?
27 endif
28 endif
29
diff --git a/meta-oe/recipes-support/pcp/pcp_5.3.5.bb b/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
index 2dafab1b5..cdf506577 100644
--- a/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
+++ b/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
@@ -11,11 +11,12 @@ DEPENDS += "perl-native bison-native flex-native python3-native python3-setuptoo
11 11
12 12
13SRC_URI += "file://0001-Remove-unsuitble-part-for-cross-compile.patch \ 13SRC_URI += "file://0001-Remove-unsuitble-part-for-cross-compile.patch \
14 file://pass-options-to-AR.patch \
14 " 15 "
15 16
16export PCP_DIR="${RECIPE_SYSROOT_NATIVE}" 17export PCP_DIR="${RECIPE_SYSROOT_NATIVE}"
17#export PCP_RUN_DIR="${RECIPE_SYSROOT_NATIVE}" 18#export PCP_RUN_DIR="${RECIPE_SYSROOT_NATIVE}"
18EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}"" 19EXTRA_OEMAKE = "CC="${CC}" LD="${LD}""
19inherit useradd systemd 20inherit useradd systemd
20 21
21SYSTEMD_AUTO_ENABLE:${PN} = "enable" 22SYSTEMD_AUTO_ENABLE:${PN} = "enable"