diff options
3 files changed, 39 insertions, 30 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch new file mode 100644 index 000000000..f6147cbf3 --- /dev/null +++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 5af6dec8764375ca4f13bd9fed96af090228351a Mon Sep 17 00:00:00 2001 | ||
2 | From: "Gary S. Robertson" <gary.robertson@linaro.org> | ||
3 | Date: Mon, 11 Aug 2014 11:06:04 -0500 | ||
4 | Subject: [libhugetlbfs][PATCH] Extend arm32 support to include BE variants | ||
5 | |||
6 | This patch applies the same technique used by Koen Kool in the following patch | ||
7 | which was accepted by the libhugetlbfs project: | ||
8 | |||
9 | [0a4f6] Add aarch64_be_support 2014-03-31 10:52:37 | ||
10 | |||
11 | It modifies the libhugetlbfs Makefile to mark all 32-bit arm architectures | ||
12 | as supported by the libhugetlbfs build. Builds and successful functional | ||
13 | tests have been performed for armv7a LE and BE runtime platforms. | ||
14 | |||
15 | This patch replaces and renders obsolete the following patch: | ||
16 | arm32-support.patch submitted by: Chunrong Guo <B40290@freescale.com> | ||
17 | |||
18 | Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> | ||
19 | --- | ||
20 | Makefile | 2 +- | ||
21 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/Makefile b/Makefile | ||
24 | index 91502e1..ba79607 100644 | ||
25 | --- a/Makefile | ||
26 | +++ b/Makefile | ||
27 | @@ -59,7 +59,7 @@ ELF32 = elf32ppclinux | ||
28 | TMPLIB32 = lib | ||
29 | CPPFLAGS += -DPPC_NO_SEGMENTS | ||
30 | else | ||
31 | -ifeq ($(ARCH),armv7l) | ||
32 | +ifneq (,$(findstring arm,$(ARCH))) | ||
33 | CC32 = $(CC) | ||
34 | TMPLIB32 = lib | ||
35 | ELF32 += armelf_linux_eabi | ||
36 | -- | ||
37 | 1.7.9.5 | ||
38 | |||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch deleted file mode 100644 index 96f162dd9..000000000 --- a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | |||
3 | This patch adds support for arm32. | ||
4 | |||
5 | Signed-off-by: Chunrong Guo <B40290@freescale.com> | ||
6 | |||
7 | --- a/Makefileold 2014-06-17 21:55:23.131058918 -0500 | ||
8 | +++ b/Makefile 2014-06-17 21:56:08.726098531 -0500 | ||
9 | @@ -59,6 +59,12 @@ | ||
10 | TMPLIB32 = lib | ||
11 | CPPFLAGS += -DPPC_NO_SEGMENTS | ||
12 | else | ||
13 | +ifeq ($(ARCH),arm) | ||
14 | +CC32 = $(CC) | ||
15 | +TMPLIB32 = lib | ||
16 | +ELF32 += armelf_linux_eabi | ||
17 | +CUSTOM_LDSCRIPTS = no | ||
18 | +else | ||
19 | ifeq ($(ARCH),armv7l) | ||
20 | CC32 = $(CC) | ||
21 | TMPLIB32 = lib | ||
22 | @@ -116,6 +122,7 @@ | ||
23 | endif | ||
24 | endif | ||
25 | endif | ||
26 | +endif | ||
27 | |||
28 | ifdef CC32 | ||
29 | OBJDIRS += obj32 | ||
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb index 315863db7..851b050eb 100644 --- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb +++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb | |||
@@ -17,7 +17,7 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \ | |||
17 | file://0001-aarch64-fix-cross-compilation.patch \ | 17 | file://0001-aarch64-fix-cross-compilation.patch \ |
18 | file://0001-aarch64-fix-page-size-not-properly-computed.patch \ | 18 | file://0001-aarch64-fix-page-size-not-properly-computed.patch \ |
19 | file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ | 19 | file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ |
20 | file://arm32-support.patch \ | 20 | file://0001-Extend-arm32-support-to-include-BE-variants.patch \ |
21 | " | 21 | " |
22 | 22 | ||
23 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |