diff options
-rw-r--r-- | meta-oe/recipes-security/audit/audit/0001-Fixed-swig-host-contamination-issue.patch (renamed from meta-oe/recipes-security/audit/audit/Fixed-swig-host-contamination-issue.patch) | 21 | ||||
-rw-r--r-- | meta-oe/recipes-security/audit/audit/0002-Replace-__attribute_malloc__-with-__attribute__-__ma.patch (renamed from meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch) | 15 | ||||
-rw-r--r-- | meta-oe/recipes-security/audit/audit_3.1.2.bb (renamed from meta-oe/recipes-security/audit/audit_3.1.1.bb) | 6 |
3 files changed, 24 insertions, 18 deletions
diff --git a/meta-oe/recipes-security/audit/audit/Fixed-swig-host-contamination-issue.patch b/meta-oe/recipes-security/audit/audit/0001-Fixed-swig-host-contamination-issue.patch index b023c80ae4..5f2ecc1417 100644 --- a/meta-oe/recipes-security/audit/audit/Fixed-swig-host-contamination-issue.patch +++ b/meta-oe/recipes-security/audit/audit/0001-Fixed-swig-host-contamination-issue.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 3d13f92c1bb293523670ba01aea7e655b00a6709 Mon Sep 17 00:00:00 2001 | 1 | From 9a32d42dfc6713fd0085dd4563a934afc30ec097 Mon Sep 17 00:00:00 2001 |
2 | From: Li xin <lixin.fnst@cn.fujitsu.com> | 2 | From: Li xin <lixin.fnst@cn.fujitsu.com> |
3 | Date: Sun, 19 Jul 2015 02:42:58 +0900 | 3 | Date: Sun, 19 Jul 2015 02:42:58 +0900 |
4 | Subject: [PATCH] audit: Fixed swig host contamination issue | 4 | Subject: [PATCH] Fixed swig host contamination issue |
5 | 5 | ||
6 | The audit build uses swig to generate a python wrapper. | 6 | The audit build uses swig to generate a python wrapper. |
7 | Unfortunately, the swig info file references host include | 7 | Unfortunately, the swig info file references host include |
@@ -18,6 +18,8 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
18 | bindings/swig/src/auditswig.i | 2 +- | 18 | bindings/swig/src/auditswig.i | 2 +- |
19 | 2 files changed, 3 insertions(+), 2 deletions(-) | 19 | 2 files changed, 3 insertions(+), 2 deletions(-) |
20 | 20 | ||
21 | diff --git a/bindings/swig/python3/Makefile.am b/bindings/swig/python3/Makefile.am | ||
22 | index 6131e80d..2fb7207b 100644 | ||
21 | --- a/bindings/swig/python3/Makefile.am | 23 | --- a/bindings/swig/python3/Makefile.am |
22 | +++ b/bindings/swig/python3/Makefile.am | 24 | +++ b/bindings/swig/python3/Makefile.am |
23 | @@ -23,6 +23,7 @@ | 25 | @@ -23,6 +23,7 @@ |
@@ -28,7 +30,7 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
28 | LIBS = $(top_builddir)/lib/libaudit.la | 30 | LIBS = $(top_builddir)/lib/libaudit.la |
29 | SWIG_FLAGS = -python -py3 -modern | 31 | SWIG_FLAGS = -python -py3 -modern |
30 | SWIG_INCLUDES = -I. -I$(top_builddir) -I${top_srcdir}/lib $(PYTHON3_INCLUDES) | 32 | SWIG_INCLUDES = -I. -I$(top_builddir) -I${top_srcdir}/lib $(PYTHON3_INCLUDES) |
31 | @@ -37,7 +38,7 @@ _audit_la_DEPENDENCIES =${top_srcdir}/li | 33 | @@ -37,7 +38,7 @@ _audit_la_DEPENDENCIES =${top_srcdir}/lib/libaudit.h ${top_builddir}/lib/libaudi |
32 | _audit_la_LIBADD = ${top_builddir}/lib/libaudit.la | 34 | _audit_la_LIBADD = ${top_builddir}/lib/libaudit.la |
33 | nodist__audit_la_SOURCES = audit_wrap.c | 35 | nodist__audit_la_SOURCES = audit_wrap.c |
34 | audit.py audit_wrap.c: ${srcdir}/../src/auditswig.i | 36 | audit.py audit_wrap.c: ${srcdir}/../src/auditswig.i |
@@ -37,14 +39,19 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
37 | 39 | ||
38 | CLEANFILES = audit.py* audit_wrap.c *~ | 40 | CLEANFILES = audit.py* audit_wrap.c *~ |
39 | 41 | ||
42 | diff --git a/bindings/swig/src/auditswig.i b/bindings/swig/src/auditswig.i | ||
43 | index 9a2c5661..6cbb7295 100644 | ||
40 | --- a/bindings/swig/src/auditswig.i | 44 | --- a/bindings/swig/src/auditswig.i |
41 | +++ b/bindings/swig/src/auditswig.i | 45 | +++ b/bindings/swig/src/auditswig.i |
42 | @@ -39,7 +39,7 @@ signed | 46 | @@ -43,7 +43,7 @@ typedef unsigned uid_t; |
43 | #define __attribute(X) /*nothing*/ | 47 | * generating setters against them: https://github.com/swig/swig/issues/1699 |
44 | typedef unsigned __u32; | 48 | */ |
45 | typedef unsigned uid_t; | 49 | %ignore audit_rule_data::buf; |
46 | -%include "/usr/include/linux/audit.h" | 50 | -%include "/usr/include/linux/audit.h" |
47 | +%include "../lib/audit.h" | 51 | +%include "../lib/audit.h" |
48 | #define __extension__ /*nothing*/ | 52 | #define __extension__ /*nothing*/ |
49 | %include <stdint.i> | 53 | %include <stdint.i> |
50 | %include "../lib/libaudit.h" | 54 | %include "../lib/libaudit.h" |
55 | -- | ||
56 | 2.25.1 | ||
57 | |||
diff --git a/meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch b/meta-oe/recipes-security/audit/audit/0002-Replace-__attribute_malloc__-with-__attribute__-__ma.patch index 23747c45f0..7f0af74a8c 100644 --- a/meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch +++ b/meta-oe/recipes-security/audit/audit/0002-Replace-__attribute_malloc__-with-__attribute__-__ma.patch | |||
@@ -1,8 +1,7 @@ | |||
1 | From 79c8d6a2755c9dfa00a5e86378e89a94eef0504d Mon Sep 17 00:00:00 2001 | 1 | From 679cb57fa93984fed345dd3890cdbcbaa24e8518 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Tue, 9 Aug 2022 23:57:03 -0700 | 3 | Date: Tue, 9 Aug 2022 23:57:03 -0700 |
4 | Subject: [PATCH] Replace __attribute_malloc__ with | 4 | Subject: [PATCH] Replace __attribute_malloc__ with __attribute__((__malloc__)) |
5 | __attribute__((__malloc__)) | ||
6 | 5 | ||
7 | __attribute_malloc__ is not available on musl | 6 | __attribute_malloc__ is not available on musl |
8 | 7 | ||
@@ -11,18 +10,18 @@ Fixes | |||
11 | | __attribute_malloc__ __attr_dealloc (auparse_destroy, 1); | 10 | | __attribute_malloc__ __attr_dealloc (auparse_destroy, 1); |
12 | | ^ | 11 | | ^ |
13 | 12 | ||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | Upstream-Status: Pending | 13 | Upstream-Status: Pending |
17 | 14 | ||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
18 | auparse/auparse.h | 2 +- | 17 | auparse/auparse.h | 2 +- |
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | 18 | 1 file changed, 1 insertion(+), 1 deletion(-) |
20 | 19 | ||
21 | diff --git a/auparse/auparse.h b/auparse/auparse.h | 20 | diff --git a/auparse/auparse.h b/auparse/auparse.h |
22 | index 95cf256d..c7dbe5ff 100644 | 21 | index 5cb7402e..39156eff 100644 |
23 | --- a/auparse/auparse.h | 22 | --- a/auparse/auparse.h |
24 | +++ b/auparse/auparse.h | 23 | +++ b/auparse/auparse.h |
25 | @@ -51,7 +51,7 @@ typedef void (*auparse_callback_ptr)(auparse_state_t *au, | 24 | @@ -54,7 +54,7 @@ typedef void (*auparse_callback_ptr)(auparse_state_t *au, |
26 | void auparse_destroy(auparse_state_t *au); | 25 | void auparse_destroy(auparse_state_t *au); |
27 | void auparse_destroy_ext(auparse_state_t *au, auparse_destroy_what_t what); | 26 | void auparse_destroy_ext(auparse_state_t *au, auparse_destroy_what_t what); |
28 | auparse_state_t *auparse_init(ausource_t source, const void *b) | 27 | auparse_state_t *auparse_init(ausource_t source, const void *b) |
@@ -32,5 +31,5 @@ index 95cf256d..c7dbe5ff 100644 | |||
32 | __attr_access ((__read_only__, 2, 3)); | 31 | __attr_access ((__read_only__, 2, 3)); |
33 | int auparse_feed(auparse_state_t *au, const char *data, size_t data_len) | 32 | int auparse_feed(auparse_state_t *au, const char *data, size_t data_len) |
34 | -- | 33 | -- |
35 | 2.37.1 | 34 | 2.25.1 |
36 | 35 | ||
diff --git a/meta-oe/recipes-security/audit/audit_3.1.1.bb b/meta-oe/recipes-security/audit/audit_3.1.2.bb index 7ed2fd2dec..5380e90223 100644 --- a/meta-oe/recipes-security/audit/audit_3.1.1.bb +++ b/meta-oe/recipes-security/audit/audit_3.1.2.bb | |||
@@ -8,15 +8,15 @@ LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later" | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/linux-audit/${BPN}-userspace.git;branch=master;protocol=https \ | 10 | SRC_URI = "git://github.com/linux-audit/${BPN}-userspace.git;branch=master;protocol=https \ |
11 | file://Fixed-swig-host-contamination-issue.patch \ | 11 | file://0001-Fixed-swig-host-contamination-issue.patch \ |
12 | file://0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch \ | 12 | file://0002-Replace-__attribute_malloc__-with-__attribute__-__ma.patch \ |
13 | file://auditd \ | 13 | file://auditd \ |
14 | file://auditd.service \ | 14 | file://auditd.service \ |
15 | file://audit-volatile.conf \ | 15 | file://audit-volatile.conf \ |
16 | " | 16 | " |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | SRCREV = "6e367585a899231da05797c6126f8bb01febb2f5" | 19 | SRCREV = "572eb7d4fe926e7c1c52166d08e78af54877cbc5" |
20 | 20 | ||
21 | inherit autotools python3targetconfig update-rc.d systemd | 21 | inherit autotools python3targetconfig update-rc.d systemd |
22 | 22 | ||