summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb (renamed from meta-oe/recipes-support/dfu-util/dfu-util-native_0.8.bb)7
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util/0001-Revert-Makefile.am-Drop-static-dfu-util.patch (renamed from meta-oe/recipes-support/dfu-util/dfu-util/0002-Revert-Makefile.am-Drop-static-dfu-util.patch)6
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util/0001-configure.ac-Don-t-check-for-usbpath.patch38
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util_0.8.bb17
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb14
5 files changed, 19 insertions, 63 deletions
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.8.bb b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
index 8be9d850e..7a7a662ab 100644
--- a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.8.bb
+++ b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
@@ -1,19 +1,16 @@
1require dfu-util_${PV}.bb 1require dfu-util_${PV}.bb
2 2
3inherit native deploy 3inherit native deploy
4do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
5 4
6DEPENDS = "libusb1-native" 5DEPENDS = "libusb1-native"
7 6
8FILESPATH =. "${FILE_DIRNAME}/${BPN}-${PV}:" 7SRC_URI += "file://0001-Revert-Makefile.am-Drop-static-dfu-util.patch"
9SRC_URI += "file://0002-Revert-Makefile.am-Drop-static-dfu-util.patch"
10 8
9do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
11do_deploy() { 10do_deploy() {
12 install -d ${DEPLOY_DIR_TOOLS} 11 install -d ${DEPLOY_DIR_TOOLS}
13 install -m 0755 src/dfu-util_static ${DEPLOY_DIR_TOOLS}/dfu-util-${PV} 12 install -m 0755 src/dfu-util_static ${DEPLOY_DIR_TOOLS}/dfu-util-${PV}
14 rm -f ${DEPLOY_DIR_TOOLS}/dfu-util 13 rm -f ${DEPLOY_DIR_TOOLS}/dfu-util
15 ln -sf ./dfu-util-${PV} ${DEPLOY_DIR_TOOLS}/dfu-util 14 ln -sf ./dfu-util-${PV} ${DEPLOY_DIR_TOOLS}/dfu-util
16
17} 15}
18
19addtask deploy before do_package after do_install 16addtask deploy before do_package after do_install
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util/0002-Revert-Makefile.am-Drop-static-dfu-util.patch b/meta-oe/recipes-support/dfu-util/dfu-util/0001-Revert-Makefile.am-Drop-static-dfu-util.patch
index 7bd965b0f..1c6ad0807 100644
--- a/meta-oe/recipes-support/dfu-util/dfu-util/0002-Revert-Makefile.am-Drop-static-dfu-util.patch
+++ b/meta-oe/recipes-support/dfu-util/dfu-util/0001-Revert-Makefile.am-Drop-static-dfu-util.patch
@@ -1,7 +1,7 @@
1From 7d613b28c1b48b5cc3a0882d24e0ac938faff4c2 Mon Sep 17 00:00:00 2001 1From c2aab3b9ae1febcb6b4c6561a59df1930a57b394 Mon Sep 17 00:00:00 2001
2From: Martin JaMa Jansa <Martin.Jansa@gmail.com> 2From: Martin JaMa Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 11 Aug 2011 11:19:52 +0200 3Date: Thu, 11 Aug 2011 11:19:52 +0200
4Subject: [PATCH 2/2] Revert "Makefile.am: Drop static dfu-util" 4Subject: [PATCH] Revert "Makefile.am: Drop static dfu-util"
5 5
6This reverts commit fe0426ddc04f503d148c5e5f931f16b8f674f071. 6This reverts commit fe0426ddc04f503d148c5e5f931f16b8f674f071.
7 7
@@ -12,7 +12,7 @@ Signed-off-by: Martin JaMa Jansa <Martin.Jansa@gmail.com>
12 2 files changed, 22 insertions(+), 2 deletions(-) 12 2 files changed, 22 insertions(+), 2 deletions(-)
13 13
14diff --git a/configure.ac b/configure.ac 14diff --git a/configure.ac b/configure.ac
15index a1dcc7a..bb71e02 100644 15index f5a43b8..6a3757e 100644
16--- a/configure.ac 16--- a/configure.ac
17+++ b/configure.ac 17+++ b/configure.ac
18@@ -21,7 +21,7 @@ AS_IF([test x$native_libusb = xno], [ 18@@ -21,7 +21,7 @@ AS_IF([test x$native_libusb = xno], [
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util/0001-configure.ac-Don-t-check-for-usbpath.patch b/meta-oe/recipes-support/dfu-util/dfu-util/0001-configure.ac-Don-t-check-for-usbpath.patch
deleted file mode 100644
index bab4a7134..000000000
--- a/meta-oe/recipes-support/dfu-util/dfu-util/0001-configure.ac-Don-t-check-for-usbpath.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From e1811274b61db0f5ca55c50ec96d799e2d85fa06 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sun, 3 Aug 2014 17:50:06 +0200
4Subject: [PATCH 1/2] configure.ac: Don't check for usbpath
5
6* otherwise it fails to build with -lusb
7 | main.o: In function `resolve_device_path':
8 | dfu-util/0.7-r0/dfu-util-0.7/src/main.c:371: undefined reference to `usb_path2devnum'
9 | collect2: error: ld returned 1 exit status
10
11Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12---
13 configure.ac | 3 +--
14 1 file changed, 1 insertion(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index 8622114..a1dcc7a 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -20,14 +20,13 @@ AS_IF([test x$native_libusb = xno], [
21 PKG_CHECK_MODULES([USB], [libusb-1.0 >= 1.0.0],,
22 AC_MSG_ERROR([*** Required libusb-1.0 >= 1.0.0 not installed ***]))
23 ])
24-AC_CHECK_LIB([usbpath],[usb_path2devnum],,,-lusb)
25
26 LIBS="$LIBS $USB_LIBS"
27 CFLAGS="$CFLAGS $USB_CFLAGS"
28
29 # Checks for header files.
30 AC_HEADER_STDC
31-AC_CHECK_HEADERS([usbpath.h windows.h sysexits.h])
32+AC_CHECK_HEADERS([windows.h sysexits.h])
33
34 # Checks for typedefs, structures, and compiler characteristics.
35 AC_C_CONST
36--
372.7.2
38
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util_0.8.bb b/meta-oe/recipes-support/dfu-util/dfu-util_0.8.bb
deleted file mode 100644
index 51f4ae1e1..000000000
--- a/meta-oe/recipes-support/dfu-util/dfu-util_0.8.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1DESCRIPTION = "USB Device Firmware Upgrade utility"
2SECTION = "devel"
3AUTHOR = "Harald Welte <laforge@openmoko.org>"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7
8SRC_URI = "http://dfu-util.gnumonks.org/releases/${BP}.tar.gz \
9 file://0001-configure.ac-Don-t-check-for-usbpath.patch \
10"
11
12inherit autotools pkgconfig
13
14DEPENDS = "libusb1"
15
16SRC_URI[md5sum] = "fc6daf6b0ee57d7e40ffa3e8111023d1"
17SRC_URI[sha256sum] = "55cbde9be12a212bd84bce9d1e63941d9a16139ed0d4912401367eba1502f058"
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb b/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb
new file mode 100644
index 000000000..01bca2294
--- /dev/null
+++ b/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb
@@ -0,0 +1,14 @@
1DESCRIPTION = "USB Device Firmware Upgrade utility"
2SECTION = "devel"
3AUTHOR = "Harald Welte <laforge@openmoko.org>"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7SRC_URI = "http://dfu-util.gnumonks.org/releases/${BP}.tar.gz"
8
9inherit autotools pkgconfig
10
11DEPENDS = "libusb1"
12
13SRC_URI[md5sum] = "233bb1e08ef4b405062445d84e28fde6"
14SRC_URI[sha256sum] = "36428c6a6cb3088cad5a3592933385253da5f29f2effa61518ee5991ea38f833"