diff options
-rw-r--r-- | meta-oe/recipes-kernel/minicoredumper/files/0001-fix-compile-error-on-arch-x32.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.0.bb | 7 |
2 files changed, 36 insertions, 3 deletions
diff --git a/meta-oe/recipes-kernel/minicoredumper/files/0001-fix-compile-error-on-arch-x32.patch b/meta-oe/recipes-kernel/minicoredumper/files/0001-fix-compile-error-on-arch-x32.patch new file mode 100644 index 000000000..6ba6ad481 --- /dev/null +++ b/meta-oe/recipes-kernel/minicoredumper/files/0001-fix-compile-error-on-arch-x32.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 883f53ee33eaef8aca1288a110857402ad362966 Mon Sep 17 00:00:00 2001 | ||
2 | From: John Ogness <john.ogness@linutronix.de> | ||
3 | Date: Fri, 8 Sep 2017 15:03:03 -0700 | ||
4 | Subject: [PATCH] fix compile error on arch=x32 | ||
5 | |||
6 | On the x32 architecture time_t is a "long long int". By | ||
7 | typecasting time_t to "long long", this should work correctly | ||
8 | for all architectures. | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | Upstream-Status: Pending | ||
13 | |||
14 | src/minicoredumper/corestripper.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/src/minicoredumper/corestripper.c b/src/minicoredumper/corestripper.c | ||
18 | index fd39bfb..07dc318 100644 | ||
19 | --- a/src/minicoredumper/corestripper.c | ||
20 | +++ b/src/minicoredumper/corestripper.c | ||
21 | @@ -1241,7 +1241,7 @@ static int dump_compressed_tar(struct dump_info *di) | ||
22 | snprintf(hdr.mode, sizeof(hdr.mode), "%07o", 0644); | ||
23 | snprintf(hdr.uid, sizeof(hdr.uid), "%07o", 0); | ||
24 | snprintf(hdr.gid, sizeof(hdr.gid), "%07o", 0); | ||
25 | - snprintf(hdr.mtime, sizeof(hdr.mtime), "%011lo", | ||
26 | + snprintf(hdr.mtime, sizeof(hdr.mtime), "%011llo", | ||
27 | (long long)time(NULL)); | ||
28 | memset(hdr.checksum, ' ', sizeof(hdr.checksum)); | ||
29 | hdr.type = 'S'; | ||
30 | -- | ||
31 | 2.14.1 | ||
32 | |||
diff --git a/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.0.bb b/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.0.bb index 3bf9f66b9..1858e102d 100644 --- a/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.0.bb +++ b/meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.0.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | SUMMARY = "minicoredumper provides an alternate core dump facility for Linux \ | 1 | SUMMARY = "minicoredumper provides an alternate core dump facility for Linux \ |
2 | to allow minimal and customized crash dumps" | 2 | to allow minimal and customized crash dumps" |
3 | LICENSE = " LGPLv2.1 & BSD-2-Clause" | 3 | LICENSE = " LGPLv2.1 & BSD-2-Clause" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=709087c2ed0acda54a4d91497a889e42 \ | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=aa846ae365f71b69e9fa0d21a56391ec \ |
5 | file://COPYING.BSD;md5=b915ac80d5236d6aa659cb986daf00e5 \ | 5 | file://COPYING.BSD;md5=b915ac80d5236d6aa659cb986daf00e5 \ |
6 | file://COPYING.LGPLv2.1;md5=321bf41f280cf805086dd5a720b37785 \ | 6 | file://COPYING.LGPLv2.1;md5=321bf41f280cf805086dd5a720b37785 \ |
7 | " | 7 | " |
@@ -9,14 +9,15 @@ DEPENDS = "elfutils dbus dbus-glib-native glib-2.0 dbus-glib util-linux json-c" | |||
9 | 9 | ||
10 | inherit autotools pkgconfig systemd update-rc.d | 10 | inherit autotools pkgconfig systemd update-rc.d |
11 | 11 | ||
12 | SRCREV = "248019446ccf6079926efb54f8b6dd7be769bbae" | 12 | SRCREV = "cdc1faf1212a51e89b477468876e229223fceb9a" |
13 | 13 | ||
14 | PR .= "+git${SRCPV}" | 14 | PR .= "+git${SRCPV}" |
15 | 15 | ||
16 | SRC_URI = "git://github.com/Linutronix/minicoredumper-debian;branch=unstable \ | 16 | SRC_URI = "git://git.linuxfoundation.org/diamon/minicoredumper.git;protocol=http \ |
17 | file://minicoredumper.service \ | 17 | file://minicoredumper.service \ |
18 | file://minicoredumper.init \ | 18 | file://minicoredumper.init \ |
19 | file://0001-minicoredumper-Initialize-pointer-to-config-struct-t.patch \ | 19 | file://0001-minicoredumper-Initialize-pointer-to-config-struct-t.patch \ |
20 | file://0001-fix-compile-error-on-arch-x32.patch \ | ||
20 | " | 21 | " |
21 | 22 | ||
22 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |