summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch30
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch4
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb (renamed from meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb)5
3 files changed, 35 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch b/meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch
new file mode 100644
index 000000000..2a583466e
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs/0001-Bug-fix-for-pid_t-not-found-on-musl.patch
@@ -0,0 +1,30 @@
1From d0d5ac317dab11610a5fc91ca3e7f5ad72ce2236 Mon Sep 17 00:00:00 2001
2From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
3Date: Tue, 29 Oct 2019 13:19:37 +0800
4Subject: [PATCH] Bug fix for pid_t not found on musl.
5
6When compiling version 5.1.6 on musl, the following error occurs:
7log.h:49:8: error: unknown type name 'pid_t'
8
9Upstream-Status: Pending
10
11Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
12---
13 lib/defaults.c | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/lib/defaults.c b/lib/defaults.c
17index a6ea116..b3ecfa5 100644
18--- a/lib/defaults.c
19+++ b/lib/defaults.c
20@@ -21,6 +21,7 @@
21 #include <string.h>
22 #include <sys/utsname.h>
23 #include <sys/stat.h>
24+#include <sys/types.h>
25 #include <stdarg.h>
26
27 #include "config.h"
28--
292.20.1
30
diff --git a/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch b/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch
index 410827b33..b991acad3 100644
--- a/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch
+++ b/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch
@@ -9,7 +9,7 @@ Upstream-Status: Pending
9 9
10Signed-off-by: Khem Raj <raj.khem@gmail.com> 10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11 11
12update patch to version 5.1.5 12update patch to version 5.1.6
13Signed-off-by: Changqing Li <changqing.li@windriver.com> 13Signed-off-by: Changqing Li <changqing.li@windriver.com>
14--- 14---
15 configure.in | 2 +- 15 configure.in | 2 +-
@@ -20,7 +20,7 @@ index 493b9f1..268d06b 100644
20--- a/configure.in 20--- a/configure.in
21+++ b/configure.in 21+++ b/configure.in
22@@ -12,7 +12,7 @@ define([AC_CACHE_SAVE], )dnl 22@@ -12,7 +12,7 @@ define([AC_CACHE_SAVE], )dnl
23 AC_INIT(.autofs-5.1.5) 23 AC_INIT(.autofs-5.1.6)
24 24
25 # for pkg-config macros 25 # for pkg-config macros
26-m4_include([/usr/share/aclocal/pkg.m4]) 26-m4_include([/usr/share/aclocal/pkg.m4])
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb
index 9e43549e8..aeadc9d5d 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.1.5.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb
@@ -25,11 +25,12 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
25 file://pkgconfig-libnsl.patch \ 25 file://pkgconfig-libnsl.patch \
26 file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \ 26 file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \
27 file://0001-Do-not-hardcode-path-for-pkg.m4.patch \ 27 file://0001-Do-not-hardcode-path-for-pkg.m4.patch \
28 file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \
28 " 29 "
29 30
30 31
31SRC_URI[md5sum] = "03b13168ec7bd66a6f2d5f6fea705eee" 32SRC_URI[md5sum] = "e6800e0afd6009ecdff148088c564050"
32SRC_URI[sha256sum] = "86a8e56ea9d72bb53ff8cdfeefb5cafe983592c6b0178fb99c4a731e59879181" 33SRC_URI[sha256sum] = "82094cad44f4e5c4f93eff2789cd66b57d7ab3fa646b7722d97608571001e694"
33 34
34UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/" 35UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/"
35 36