summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-test/testfloat/files/0001-Makefile-for-cross-compile-SoftFloat.patch135
-rw-r--r--meta-oe/recipes-test/testfloat/files/0002-Makefile-for-cross-compile-TestFloat.patch117
-rw-r--r--meta-oe/recipes-test/testfloat/testfloat_3e.bb (renamed from meta-oe/recipes-test/testfloat/testfloat_3a.bb)15
3 files changed, 183 insertions, 84 deletions
diff --git a/meta-oe/recipes-test/testfloat/files/0001-Makefile-for-cross-compile-SoftFloat.patch b/meta-oe/recipes-test/testfloat/files/0001-Makefile-for-cross-compile-SoftFloat.patch
index 71782c5b9..9f41bf2da 100644
--- a/meta-oe/recipes-test/testfloat/files/0001-Makefile-for-cross-compile-SoftFloat.patch
+++ b/meta-oe/recipes-test/testfloat/files/0001-Makefile-for-cross-compile-SoftFloat.patch
@@ -1,32 +1,34 @@
1Upstream-Status: Inappropriate [configuration] 1From 99b62670d01c6081d883303722726beb65699cbb Mon Sep 17 00:00:00 2001
2From: Zong Li <zong.li@sifive.com>
3Date: Wed, 6 May 2020 01:23:22 -0700
4Subject: [PATCH] Makefile for cross compile SoftFloat 3e
2 5
3From 07f2528d93f44fe1d8080a4225f29f4ada9f4663 Mon Sep 17 00:00:00 2001 6This commit adds a Makefile for cross compile on SoftFloat
4From: Fabio Berton <fabio.berton@ossystems.com.br> 73e version. Almost implementation is based on meta-oe porting
5Date: Thu, 4 Feb 2016 09:15:37 -0200 8from Fabio Berton <fabio.berton@ossystems.com.br>.
6Subject: [PATCH 1/2] Makefile for cross compile SoftFloat
7 9
8Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> 10Signed-off-by: Zong Li <zongbox@gmail.com>
9--- 11---
10 SoftFloat-3a/build/Linux-Cross-Compile/Makefile | 274 ++++++++++++++++++++++ 12 SoftFloat-3e/build/Linux-Cross-Compile/Makefile | 325 ++++++++++++++++++++++
11 SoftFloat-3a/build/Linux-Cross-Compile/platform.h | 44 ++++ 13 SoftFloat-3e/build/Linux-Cross-Compile/platform.h | 52 ++++
12 2 files changed, 318 insertions(+) 14 2 files changed, 377 insertions(+)
13 create mode 100644 SoftFloat-3a/build/Linux-Cross-Compile/Makefile 15 create mode 100644 SoftFloat-3e/build/Linux-Cross-Compile/Makefile
14 create mode 100644 SoftFloat-3a/build/Linux-Cross-Compile/platform.h 16 create mode 100644 SoftFloat-3e/build/Linux-Cross-Compile/platform.h
15 17
16diff --git a/SoftFloat-3a/build/Linux-Cross-Compile/Makefile b/SoftFloat-3a/build/Linux-Cross-Compile/Makefile 18diff --git a/SoftFloat-3e/build/Linux-Cross-Compile/Makefile b/SoftFloat-3e/build/Linux-Cross-Compile/Makefile
17new file mode 100644 19new file mode 100644
18index 0000000..c4d0a60 20index 0000000..4da4bc9
19--- /dev/null 21--- /dev/null
20+++ b/SoftFloat-3a/build/Linux-Cross-Compile/Makefile 22+++ b/SoftFloat-3e/build/Linux-Cross-Compile/Makefile
21@@ -0,0 +1,274 @@ 23@@ -0,0 +1,325 @@
22+ 24+
23+#============================================================================= 25+#=============================================================================
24+# 26+#
25+# This Makefile is part of the SoftFloat IEEE Floating-Point Arithmetic 27+# This Makefile template is part of the SoftFloat IEEE Floating-Point
26+# Package, Release 3a, by John R. Hauser. 28+# Arithmetic Package, Release 3e, by John R. Hauser.
27+# 29+#
28+# Copyright 2011, 2012, 2013, 2014 The Regents of the University of 30+# Copyright 2011, 2012, 2013, 2014, 2015, 2016, 2017 The Regents of the
29+# California. All rights reserved. 31+# University of California. All rights reserved.
30+# 32+#
31+# Redistribution and use in source and binary forms, with or without 33+# Redistribution and use in source and binary forms, with or without
32+# modification, are permitted provided that the following conditions are met: 34+# modification, are permitted provided that the following conditions are met:
@@ -55,21 +57,25 @@ index 0000000..c4d0a60
55+# 57+#
56+#============================================================================= 58+#=============================================================================
57+ 59+
58+SOURCE_DIR = ../../source 60+SOURCE_DIR ?= ../../source
59+SPECIALIZE_TYPE = 8086 61+SPECIALIZE_TYPE ?= 8086
60+ 62+
61+SOFTFLOAT_OPTS = -DINLINE_LEVEL=5 -DSOFTFLOAT_FAST_DIV64TO32 -fgnu89-inline 63+SOFTFLOAT_OPTS ?= \
64+ -DSOFTFLOAT_ROUND_ODD -DINLINE_LEVEL=5 -DSOFTFLOAT_FAST_DIV32TO16 \
65+ -DSOFTFLOAT_FAST_DIV64TO32
62+ 66+
63+DELETE = rm -f 67+DELETE = rm -f
64+C_INCLUDES = -I. -I$(SOURCE_DIR)/$(SPECIALIZE_TYPE) -I$(SOURCE_DIR)/include 68+C_INCLUDES = -I. -I$(SOURCE_DIR)/$(SPECIALIZE_TYPE) -I$(SOURCE_DIR)/include
65+COMPILE_C = \ 69+COMPILE_C = \
66+ ${CC} -c -Werror-implicit-function-declaration $(SOFTFLOAT_OPTS) \ 70+ ${CC} -c -Werror-implicit-function-declaration $(SOFTFLOAT_OPTS) \
67+ $(C_INCLUDES) -O2 -o $@ 71+ $(C_INCLUDES) -O2 -o $@
68+MAKELIB = ${AR} crs $@ 72+MAKELIB = ${AR} crs $@
69+ 73+
70+OBJ = .o 74+OBJ = .o
71+LIB = .a 75+LIB = .a
72+ 76+
77+OTHER_HEADERS =
78+
73+.PHONY: all 79+.PHONY: all
74+all: softfloat$(LIB) 80+all: softfloat$(LIB)
75+ 81+
@@ -87,6 +93,7 @@ index 0000000..c4d0a60
87+ s_shiftRightJamM$(OBJ) \ 93+ s_shiftRightJamM$(OBJ) \
88+ s_shiftRightM$(OBJ) \ 94+ s_shiftRightM$(OBJ) \
89+ s_countLeadingZeros8$(OBJ) \ 95+ s_countLeadingZeros8$(OBJ) \
96+ s_countLeadingZeros16$(OBJ) \
90+ s_countLeadingZeros32$(OBJ) \ 97+ s_countLeadingZeros32$(OBJ) \
91+ s_countLeadingZeros64$(OBJ) \ 98+ s_countLeadingZeros64$(OBJ) \
92+ s_addM$(OBJ) \ 99+ s_addM$(OBJ) \
@@ -97,12 +104,17 @@ index 0000000..c4d0a60
97+ s_subM$(OBJ) \ 104+ s_subM$(OBJ) \
98+ s_mul64To128M$(OBJ) \ 105+ s_mul64To128M$(OBJ) \
99+ s_mul128MTo256M$(OBJ) \ 106+ s_mul128MTo256M$(OBJ) \
107+ s_approxRecip_1Ks$(OBJ) \
100+ s_approxRecip32_1$(OBJ) \ 108+ s_approxRecip32_1$(OBJ) \
109+ s_approxRecipSqrt_1Ks$(OBJ) \
101+ s_approxRecipSqrt32_1$(OBJ) \ 110+ s_approxRecipSqrt32_1$(OBJ) \
102+ s_remStepMBy32$(OBJ) \ 111+ s_remStepMBy32$(OBJ) \
103+ 112+
104+OBJS_SPECIALIZE = \ 113+OBJS_SPECIALIZE = \
105+ softfloat_raiseFlags$(OBJ) \ 114+ softfloat_raiseFlags$(OBJ) \
115+ s_f16UIToCommonNaN$(OBJ) \
116+ s_commonNaNToF16UI$(OBJ) \
117+ s_propagateNaNF16UI$(OBJ) \
106+ s_f32UIToCommonNaN$(OBJ) \ 118+ s_f32UIToCommonNaN$(OBJ) \
107+ s_commonNaNToF32UI$(OBJ) \ 119+ s_commonNaNToF32UI$(OBJ) \
108+ s_propagateNaNF32UI$(OBJ) \ 120+ s_propagateNaNF32UI$(OBJ) \
@@ -119,10 +131,16 @@ index 0000000..c4d0a60
119+ s_propagateNaNF128M$(OBJ) \ 131+ s_propagateNaNF128M$(OBJ) \
120+ 132+
121+OBJS_OTHERS = \ 133+OBJS_OTHERS = \
122+ s_roundPackToUI32$(OBJ) \ 134+ s_roundToUI32$(OBJ) \
123+ s_roundPackMToUI64$(OBJ) \ 135+ s_roundMToUI64$(OBJ) \
124+ s_roundPackToI32$(OBJ) \ 136+ s_roundToI32$(OBJ) \
125+ s_roundPackMToI64$(OBJ) \ 137+ s_roundMToI64$(OBJ) \
138+ s_normSubnormalF16Sig$(OBJ) \
139+ s_roundPackToF16$(OBJ) \
140+ s_normRoundPackToF16$(OBJ) \
141+ s_addMagsF16$(OBJ) \
142+ s_subMagsF16$(OBJ) \
143+ s_mulAddF16$(OBJ) \
126+ s_normSubnormalF32Sig$(OBJ) \ 144+ s_normSubnormalF32Sig$(OBJ) \
127+ s_roundPackToF32$(OBJ) \ 145+ s_roundPackToF32$(OBJ) \
128+ s_normRoundPackToF32$(OBJ) \ 146+ s_normRoundPackToF32$(OBJ) \
@@ -151,22 +169,53 @@ index 0000000..c4d0a60
151+ s_addF128M$(OBJ) \ 169+ s_addF128M$(OBJ) \
152+ s_mulAddF128M$(OBJ) \ 170+ s_mulAddF128M$(OBJ) \
153+ softfloat_state$(OBJ) \ 171+ softfloat_state$(OBJ) \
172+ ui32_to_f16$(OBJ) \
154+ ui32_to_f32$(OBJ) \ 173+ ui32_to_f32$(OBJ) \
155+ ui32_to_f64$(OBJ) \ 174+ ui32_to_f64$(OBJ) \
156+ ui32_to_extF80M$(OBJ) \ 175+ ui32_to_extF80M$(OBJ) \
157+ ui32_to_f128M$(OBJ) \ 176+ ui32_to_f128M$(OBJ) \
177+ ui64_to_f16$(OBJ) \
158+ ui64_to_f32$(OBJ) \ 178+ ui64_to_f32$(OBJ) \
159+ ui64_to_f64$(OBJ) \ 179+ ui64_to_f64$(OBJ) \
160+ ui64_to_extF80M$(OBJ) \ 180+ ui64_to_extF80M$(OBJ) \
161+ ui64_to_f128M$(OBJ) \ 181+ ui64_to_f128M$(OBJ) \
182+ i32_to_f16$(OBJ) \
162+ i32_to_f32$(OBJ) \ 183+ i32_to_f32$(OBJ) \
163+ i32_to_f64$(OBJ) \ 184+ i32_to_f64$(OBJ) \
164+ i32_to_extF80M$(OBJ) \ 185+ i32_to_extF80M$(OBJ) \
165+ i32_to_f128M$(OBJ) \ 186+ i32_to_f128M$(OBJ) \
187+ i64_to_f16$(OBJ) \
166+ i64_to_f32$(OBJ) \ 188+ i64_to_f32$(OBJ) \
167+ i64_to_f64$(OBJ) \ 189+ i64_to_f64$(OBJ) \
168+ i64_to_extF80M$(OBJ) \ 190+ i64_to_extF80M$(OBJ) \
169+ i64_to_f128M$(OBJ) \ 191+ i64_to_f128M$(OBJ) \
192+ f16_to_ui32$(OBJ) \
193+ f16_to_ui64$(OBJ) \
194+ f16_to_i32$(OBJ) \
195+ f16_to_i64$(OBJ) \
196+ f16_to_ui32_r_minMag$(OBJ) \
197+ f16_to_ui64_r_minMag$(OBJ) \
198+ f16_to_i32_r_minMag$(OBJ) \
199+ f16_to_i64_r_minMag$(OBJ) \
200+ f16_to_f32$(OBJ) \
201+ f16_to_f64$(OBJ) \
202+ f16_to_extF80M$(OBJ) \
203+ f16_to_f128M$(OBJ) \
204+ f16_roundToInt$(OBJ) \
205+ f16_add$(OBJ) \
206+ f16_sub$(OBJ) \
207+ f16_mul$(OBJ) \
208+ f16_mulAdd$(OBJ) \
209+ f16_div$(OBJ) \
210+ f16_rem$(OBJ) \
211+ f16_sqrt$(OBJ) \
212+ f16_eq$(OBJ) \
213+ f16_le$(OBJ) \
214+ f16_lt$(OBJ) \
215+ f16_eq_signaling$(OBJ) \
216+ f16_le_quiet$(OBJ) \
217+ f16_lt_quiet$(OBJ) \
218+ f16_isSignalingNaN$(OBJ) \
170+ f32_to_ui32$(OBJ) \ 219+ f32_to_ui32$(OBJ) \
171+ f32_to_ui64$(OBJ) \ 220+ f32_to_ui64$(OBJ) \
172+ f32_to_i32$(OBJ) \ 221+ f32_to_i32$(OBJ) \
@@ -175,6 +224,7 @@ index 0000000..c4d0a60
175+ f32_to_ui64_r_minMag$(OBJ) \ 224+ f32_to_ui64_r_minMag$(OBJ) \
176+ f32_to_i32_r_minMag$(OBJ) \ 225+ f32_to_i32_r_minMag$(OBJ) \
177+ f32_to_i64_r_minMag$(OBJ) \ 226+ f32_to_i64_r_minMag$(OBJ) \
227+ f32_to_f16$(OBJ) \
178+ f32_to_f64$(OBJ) \ 228+ f32_to_f64$(OBJ) \
179+ f32_to_extF80M$(OBJ) \ 229+ f32_to_extF80M$(OBJ) \
180+ f32_to_f128M$(OBJ) \ 230+ f32_to_f128M$(OBJ) \
@@ -201,6 +251,7 @@ index 0000000..c4d0a60
201+ f64_to_ui64_r_minMag$(OBJ) \ 251+ f64_to_ui64_r_minMag$(OBJ) \
202+ f64_to_i32_r_minMag$(OBJ) \ 252+ f64_to_i32_r_minMag$(OBJ) \
203+ f64_to_i64_r_minMag$(OBJ) \ 253+ f64_to_i64_r_minMag$(OBJ) \
254+ f64_to_f16$(OBJ) \
204+ f64_to_f32$(OBJ) \ 255+ f64_to_f32$(OBJ) \
205+ f64_to_extF80M$(OBJ) \ 256+ f64_to_extF80M$(OBJ) \
206+ f64_to_f128M$(OBJ) \ 257+ f64_to_f128M$(OBJ) \
@@ -227,6 +278,7 @@ index 0000000..c4d0a60
227+ extF80M_to_ui64_r_minMag$(OBJ) \ 278+ extF80M_to_ui64_r_minMag$(OBJ) \
228+ extF80M_to_i32_r_minMag$(OBJ) \ 279+ extF80M_to_i32_r_minMag$(OBJ) \
229+ extF80M_to_i64_r_minMag$(OBJ) \ 280+ extF80M_to_i64_r_minMag$(OBJ) \
281+ extF80M_to_f16$(OBJ) \
230+ extF80M_to_f32$(OBJ) \ 282+ extF80M_to_f32$(OBJ) \
231+ extF80M_to_f64$(OBJ) \ 283+ extF80M_to_f64$(OBJ) \
232+ extF80M_to_f128M$(OBJ) \ 284+ extF80M_to_f128M$(OBJ) \
@@ -251,6 +303,7 @@ index 0000000..c4d0a60
251+ f128M_to_ui64_r_minMag$(OBJ) \ 303+ f128M_to_ui64_r_minMag$(OBJ) \
252+ f128M_to_i32_r_minMag$(OBJ) \ 304+ f128M_to_i32_r_minMag$(OBJ) \
253+ f128M_to_i64_r_minMag$(OBJ) \ 305+ f128M_to_i64_r_minMag$(OBJ) \
306+ f128M_to_f16$(OBJ) \
254+ f128M_to_f32$(OBJ) \ 307+ f128M_to_f32$(OBJ) \
255+ f128M_to_f64$(OBJ) \ 308+ f128M_to_f64$(OBJ) \
256+ f128M_to_extF80M$(OBJ) \ 309+ f128M_to_extF80M$(OBJ) \
@@ -272,7 +325,7 @@ index 0000000..c4d0a60
272+OBJS_ALL = $(OBJS_PRIMITIVES) $(OBJS_SPECIALIZE) $(OBJS_OTHERS) 325+OBJS_ALL = $(OBJS_PRIMITIVES) $(OBJS_SPECIALIZE) $(OBJS_OTHERS)
273+ 326+
274+$(OBJS_ALL): \ 327+$(OBJS_ALL): \
275+ platform.h $(SOURCE_DIR)/include/primitiveTypes.h \ 328+ $(OTHER_HEADERS) platform.h $(SOURCE_DIR)/include/primitiveTypes.h \
276+ $(SOURCE_DIR)/include/primitives.h 329+ $(SOURCE_DIR)/include/primitives.h
277+$(OBJS_SPECIALIZE) $(OBJS_OTHERS): \ 330+$(OBJS_SPECIALIZE) $(OBJS_OTHERS): \
278+ $(SOURCE_DIR)/include/softfloat_types.h $(SOURCE_DIR)/include/internals.h \ 331+ $(SOURCE_DIR)/include/softfloat_types.h $(SOURCE_DIR)/include/internals.h \
@@ -293,20 +346,20 @@ index 0000000..c4d0a60
293+clean: 346+clean:
294+ $(DELETE) $(OBJS_ALL) softfloat$(LIB) 347+ $(DELETE) $(OBJS_ALL) softfloat$(LIB)
295+ 348+
296diff --git a/SoftFloat-3a/build/Linux-Cross-Compile/platform.h b/SoftFloat-3a/build/Linux-Cross-Compile/platform.h 349diff --git a/SoftFloat-3e/build/Linux-Cross-Compile/platform.h b/SoftFloat-3e/build/Linux-Cross-Compile/platform.h
297new file mode 100644 350new file mode 100644
298index 0000000..5e566fc 351index 0000000..1728c15
299--- /dev/null 352--- /dev/null
300+++ b/SoftFloat-3a/build/Linux-Cross-Compile/platform.h 353+++ b/SoftFloat-3e/build/Linux-Cross-Compile/platform.h
301@@ -0,0 +1,44 @@ 354@@ -0,0 +1,52 @@
302+ 355+
303+/*============================================================================ 356+/*============================================================================
304+ 357+
305+This C header file is part of the SoftFloat IEEE Floating-Point Arithmetic 358+This C header template is part of the SoftFloat IEEE Floating-Point Arithmetic
306+Package, Release 3a, by John R. Hauser. 359+Package, Release 3e, by John R. Hauser.
307+ 360+
308+Copyright 2011, 2012, 2013, 2014 The Regents of the University of California. 361+Copyright 2011, 2012, 2013, 2014, 2015, 2016 The Regents of the University of
309+All rights reserved. 362+California. All rights reserved.
310+ 363+
311+Redistribution and use in source and binary forms, with or without 364+Redistribution and use in source and binary forms, with or without
312+modification, are permitted provided that the following conditions are met: 365+modification, are permitted provided that the following conditions are met:
@@ -341,8 +394,16 @@ index 0000000..5e566fc
341+ 394+
342+/*---------------------------------------------------------------------------- 395+/*----------------------------------------------------------------------------
343+*----------------------------------------------------------------------------*/ 396+*----------------------------------------------------------------------------*/
397+#ifdef __GNUC_STDC_INLINE__
398+#define INLINE inline
399+#else
344+#define INLINE extern inline 400+#define INLINE extern inline
401+#endif
345+ 402+
403+/*----------------------------------------------------------------------------
404+*----------------------------------------------------------------------------*/
405+#define SOFTFLOAT_BUILTIN_CLZ 1
406+#include "opts-GCC.h"
346-- 407--
3472.1.4 4082.7.4
348 409
diff --git a/meta-oe/recipes-test/testfloat/files/0002-Makefile-for-cross-compile-TestFloat.patch b/meta-oe/recipes-test/testfloat/files/0002-Makefile-for-cross-compile-TestFloat.patch
index 71ca343cc..b7d861f8f 100644
--- a/meta-oe/recipes-test/testfloat/files/0002-Makefile-for-cross-compile-TestFloat.patch
+++ b/meta-oe/recipes-test/testfloat/files/0002-Makefile-for-cross-compile-TestFloat.patch
@@ -1,33 +1,35 @@
1Upstream-Status: Inappropriate [configuration] 1From 3503f7f3845caba454949fdf8408e85ca4fdb943 Mon Sep 17 00:00:00 2001
2From: Zong Li <zong.li@sifive.com>
3Date: Wed, 6 May 2020 01:25:55 -0700
4Subject: [PATCH] Makefile for cross compile TestFloat 3e
2 5
3From 9aa4a416f05967320c1aa52bdccfe105a3bf3269 Mon Sep 17 00:00:00 2001 6This commit adds a Makefile for cross compile on TestFloat
4From: Fabio Berton <fabio.berton@ossystems.com.br> 73e version. Almost implementation is based on meta-oe porting
5Date: Thu, 4 Feb 2016 09:16:09 -0200 8from Fabio Berton <fabio.berton@ossystems.com.br>.
6Subject: [PATCH 2/2] Makefile for cross compile TestFloat
7 9
8Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> 10Signed-off-by: Zong Li <zongbox@gmail.com>
9--- 11---
10 TestFloat-3a/build/Linux-Cross-Compile/Makefile | 321 ++++++++++++++++++++++ 12 TestFloat-3e/build/Linux-Cross-Compile/Makefile | 353 ++++++++++++++++++++++
11 TestFloat-3a/build/Linux-Cross-Compile/platform.h | 45 +++ 13 TestFloat-3e/build/Linux-Cross-Compile/platform.h | 48 +++
12 2 files changed, 366 insertions(+) 14 2 files changed, 401 insertions(+)
13 create mode 100644 TestFloat-3a/build/Linux-Cross-Compile/Makefile 15 create mode 100644 TestFloat-3e/build/Linux-Cross-Compile/Makefile
14 create mode 100644 TestFloat-3a/build/Linux-Cross-Compile/platform.h 16 create mode 100644 TestFloat-3e/build/Linux-Cross-Compile/platform.h
15 17
16diff --git a/TestFloat-3a/build/Linux-Cross-Compile/Makefile b/TestFloat-3a/build/Linux-Cross-Compile/Makefile 18diff --git a/TestFloat-3e/build/Linux-Cross-Compile/Makefile b/TestFloat-3e/build/Linux-Cross-Compile/Makefile
17new file mode 100644 19new file mode 100644
18index 0000000..a89326a 20index 0000000..d82b9ed
19--- /dev/null 21--- /dev/null
20+++ b/TestFloat-3a/build/Linux-Cross-Compile/Makefile 22+++ b/TestFloat-3e/build/Linux-Cross-Compile/Makefile
21@@ -0,0 +1,321 @@ 23@@ -0,0 +1,353 @@
22+ 24+
23+#============================================================================= 25+#=============================================================================
24+# 26+#
25+# This Makefile is part of TestFloat, Release 3a, a package of programs for 27+# This Makefile template is part of TestFloat, Release 3b, a package of
26+# testing the correctness of floating-point arithmetic complying with the IEEE 28+# programs for testing the correctness of floating-point arithmetic complying
27+# Standard for Floating-Point, by John R. Hauser. 29+# with the IEEE Standard for Floating-Point, by John R. Hauser.
28+# 30+#
29+# Copyright 2011, 2012, 2013, 2014, 2015 The Regents of the University of 31+# Copyright 2011, 2012, 2013, 2014, 2015, 2016 The Regents of the University
30+# California. All rights reserved. 32+# of California. All rights reserved.
31+# 33+#
32+# Redistribution and use in source and binary forms, with or without 34+# Redistribution and use in source and binary forms, with or without
33+# modification, are permitted provided that the following conditions are met: 35+# modification, are permitted provided that the following conditions are met:
@@ -56,28 +58,29 @@ index 0000000..a89326a
56+# 58+#
57+#============================================================================= 59+#=============================================================================
58+ 60+
59+SOURCE_DIR = ../../source 61+SOURCE_DIR ?= ../../source
62+SOFTFLOAT_DIR ?= ../../../SoftFloat-3e
63+PLATFORM ?= Linux-Cross-Compile
64+
60+SUBJ_SOURCE_DIR = $(SOURCE_DIR)/subj-C 65+SUBJ_SOURCE_DIR = $(SOURCE_DIR)/subj-C
61+SOFTFLOAT_DIR = ../../../SoftFloat-3a
62+SOFTFLOAT_INCLUDE_DIR = $(SOFTFLOAT_DIR)/source/include 66+SOFTFLOAT_INCLUDE_DIR = $(SOFTFLOAT_DIR)/source/include
63+PLATFORM = Linux-Cross-Compile
64+ 67+
65+SOFTFLOAT_H = \ 68+SOFTFLOAT_H = \
66+ $(SOFTFLOAT_INCLUDE_DIR)/softfloat_types.h \ 69+ $(SOFTFLOAT_INCLUDE_DIR)/softfloat_types.h \
67+ $(SOFTFLOAT_INCLUDE_DIR)/softfloat.h 70+ $(SOFTFLOAT_INCLUDE_DIR)/softfloat.h
68+SOFTFLOAT_LIB = $(SOFTFLOAT_DIR)/build/$(PLATFORM)/softfloat$(LIB) 71+SOFTFLOAT_LIB = $(SOFTFLOAT_DIR)/build/$(PLATFORM)/softfloat$(LIB)
69+ 72+
70+TESTFLOAT_OPTS = -DEXTFLOAT80 -DFLOAT128 -DLONG_DOUBLE_IS_EXTFLOAT80 -fgnu89-inline 73+TESTFLOAT_OPTS ?= -DFLOAT16 -DFLOAT64 -DEXTFLOAT80 -DFLOAT128 -DFLOAT_ROUND_ODD
71+ 74+
72+DELETE = rm -f 75+DELETE = rm -f
73+C_INCLUDES = \ 76+C_INCLUDES = \
74+ -I. -I$(SUBJ_SOURCE_DIR) -I$(SOURCE_DIR) -I$(SOFTFLOAT_INCLUDE_DIR) 77+ -I. -I$(SUBJ_SOURCE_DIR) -I$(SOURCE_DIR) -I$(SOFTFLOAT_INCLUDE_DIR)
75+COMPILE_C = \ 78+COMPILE_C = \
76+ ${CC} -c -Werror-implicit-function-declaration $(TESTFLOAT_OPTS) \ 79+ ${CC} -c -Werror-implicit-function-declaration \
77+ $(C_INCLUDES) -O2 -o $@ 80+ $(TESTFLOAT_OPTS) $(C_INCLUDES) -O2 -o $@
78+COMPILE_SLOWFLOAT_C = \ 81+COMPILE_SLOWFLOAT_C = \
79+ ${CC} -c -Werror-implicit-function-declaration $(TESTFLOAT_OPTS) \ 82+ ${CC} -c -Werror-implicit-function-declaration \
80+ $(C_INCLUDES) -O3 -o $@ 83+ $(TESTFLOAT_OPTS) $(C_INCLUDES) -O3 -o $@
81+MAKELIB = ${AR} crs $@ 84+MAKELIB = ${AR} crs $@
82+LINK = ${CC} -o $@ ${LDFLAGS} 85+LINK = ${CC} -o $@ ${LDFLAGS}
83+OTHER_LIBS = -lm 86+OTHER_LIBS = -lm
@@ -99,6 +102,7 @@ index 0000000..a89326a
99+ genCases_ui64$(OBJ) \ 102+ genCases_ui64$(OBJ) \
100+ genCases_i32$(OBJ) \ 103+ genCases_i32$(OBJ) \
101+ genCases_i64$(OBJ) \ 104+ genCases_i64$(OBJ) \
105+ genCases_f16$(OBJ) \
102+ genCases_f32$(OBJ) \ 106+ genCases_f32$(OBJ) \
103+ genCases_f64$(OBJ) \ 107+ genCases_f64$(OBJ) \
104+ genCases_extF80$(OBJ) \ 108+ genCases_extF80$(OBJ) \
@@ -107,6 +111,9 @@ index 0000000..a89326a
107+OBJS_WRITECASE = \ 111+OBJS_WRITECASE = \
108+ writeCase_a_ui32$(OBJ) \ 112+ writeCase_a_ui32$(OBJ) \
109+ writeCase_a_ui64$(OBJ) \ 113+ writeCase_a_ui64$(OBJ) \
114+ writeCase_a_f16$(OBJ) \
115+ writeCase_ab_f16$(OBJ) \
116+ writeCase_abc_f16$(OBJ) \
110+ writeCase_a_f32$(OBJ) \ 117+ writeCase_a_f32$(OBJ) \
111+ writeCase_ab_f32$(OBJ) \ 118+ writeCase_ab_f32$(OBJ) \
112+ writeCase_abc_f32$(OBJ) \ 119+ writeCase_abc_f32$(OBJ) \
@@ -115,35 +122,56 @@ index 0000000..a89326a
115+ writeCase_abc_f64$(OBJ) \ 122+ writeCase_abc_f64$(OBJ) \
116+ writeCase_a_extF80M$(OBJ) \ 123+ writeCase_a_extF80M$(OBJ) \
117+ writeCase_ab_extF80M$(OBJ) \ 124+ writeCase_ab_extF80M$(OBJ) \
118+ writeCase_abc_extF80M$(OBJ) \
119+ writeCase_a_f128M$(OBJ) \ 125+ writeCase_a_f128M$(OBJ) \
120+ writeCase_ab_f128M$(OBJ) \ 126+ writeCase_ab_f128M$(OBJ) \
121+ writeCase_abc_f128M$(OBJ) \ 127+ writeCase_abc_f128M$(OBJ) \
122+ writeCase_z_bool$(OBJ) \ 128+ writeCase_z_bool$(OBJ) \
123+ writeCase_z_ui32$(OBJ) \ 129+ writeCase_z_ui32$(OBJ) \
124+ writeCase_z_ui64$(OBJ) \ 130+ writeCase_z_ui64$(OBJ) \
131+ writeCase_z_f16$(OBJ) \
125+ writeCase_z_f32$(OBJ) \ 132+ writeCase_z_f32$(OBJ) \
126+ writeCase_z_f64$(OBJ) \ 133+ writeCase_z_f64$(OBJ) \
127+ writeCase_z_extF80M$(OBJ) \ 134+ writeCase_z_extF80M$(OBJ) \
128+ writeCase_z_f128M$(OBJ) \ 135+ writeCase_z_f128M$(OBJ) \
129+ 136+
130+OBJS_TEST = \ 137+OBJS_TEST = \
138+ test_a_ui32_z_f16$(OBJ) \
131+ test_a_ui32_z_f32$(OBJ) \ 139+ test_a_ui32_z_f32$(OBJ) \
132+ test_a_ui32_z_f64$(OBJ) \ 140+ test_a_ui32_z_f64$(OBJ) \
133+ test_a_ui32_z_extF80$(OBJ) \ 141+ test_a_ui32_z_extF80$(OBJ) \
134+ test_a_ui32_z_f128$(OBJ) \ 142+ test_a_ui32_z_f128$(OBJ) \
143+ test_a_ui64_z_f16$(OBJ) \
135+ test_a_ui64_z_f32$(OBJ) \ 144+ test_a_ui64_z_f32$(OBJ) \
136+ test_a_ui64_z_f64$(OBJ) \ 145+ test_a_ui64_z_f64$(OBJ) \
137+ test_a_ui64_z_extF80$(OBJ) \ 146+ test_a_ui64_z_extF80$(OBJ) \
138+ test_a_ui64_z_f128$(OBJ) \ 147+ test_a_ui64_z_f128$(OBJ) \
148+ test_a_i32_z_f16$(OBJ) \
139+ test_a_i32_z_f32$(OBJ) \ 149+ test_a_i32_z_f32$(OBJ) \
140+ test_a_i32_z_f64$(OBJ) \ 150+ test_a_i32_z_f64$(OBJ) \
141+ test_a_i32_z_extF80$(OBJ) \ 151+ test_a_i32_z_extF80$(OBJ) \
142+ test_a_i32_z_f128$(OBJ) \ 152+ test_a_i32_z_f128$(OBJ) \
153+ test_a_i64_z_f16$(OBJ) \
143+ test_a_i64_z_f32$(OBJ) \ 154+ test_a_i64_z_f32$(OBJ) \
144+ test_a_i64_z_f64$(OBJ) \ 155+ test_a_i64_z_f64$(OBJ) \
145+ test_a_i64_z_extF80$(OBJ) \ 156+ test_a_i64_z_extF80$(OBJ) \
146+ test_a_i64_z_f128$(OBJ) \ 157+ test_a_i64_z_f128$(OBJ) \
158+ test_a_f16_z_ui32_rx$(OBJ) \
159+ test_a_f16_z_ui64_rx$(OBJ) \
160+ test_a_f16_z_i32_rx$(OBJ) \
161+ test_a_f16_z_i64_rx$(OBJ) \
162+ test_a_f16_z_ui32_x$(OBJ) \
163+ test_a_f16_z_ui64_x$(OBJ) \
164+ test_a_f16_z_i32_x$(OBJ) \
165+ test_a_f16_z_i64_x$(OBJ) \
166+ test_a_f16_z_f32$(OBJ) \
167+ test_a_f16_z_f64$(OBJ) \
168+ test_a_f16_z_extF80$(OBJ) \
169+ test_a_f16_z_f128$(OBJ) \
170+ test_az_f16$(OBJ) \
171+ test_az_f16_rx$(OBJ) \
172+ test_abz_f16$(OBJ) \
173+ test_abcz_f16$(OBJ) \
174+ test_ab_f16_z_bool$(OBJ) \
147+ test_a_f32_z_ui32_rx$(OBJ) \ 175+ test_a_f32_z_ui32_rx$(OBJ) \
148+ test_a_f32_z_ui64_rx$(OBJ) \ 176+ test_a_f32_z_ui64_rx$(OBJ) \
149+ test_a_f32_z_i32_rx$(OBJ) \ 177+ test_a_f32_z_i32_rx$(OBJ) \
@@ -152,6 +180,7 @@ index 0000000..a89326a
152+ test_a_f32_z_ui64_x$(OBJ) \ 180+ test_a_f32_z_ui64_x$(OBJ) \
153+ test_a_f32_z_i32_x$(OBJ) \ 181+ test_a_f32_z_i32_x$(OBJ) \
154+ test_a_f32_z_i64_x$(OBJ) \ 182+ test_a_f32_z_i64_x$(OBJ) \
183+ test_a_f32_z_f16$(OBJ) \
155+ test_a_f32_z_f64$(OBJ) \ 184+ test_a_f32_z_f64$(OBJ) \
156+ test_a_f32_z_extF80$(OBJ) \ 185+ test_a_f32_z_extF80$(OBJ) \
157+ test_a_f32_z_f128$(OBJ) \ 186+ test_a_f32_z_f128$(OBJ) \
@@ -168,6 +197,7 @@ index 0000000..a89326a
168+ test_a_f64_z_ui64_x$(OBJ) \ 197+ test_a_f64_z_ui64_x$(OBJ) \
169+ test_a_f64_z_i32_x$(OBJ) \ 198+ test_a_f64_z_i32_x$(OBJ) \
170+ test_a_f64_z_i64_x$(OBJ) \ 199+ test_a_f64_z_i64_x$(OBJ) \
200+ test_a_f64_z_f16$(OBJ) \
171+ test_a_f64_z_f32$(OBJ) \ 201+ test_a_f64_z_f32$(OBJ) \
172+ test_a_f64_z_extF80$(OBJ) \ 202+ test_a_f64_z_extF80$(OBJ) \
173+ test_a_f64_z_f128$(OBJ) \ 203+ test_a_f64_z_f128$(OBJ) \
@@ -184,6 +214,7 @@ index 0000000..a89326a
184+ test_a_extF80_z_ui64_x$(OBJ) \ 214+ test_a_extF80_z_ui64_x$(OBJ) \
185+ test_a_extF80_z_i32_x$(OBJ) \ 215+ test_a_extF80_z_i32_x$(OBJ) \
186+ test_a_extF80_z_i64_x$(OBJ) \ 216+ test_a_extF80_z_i64_x$(OBJ) \
217+ test_a_extF80_z_f16$(OBJ) \
187+ test_a_extF80_z_f32$(OBJ) \ 218+ test_a_extF80_z_f32$(OBJ) \
188+ test_a_extF80_z_f64$(OBJ) \ 219+ test_a_extF80_z_f64$(OBJ) \
189+ test_a_extF80_z_f128$(OBJ) \ 220+ test_a_extF80_z_f128$(OBJ) \
@@ -199,6 +230,7 @@ index 0000000..a89326a
199+ test_a_f128_z_ui64_x$(OBJ) \ 230+ test_a_f128_z_ui64_x$(OBJ) \
200+ test_a_f128_z_i32_x$(OBJ) \ 231+ test_a_f128_z_i32_x$(OBJ) \
201+ test_a_f128_z_i64_x$(OBJ) \ 232+ test_a_f128_z_i64_x$(OBJ) \
233+ test_a_f128_z_f16$(OBJ) \
202+ test_a_f128_z_f32$(OBJ) \ 234+ test_a_f128_z_f32$(OBJ) \
203+ test_a_f128_z_f64$(OBJ) \ 235+ test_a_f128_z_f64$(OBJ) \
204+ test_a_f128_z_extF80$(OBJ) \ 236+ test_a_f128_z_extF80$(OBJ) \
@@ -209,6 +241,7 @@ index 0000000..a89326a
209+ test_ab_f128_z_bool$(OBJ) \ 241+ test_ab_f128_z_bool$(OBJ) \
210+ 242+
211+OBJS_LIB = \ 243+OBJS_LIB = \
244+ uint128_inline$(OBJ) \
212+ uint128$(OBJ) \ 245+ uint128$(OBJ) \
213+ fail$(OBJ) \ 246+ fail$(OBJ) \
214+ functions_common$(OBJ) \ 247+ functions_common$(OBJ) \
@@ -218,6 +251,7 @@ index 0000000..a89326a
218+ genCases_common$(OBJ) \ 251+ genCases_common$(OBJ) \
219+ $(OBJS_GENCASES) \ 252+ $(OBJS_GENCASES) \
220+ genCases_writeTestsTotal$(OBJ) \ 253+ genCases_writeTestsTotal$(OBJ) \
254+ verCases_inline$(OBJ) \
221+ verCases_common$(OBJ) \ 255+ verCases_common$(OBJ) \
222+ verCases_writeFunctionName$(OBJ) \ 256+ verCases_writeFunctionName$(OBJ) \
223+ readHex$(OBJ) \ 257+ readHex$(OBJ) \
@@ -340,21 +374,21 @@ index 0000000..a89326a
340+ $(DELETE) $(OBJS_TESTFLOAT_VER) testfloat_ver$(EXE) 374+ $(DELETE) $(OBJS_TESTFLOAT_VER) testfloat_ver$(EXE)
341+ $(DELETE) $(OBJS_TESTFLOAT) testfloat$(EXE) 375+ $(DELETE) $(OBJS_TESTFLOAT) testfloat$(EXE)
342+ 376+
343diff --git a/TestFloat-3a/build/Linux-Cross-Compile/platform.h b/TestFloat-3a/build/Linux-Cross-Compile/platform.h 377diff --git a/TestFloat-3e/build/Linux-Cross-Compile/platform.h b/TestFloat-3e/build/Linux-Cross-Compile/platform.h
344new file mode 100644 378new file mode 100644
345index 0000000..09e63a0 379index 0000000..487a43b
346--- /dev/null 380--- /dev/null
347+++ b/TestFloat-3a/build/Linux-Cross-Compile/platform.h 381+++ b/TestFloat-3e/build/Linux-Cross-Compile/platform.h
348@@ -0,0 +1,45 @@ 382@@ -0,0 +1,48 @@
349+ 383+
350+/*============================================================================ 384+/*============================================================================
351+ 385+
352+This C header file is part of TestFloat, Release 3a, a package of programs for 386+This C header template is part of TestFloat, Release 3e, a package of programs
353+testing the correctness of floating-point arithmetic complying with the IEEE 387+for testing the correctness of floating-point arithmetic complying with the
354+Standard for Floating-Point, by John R. Hauser. 388+IEEE Standard for Floating-Point, by John R. Hauser.
355+ 389+
356+Copyright 2011, 2012, 2013, 2014 The Regents of the University of California. 390+Copyright 2011, 2012, 2013, 2014, 2015, 2016 The Regents of the University of
357+All rights reserved. 391+California. All rights reserved.
358+ 392+
359+Redistribution and use in source and binary forms, with or without 393+Redistribution and use in source and binary forms, with or without
360+modification, are permitted provided that the following conditions are met: 394+modification, are permitted provided that the following conditions are met:
@@ -389,8 +423,11 @@ index 0000000..09e63a0
389+ 423+
390+/*---------------------------------------------------------------------------- 424+/*----------------------------------------------------------------------------
391+*----------------------------------------------------------------------------*/ 425+*----------------------------------------------------------------------------*/
426+#ifdef __GNUC_STDC_INLINE__
427+#define INLINE inline
428+#else
392+#define INLINE extern inline 429+#define INLINE extern inline
393+ 430+#endif
394-- 431--
3952.1.4 4322.7.4
396 433
diff --git a/meta-oe/recipes-test/testfloat/testfloat_3a.bb b/meta-oe/recipes-test/testfloat/testfloat_3e.bb
index ace376ef2..48f50d827 100644
--- a/meta-oe/recipes-test/testfloat/testfloat_3a.bb
+++ b/meta-oe/recipes-test/testfloat/testfloat_3e.bb
@@ -1,3 +1,4 @@
1SUMMARY = "Berkeley TestFloat 3e"
1DESCRIPTION = "Berkeley TestFloat is a small collection of programs for \ 2DESCRIPTION = "Berkeley TestFloat is a small collection of programs for \
2 testing that an implementation of binary floating-point conforms to the \ 3 testing that an implementation of binary floating-point conforms to the \
3 IEEE Standard for Floating-Point Arithmetic." 4 IEEE Standard for Floating-Point Arithmetic."
@@ -5,18 +6,18 @@ DESCRIPTION = "Berkeley TestFloat is a small collection of programs for \
5HOMEPAGE = "http://www.jhauser.us/arithmetic/TestFloat.html" 6HOMEPAGE = "http://www.jhauser.us/arithmetic/TestFloat.html"
6 7
7LICENSE = "BSD-3-Clause" 8LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://TestFloat-${PV}/COPYING.txt;md5=e45c175a323b5727777fb6bd4b26eafc" 9LIC_FILES_CHKSUM = "file://TestFloat-${PV}/COPYING.txt;md5=d467c2d231054347e8fd885ac06e7b2b"
9 10
10SRC_URI = "\ 11SRC_URI = "\
11 http://www.jhauser.us/arithmetic/TestFloat-3a.zip;name=TestFloat \ 12 http://www.jhauser.us/arithmetic/TestFloat-3e.zip;name=TestFloat \
12 http://www.jhauser.us/arithmetic/SoftFloat-3a.zip;name=SoftFloat \ 13 http://www.jhauser.us/arithmetic/SoftFloat-3e.zip;name=SoftFloat \
13 file://0001-Makefile-for-cross-compile-SoftFloat.patch \ 14 file://0001-Makefile-for-cross-compile-SoftFloat.patch \
14 file://0002-Makefile-for-cross-compile-TestFloat.patch \ 15 file://0002-Makefile-for-cross-compile-TestFloat.patch \
15" 16"
16SRC_URI[TestFloat.md5sum] = "5a124e85ab74c5e52da27d401cea6cc3" 17SRC_URI[TestFloat.md5sum] = "e70a1e6c6732abf79645a6dcca69a654"
17SRC_URI[TestFloat.sha256sum] = "fa258b5b3c751656a372051adee4183e19ad4763032322eb7a87dfb9e2c22c75" 18SRC_URI[TestFloat.sha256sum] = "6d4bdf0096b48a653aa59fc203a9e5fe18b5a58d7a1b715107c7146776a0aad6"
18SRC_URI[SoftFloat.md5sum] = "e53bd4550cf99690642c41374d188517" 19SRC_URI[SoftFloat.md5sum] = "7dac954ea4aed0697cbfee800ba4f492"
19SRC_URI[SoftFloat.sha256sum] = "946fd23180559d60eb6683dda1cf8b142f5426dedfefb97b03c6afdfd70ee9e0" 20SRC_URI[SoftFloat.sha256sum] = "21130ce885d35c1fe73fc1e1bf2244178167e05c6747cad5f450cc991714c746"
20 21
21S = "${WORKDIR}" 22S = "${WORKDIR}"
22 23