diff options
-rw-r--r-- | meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0001-f2fs-tools-Use-srcdir-prefix-to-denote-include-path.patch | 29 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0002-Fix-mkfs-out-of-tree-builds.patch | 37 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools_1.11.0.bb (renamed from meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools_1.8.0.bb) | 8 |
3 files changed, 34 insertions, 40 deletions
diff --git a/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0001-f2fs-tools-Use-srcdir-prefix-to-denote-include-path.patch b/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0001-f2fs-tools-Use-srcdir-prefix-to-denote-include-path.patch new file mode 100644 index 000000000..0a3261b4e --- /dev/null +++ b/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0001-f2fs-tools-Use-srcdir-prefix-to-denote-include-path.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 0fb9d6bc25e903f7831a38468845ea143fb5afd5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 11 Aug 2018 18:49:03 -0700 | ||
4 | Subject: [PATCH] f2fs-tools: Use srcdir prefix to denote include path | ||
5 | |||
6 | This helps builds when builddir != srcdir | ||
7 | |||
8 | Upstream-Status: Submitted [https://lkml.org/lkml/2018/8/12/1] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | tools/sg_write_buffer/Makefile.am | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/tools/sg_write_buffer/Makefile.am b/tools/sg_write_buffer/Makefile.am | ||
15 | index 922c328..19c438d 100644 | ||
16 | --- a/tools/sg_write_buffer/Makefile.am | ||
17 | +++ b/tools/sg_write_buffer/Makefile.am | ||
18 | @@ -1,7 +1,7 @@ | ||
19 | ## Makefile.am | ||
20 | |||
21 | if LINUX | ||
22 | -AM_CPPFLAGS = -I./include | ||
23 | +AM_CPPFLAGS = -I$(srcdir)/include | ||
24 | AM_CFLAGS = -Wall | ||
25 | sbin_PROGRAMS = sg_write_buffer | ||
26 | sg_write_buffer_SOURCES = sg_write_buffer.c \ | ||
27 | -- | ||
28 | 2.18.0 | ||
29 | |||
diff --git a/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0002-Fix-mkfs-out-of-tree-builds.patch b/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0002-Fix-mkfs-out-of-tree-builds.patch deleted file mode 100644 index 9e561cb11..000000000 --- a/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools/0002-Fix-mkfs-out-of-tree-builds.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 0731eefd389e01419f78a115e1363ed0c28cfd3a Mon Sep 17 00:00:00 2001 | ||
2 | From: "Yong, Jonathan" <jonathan.yong@intel.com> | ||
3 | Date: Thu, 30 Mar 2017 08:03:37 +0000 | ||
4 | Subject: [PATCH] Fix mkfs out of tree builds | ||
5 | |||
6 | Libraries are built in builddir, not srcdir, fix Makefile.am | ||
7 | accordingly. | ||
8 | |||
9 | Signed-off-by: Yong, Jonathan <jonathan.yong@intel.com> | ||
10 | Signed-off-by: Jaegeuk Kim <jaegeuk@kernel.org> | ||
11 | |||
12 | The patch was imported from the f2fs-tools repo | ||
13 | (git://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git) | ||
14 | commit ID 0731eefd389e01419f78a115e1363ed0c28cfd3a. | ||
15 | |||
16 | Upstream-Status: Accepted, expected to be included in 1.9.0. | ||
17 | |||
18 | Signed-off-by: Yong, Jonathan <jonathan.yong@intel.com> | ||
19 | |||
20 | --- | ||
21 | mkfs/Makefile.am | 2 +- | ||
22 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/mkfs/Makefile.am b/mkfs/Makefile.am | ||
25 | index 162a0cf..0ea8b49 100644 | ||
26 | --- a/mkfs/Makefile.am | ||
27 | +++ b/mkfs/Makefile.am | ||
28 | @@ -10,5 +10,5 @@ lib_LTLIBRARIES = libf2fs_format.la | ||
29 | libf2fs_format_la_SOURCES = f2fs_format_main.c f2fs_format.c f2fs_format_utils.c | ||
30 | libf2fs_format_la_CFLAGS = -DWITH_BLKDISCARD | ||
31 | libf2fs_format_la_CPPFLAGS = -I$(top_srcdir)/include | ||
32 | -libf2fs_format_la_LDFLAGS = -luuid -L$(top_srcdir)/lib -lf2fs \ | ||
33 | +libf2fs_format_la_LDFLAGS = -luuid -L$(top_builddir)/lib -lf2fs \ | ||
34 | -version-info $(FMT_CURRENT):$(FMT_REVISION):$(FMT_AGE) | ||
35 | -- | ||
36 | 2.10.2 | ||
37 | |||
diff --git a/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools_1.8.0.bb b/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools_1.11.0.bb index 691cb6ea0..2240049d4 100644 --- a/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools_1.8.0.bb +++ b/meta-filesystems/recipes-utils/f2fs-tools/f2fs-tools_1.11.0.bb | |||
@@ -7,10 +7,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=362b4b2594cd362b874a97718faa51d3" | |||
7 | # to provide libuuid | 7 | # to provide libuuid |
8 | DEPENDS = "util-linux" | 8 | DEPENDS = "util-linux" |
9 | 9 | ||
10 | SRCREV = "1e7aedf99b85d16f94d1d8ad2fcf846403bb2174" | 10 | # v1.11.0 |
11 | SRCREV = "b98fab3666e498c2e27ad9dcda6874c9b683f06b" | ||
11 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git \ | 12 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git \ |
12 | file://0001-Remove-AC_CHECK_FILE-for-cross-compilation.patch \ | 13 | file://0001-Remove-AC_CHECK_FILE-for-cross-compilation.patch \ |
13 | file://0002-Fix-mkfs-out-of-tree-builds.patch" | 14 | file://0001-f2fs-tools-Use-srcdir-prefix-to-denote-include-path.patch \ |
15 | " | ||
14 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
15 | 17 | ||
16 | inherit pkgconfig autotools | 18 | inherit pkgconfig autotools |