diff options
35 files changed, 36 insertions, 121 deletions
diff --git a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb index 44411751e..fd6b85ff2 100644 --- a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb +++ b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb | |||
@@ -13,7 +13,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}.tar.bz2 \ | |||
13 | SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9" | 13 | SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9" |
14 | SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3" | 14 | SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3" |
15 | 15 | ||
16 | inherit distutils cmake gettext | 16 | inherit distutils3 cmake gettext |
17 | 17 | ||
18 | do_install_append() { | 18 | do_install_append() { |
19 | # these files seem to only be used by symbian and trigger QA warnings | 19 | # these files seem to only be used by symbian and trigger QA warnings |
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-idle_0.2.0.bb b/meta-oe/recipes-connectivity/telepathy/telepathy-idle_0.2.0.bb index ca09f6daf..5eb00aefb 100644 --- a/meta-oe/recipes-connectivity/telepathy/telepathy-idle_0.2.0.bb +++ b/meta-oe/recipes-connectivity/telepathy/telepathy-idle_0.2.0.bb | |||
@@ -11,7 +11,7 @@ SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz | |||
11 | SRC_URI[md5sum] = "92a2de5198284cbd3c430b0d1a971a86" | 11 | SRC_URI[md5sum] = "92a2de5198284cbd3c430b0d1a971a86" |
12 | SRC_URI[sha256sum] = "3013ad4b38d14ee630b8cc8ada5e95ccaa849b9a6fe15d2eaf6d0717d76f2fab" | 12 | SRC_URI[sha256sum] = "3013ad4b38d14ee630b8cc8ada5e95ccaa849b9a6fe15d2eaf6d0717d76f2fab" |
13 | 13 | ||
14 | inherit autotools pkgconfig pythonnative | 14 | inherit autotools pkgconfig python3native |
15 | 15 | ||
16 | FILES_${PN} += "${datadir}/telepathy \ | 16 | FILES_${PN} += "${datadir}/telepathy \ |
17 | ${datadir}/dbus-1" | 17 | ${datadir}/dbus-1" |
diff --git a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb index f2faec1c1..6d52222ce 100644 --- a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb +++ b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb | |||
@@ -16,4 +16,4 @@ SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e | |||
16 | 16 | ||
17 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 17 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
18 | 18 | ||
19 | inherit setuptools | 19 | inherit setuptools3 |
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc index 91d0275b3..8ecf2fd3c 100644 --- a/meta-oe/recipes-dbs/postgresql/postgresql.inc +++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc | |||
@@ -37,7 +37,7 @@ LEAD_SONAME = "libpq.so" | |||
37 | # LDFLAGS for shared libraries | 37 | # LDFLAGS for shared libraries |
38 | export LDFLAGS_SL = "${LDFLAGS}" | 38 | export LDFLAGS_SL = "${LDFLAGS}" |
39 | 39 | ||
40 | inherit autotools pkgconfig perlnative pythonnative useradd update-rc.d systemd gettext cpan-base | 40 | inherit autotools pkgconfig perlnative python3native useradd update-rc.d systemd gettext cpan-base |
41 | 41 | ||
42 | CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6" | 42 | CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6" |
43 | 43 | ||
diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.6.bb b/meta-oe/recipes-devtools/guider/guider_3.9.6.bb index 0057db661..c8ddb1508 100644 --- a/meta-oe/recipes-devtools/guider/guider_3.9.6.bb +++ b/meta-oe/recipes-devtools/guider/guider_3.9.6.bb | |||
@@ -16,7 +16,7 @@ SRCREV = "fef25c41efb9bde0614ea477d0b90bd9565ae0b4" | |||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | R = "${RECIPE_SYSROOT}" | 17 | R = "${RECIPE_SYSROOT}" |
18 | 18 | ||
19 | inherit distutils | 19 | inherit distutils3 |
20 | 20 | ||
21 | GUIDER_OBJ = "guider.pyc" | 21 | GUIDER_OBJ = "guider.pyc" |
22 | GUIDER_SCRIPT = "guider" | 22 | GUIDER_SCRIPT = "guider" |
@@ -31,5 +31,5 @@ do_install() { | |||
31 | install -v -m 0755 ${STAGING_LIBDIR_NATIVE}/python${PYTHON_BASEVERSION}/site-packages/${BPN}/${GUIDER_OBJ} ${D}${datadir}/${BPN}/${GUIDER_OBJ} | 31 | install -v -m 0755 ${STAGING_LIBDIR_NATIVE}/python${PYTHON_BASEVERSION}/site-packages/${BPN}/${GUIDER_OBJ} ${D}${datadir}/${BPN}/${GUIDER_OBJ} |
32 | } | 32 | } |
33 | 33 | ||
34 | RDEPENDS_${PN} = "python-ctypes python-shell \ | 34 | RDEPENDS_${PN} = "python3-ctypes python3-shell \ |
35 | python-json python-subprocess" | 35 | python3-json python3-subprocess" |
diff --git a/meta-oe/recipes-devtools/nanopb/nanopb_0.4.0.bb b/meta-oe/recipes-devtools/nanopb/nanopb_0.4.0.bb index aedd53a7a..dc270eab3 100644 --- a/meta-oe/recipes-devtools/nanopb/nanopb_0.4.0.bb +++ b/meta-oe/recipes-devtools/nanopb/nanopb_0.4.0.bb | |||
@@ -9,7 +9,7 @@ SRCREV = "70f0de9877b1ce12abc0229d5df84db6349fcbfc" | |||
9 | 9 | ||
10 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
11 | 11 | ||
12 | inherit cmake pythonnative | 12 | inherit cmake python3native |
13 | 13 | ||
14 | do_install_append() { | 14 | do_install_append() { |
15 | install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py | 15 | install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py |
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb index 71a47636b..a9ca58f8b 100644 --- a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb +++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c" | |||
6 | DEPENDS = "openssl" | 6 | DEPENDS = "openssl" |
7 | DEPENDS_append_class-target = " nodejs-native" | 7 | DEPENDS_append_class-target = " nodejs-native" |
8 | 8 | ||
9 | inherit pkgconfig pythonnative | 9 | inherit pkgconfig python3native |
10 | 10 | ||
11 | COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*" | 11 | COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*" |
12 | COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*" | 12 | COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*" |
diff --git a/meta-oe/recipes-devtools/php/php_7.3.11.bb b/meta-oe/recipes-devtools/php/php_7.3.11.bb index e7fb847fa..0e76cbf75 100644 --- a/meta-oe/recipes-devtools/php/php_7.3.11.bb +++ b/meta-oe/recipes-devtools/php/php_7.3.11.bb | |||
@@ -37,7 +37,7 @@ S = "${WORKDIR}/php-${PV}" | |||
37 | SRC_URI[md5sum] = "21b710b4126d4d54714de9693a6c7b0d" | 37 | SRC_URI[md5sum] = "21b710b4126d4d54714de9693a6c7b0d" |
38 | SRC_URI[sha256sum] = "92d1ff4b13c7093635f1ec338a5e6891ca99b10e65fbcadd527e5bb84d11b5e7" | 38 | SRC_URI[sha256sum] = "92d1ff4b13c7093635f1ec338a5e6891ca99b10e65fbcadd527e5bb84d11b5e7" |
39 | 39 | ||
40 | inherit autotools pkgconfig pythonnative gettext | 40 | inherit autotools pkgconfig python3native gettext |
41 | 41 | ||
42 | # phpize is not scanned for absolute paths by default (but php-config is). | 42 | # phpize is not scanned for absolute paths by default (but php-config is). |
43 | # | 43 | # |
diff --git a/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb b/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb deleted file mode 100644 index 1255a51f7..000000000 --- a/meta-oe/recipes-devtools/python/python-cpuset_1.6.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
5 | |||
6 | S = "${WORKDIR}/git" | ||
7 | SRCREV = "6c46d71a1c6ee711063153b9f7787280128f7252" | ||
8 | SRC_URI = "git://github.com/lpechacek/cpuset.git;protocol=https;" | ||
9 | |||
10 | inherit distutils | ||
11 | |||
12 | RDEPENDS_${PN} = "\ | ||
13 | python-core \ | ||
14 | python-re \ | ||
15 | python-logging \ | ||
16 | python-textutils \ | ||
17 | python-unixadmin \ | ||
18 | " | ||
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.bb b/meta-oe/recipes-devtools/python/python-distutils-extra.bb deleted file mode 100644 index eb84f7436..000000000 --- a/meta-oe/recipes-devtools/python/python-distutils-extra.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | require python-distutils-extra.inc | ||
2 | |||
3 | inherit setuptools | ||
4 | |||
5 | RDEPENDS_${PN} = "\ | ||
6 | python-distutils \ | ||
7 | " | ||
diff --git a/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb b/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb deleted file mode 100644 index 1636f7371..000000000 --- a/meta-oe/recipes-devtools/python/python-futures_3.3.0.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=834d982f973c48b6d662b5944c5ab567" | ||
5 | HOMEPAGE = "https://github.com/agronholm/pythonfutures" | ||
6 | DEPENDS = "python" | ||
7 | |||
8 | SRC_URI[md5sum] = "b43a39ae1475e3fd6940f2b4f7214675" | ||
9 | SRC_URI[sha256sum] = "7e033af76a5e35f58e56da7a91e687706faf4e7bdfb2cbc3f2cca6b9bcda9794" | ||
10 | |||
11 | inherit pypi setuptools | ||
12 | |||
13 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb b/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb deleted file mode 100644 index d00d1e2a0..000000000 --- a/meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | DESCRIPTION = "JavaScript minifier." | ||
2 | HOMEPAGE = "https://github.com/tikitu/jsmin/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a3301ce2ad647e172f4a1016c67324d" | ||
6 | |||
7 | inherit setuptools pypi | ||
8 | SRC_URI[md5sum] = "00e7a3179a4591aab2ee707b3214e2fd" | ||
9 | SRC_URI[sha256sum] = "b6df99b2cd1c75d9d342e4335b535789b8da9107ec748212706ef7bbe5c2553b" | ||
10 | |||
11 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pytoml.inc b/meta-oe/recipes-devtools/python/python-pytoml.inc deleted file mode 100644 index 180531d75..000000000 --- a/meta-oe/recipes-devtools/python/python-pytoml.inc +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | SUMMARY = "A TOML-0.4.0 parser/writer for Python" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/pytoml/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cfff423699bdaef24331933ac4f56078" | ||
6 | |||
7 | SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b" | ||
8 | SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb b/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb deleted file mode 100644 index 88fa95317..000000000 --- a/meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-pytoml.inc | ||
diff --git a/meta-oe/recipes-devtools/python/python-six_1.13.0.bb b/meta-oe/recipes-devtools/python/python-six_1.13.0.bb deleted file mode 100644 index af26e83d6..000000000 --- a/meta-oe/recipes-devtools/python/python-six_1.13.0.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit pypi setuptools | ||
2 | require recipes-devtools/python/python-six.inc | ||
diff --git a/meta-oe/recipes-devtools/python/python-which_1.1.0.bb b/meta-oe/recipes-devtools/python/python-which_1.1.0.bb deleted file mode 100644 index 901fdc763..000000000 --- a/meta-oe/recipes-devtools/python/python-which_1.1.0.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | DESCRIPTION = "which.py -- a portable GNU which replacement" | ||
2 | HOMEPAGE = "http://code.google.com/p/which/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=030b09798681482b9ad12ac47be496ea" | ||
6 | |||
7 | inherit setuptools pypi python-dir | ||
8 | |||
9 | SRCREV = "425bdeeb2d87c36e2313dc4b8d69ff2bb5a02ee9" | ||
10 | PYPI_SRC_URI = "git://github.com/trentm/which" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | do_install_append() { | ||
15 | rmdir -p --ignore-fail-on-non-empty ${D}${STAGING_BINDIR_NATIVE} | ||
16 | rmdir -p --ignore-fail-on-non-empty ${D}${datadir} | ||
17 | } | ||
18 | |||
19 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch b/meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch index 848cda5aa..848cda5aa 100644 --- a/meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch +++ b/meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch | |||
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb b/meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb index 0cbd07f66..b016df719 100644 --- a/meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb +++ b/meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb | |||
@@ -5,14 +5,13 @@ LICENSE = "LGPLv2.1" | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
6 | 6 | ||
7 | GNOMEBASEBUILDCLASS = "meson" | 7 | GNOMEBASEBUILDCLASS = "meson" |
8 | inherit gnomebase gobject-introspection distutils-base upstream-version-is-even | 8 | inherit gnomebase gobject-introspection distutils3-base upstream-version-is-even |
9 | 9 | ||
10 | DEPENDS += "python glib-2.0" | 10 | DEPENDS += "python3 glib-2.0" |
11 | 11 | ||
12 | SRCNAME = "pygobject" | 12 | SRCNAME = "pygobject" |
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ | 14 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
15 | file://0001-python-pyobject-fix-install-dir.patch \ | ||
16 | " | 15 | " |
17 | 16 | ||
18 | SRC_URI[md5sum] = "ca1dc4f31c1d6d283758e8f315a88ab6" | 17 | SRC_URI[md5sum] = "ca1dc4f31c1d6d283758e8f315a88ab6" |
@@ -22,12 +21,12 @@ S = "${WORKDIR}/${SRCNAME}-${PV}" | |||
22 | 21 | ||
23 | UNKNOWN_CONFIGURE_WHITELIST = "introspection" | 22 | UNKNOWN_CONFIGURE_WHITELIST = "introspection" |
24 | 23 | ||
25 | PACKAGECONFIG ??= "stagedir" | 24 | PACKAGECONFIG ??= "" |
26 | 25 | ||
27 | PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo" | 26 | PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo" |
28 | PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , " | 27 | PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , " |
29 | PACKAGECONFIG[python] = "-Dpython=python3, -Dpython=python2, , " | 28 | |
30 | PACKAGECONFIG[stagedir] = "-Dstagedir=${PYTHON_SITEPACKAGES_DIR}, -Dstagedir="", , " | 29 | EXTRA_OEMESON_append = " -Dpython=python3" |
31 | 30 | ||
32 | BBCLASSEXTEND = "native" | 31 | BBCLASSEXTEND = "native" |
33 | RDEPENDS_${PN} = "python-pkgutil" | 32 | RDEPENDS_${PN} = "python-pkgutil" |
diff --git a/meta-oe/recipes-devtools/sip/sip_4.19.19.bb b/meta-oe/recipes-devtools/sip/sip_4.19.19.bb index 3da15b842..6299de487 100644 --- a/meta-oe/recipes-devtools/sip/sip_4.19.19.bb +++ b/meta-oe/recipes-devtools/sip/sip_4.19.19.bb | |||
@@ -2,7 +2,7 @@ require sip.inc | |||
2 | 2 | ||
3 | DEPENDS = "python" | 3 | DEPENDS = "python" |
4 | 4 | ||
5 | inherit python-dir pythonnative | 5 | inherit python3-dir python3native |
6 | 6 | ||
7 | PACKAGES += "python-sip" | 7 | PACKAGES += "python-sip" |
8 | 8 | ||
diff --git a/meta-oe/recipes-devtools/yasm/yasm_git.bb b/meta-oe/recipes-devtools/yasm/yasm_git.bb index dc4fbf7f5..53856263f 100644 --- a/meta-oe/recipes-devtools/yasm/yasm_git.bb +++ b/meta-oe/recipes-devtools/yasm/yasm_git.bb | |||
@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/yasm/yasm.git" | |||
13 | 13 | ||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||
16 | inherit autotools gettext pythonnative | 16 | inherit autotools gettext python3native |
17 | 17 | ||
18 | CACHED_CONFIGUREVARS = "CCLD_FOR_BUILD='${CC_FOR_BUILD}'" | 18 | CACHED_CONFIGUREVARS = "CCLD_FOR_BUILD='${CC_FOR_BUILD}'" |
19 | 19 | ||
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb b/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb index 0951ac076..8b9fd74a8 100644 --- a/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb +++ b/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb | |||
@@ -19,7 +19,7 @@ SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \ | |||
19 | SRC_URI[md5sum] = "bfce96c42cede5243028510bcc57c1e6" | 19 | SRC_URI[md5sum] = "bfce96c42cede5243028510bcc57c1e6" |
20 | SRC_URI[sha256sum] = "e796fda27ce06377f491ad91aa286962a68c2b54076aa77a29673d53204453da" | 20 | SRC_URI[sha256sum] = "e796fda27ce06377f491ad91aa286962a68c2b54076aa77a29673d53204453da" |
21 | 21 | ||
22 | inherit autotools pythonnative update-rc.d pkgconfig systemd | 22 | inherit autotools python3native update-rc.d pkgconfig systemd |
23 | 23 | ||
24 | SYSTEMD_SERVICE_${PN} = "collectd.service" | 24 | SYSTEMD_SERVICE_${PN} = "collectd.service" |
25 | 25 | ||
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb index 77c995b57..765a84643 100644 --- a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb +++ b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb | |||
@@ -14,7 +14,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \ | |||
14 | 14 | ||
15 | DEPENDS += "cups python libusb" | 15 | DEPENDS += "cups python libusb" |
16 | 16 | ||
17 | inherit autotools-brokensep python-dir pythonnative pkgconfig | 17 | inherit autotools-brokensep python3-dir python3native pkgconfig |
18 | 18 | ||
19 | export STAGING_INCDIR | 19 | export STAGING_INCDIR |
20 | export STAGING_LIBDIR | 20 | export STAGING_LIBDIR |
diff --git a/meta-oe/recipes-extended/iotop/iotop_0.6.bb b/meta-oe/recipes-extended/iotop/iotop_0.6.bb index b01d7f64e..68cc35224 100644 --- a/meta-oe/recipes-extended/iotop/iotop_0.6.bb +++ b/meta-oe/recipes-extended/iotop/iotop_0.6.bb | |||
@@ -15,13 +15,13 @@ SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8d | |||
15 | UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags" | 15 | UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags" |
16 | UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)" | 16 | UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)" |
17 | 17 | ||
18 | inherit distutils | 18 | inherit distutils3 |
19 | 19 | ||
20 | do_install_append() { | 20 | do_install_append() { |
21 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true | 21 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true |
22 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true | 22 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true |
23 | } | 23 | } |
24 | 24 | ||
25 | RDEPENDS_${PN} = "python-curses python-textutils \ | 25 | RDEPENDS_${PN} = "python3-curses python3-textutils \ |
26 | python-codecs python-ctypes python-pprint \ | 26 | python3-codecs python3-ctypes python3-pprint \ |
27 | python-shell python-subprocess python-core" | 27 | python3-shell python3-subprocess python3-core" |
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb index 48dec47a8..4a8d9a1df 100644 --- a/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb +++ b/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \ | |||
6 | 6 | ||
7 | DEPENDS = "libxml2 glib-2.0 swig python" | 7 | DEPENDS = "libxml2 glib-2.0 swig python" |
8 | 8 | ||
9 | inherit autotools pkgconfig pythonnative | 9 | inherit autotools pkgconfig python3native |
10 | 10 | ||
11 | SRCREV = "3df02d4d0e9008771e8622fdc10de8333b3f0d85" | 11 | SRCREV = "3df02d4d0e9008771e8622fdc10de8333b3f0d85" |
12 | SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \ | 12 | SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \ |
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb index 419b3ee6e..754476d67 100644 --- a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb +++ b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb | |||
@@ -5,9 +5,9 @@ LICENSE = "GPLv2+" | |||
5 | LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e" | 5 | LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e" |
6 | SECTION = "System/Management" | 6 | SECTION = "System/Management" |
7 | 7 | ||
8 | inherit setuptools | 8 | inherit setuptools3 |
9 | 9 | ||
10 | DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem" | 10 | DEPENDS = "python3-native python3-pywbem-native python3-m2crypto python-pywbem" |
11 | 11 | ||
12 | SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \ | 12 | SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \ |
13 | " | 13 | " |
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb index b39ceda80..c7dbb6e39 100644 --- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb +++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb | |||
@@ -15,7 +15,7 @@ SRC_URI = "\ | |||
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | 17 | ||
18 | inherit cpan autotools-brokensep gettext pythonnative python-dir systemd | 18 | inherit cpan autotools-brokensep gettext python3native python3-dir systemd |
19 | 19 | ||
20 | BBCLASSEXTEND = "native" | 20 | BBCLASSEXTEND = "native" |
21 | 21 | ||
diff --git a/meta-oe/recipes-gnome/pyxdg/pyxdg_0.26.bb b/meta-oe/recipes-gnome/pyxdg/pyxdg_0.26.bb index 0128a7c22..a957c1d67 100644 --- a/meta-oe/recipes-gnome/pyxdg/pyxdg_0.26.bb +++ b/meta-oe/recipes-gnome/pyxdg/pyxdg_0.26.bb | |||
@@ -7,6 +7,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a" | |||
7 | SRCREV = "7db14dcf4c4305c3859a2d9fcf9f5da2db328330" | 7 | SRCREV = "7db14dcf4c4305c3859a2d9fcf9f5da2db328330" |
8 | SRC_URI = "git://anongit.freedesktop.org/xdg/pyxdg" | 8 | SRC_URI = "git://anongit.freedesktop.org/xdg/pyxdg" |
9 | 9 | ||
10 | inherit distutils | 10 | inherit distutils3 |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb index d1ba48203..51f5a4eca 100644 --- a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb +++ b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb | |||
@@ -40,7 +40,7 @@ SRCREV = "88eab6dc16da6e5dd25fe97fbb56b96ef0d58657" | |||
40 | 40 | ||
41 | S = "${WORKDIR}/git" | 41 | S = "${WORKDIR}/git" |
42 | 42 | ||
43 | inherit autotools gettext update-alternatives pkgconfig pythonnative perlnative features_check | 43 | inherit autotools gettext update-alternatives pkgconfig python3native perlnative features_check |
44 | # depends on virtual/libx11 | 44 | # depends on virtual/libx11 |
45 | REQUIRED_DISTRO_FEATURES = "x11" | 45 | REQUIRED_DISTRO_FEATURES = "x11" |
46 | 46 | ||
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-lohit_2.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-lohit_2.bb index f9679d606..0af0e91d6 100644 --- a/meta-oe/recipes-graphics/ttf-fonts/ttf-lohit_2.bb +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-lohit_2.bb | |||
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git" | |||
15 | FONT_PACKAGES = "${PN}" | 15 | FONT_PACKAGES = "${PN}" |
16 | FILES_${PN} = "${datadir}" | 16 | FILES_${PN} = "${datadir}" |
17 | 17 | ||
18 | inherit pythonnative | 18 | inherit python3native |
19 | 19 | ||
20 | do_compile() { | 20 | do_compile() { |
21 | cd ${S}; make ttf; | 21 | cd ${S}; make ttf; |
diff --git a/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb b/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb index 245dfe22c..1b289916d 100644 --- a/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb +++ b/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb | |||
@@ -24,7 +24,7 @@ SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f2 | |||
24 | 24 | ||
25 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
26 | 26 | ||
27 | inherit waf pkgconfig pythonnative features_check | 27 | inherit waf pkgconfig python3native features_check |
28 | 28 | ||
29 | LUA ?= "lua" | 29 | LUA ?= "lua" |
30 | LUA_mips64 = "" | 30 | LUA_mips64 = "" |
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.19.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.19.bb index 9fdbbf254..dbbc7140f 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.19.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.19.bb | |||
@@ -12,7 +12,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ | |||
12 | SRC_URI[md5sum] = "b3bf88706794eb8e5f2c2543bf7ba87b" | 12 | SRC_URI[md5sum] = "b3bf88706794eb8e5f2c2543bf7ba87b" |
13 | SRC_URI[sha256sum] = "27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39" | 13 | SRC_URI[sha256sum] = "27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39" |
14 | 14 | ||
15 | inherit scons update-rc.d python-dir pythonnative systemd update-alternatives | 15 | inherit scons update-rc.d python3-dir python3native systemd update-alternatives |
16 | 16 | ||
17 | INITSCRIPT_PACKAGES = "gpsd-conf" | 17 | INITSCRIPT_PACKAGES = "gpsd-conf" |
18 | INITSCRIPT_NAME = "gpsd" | 18 | INITSCRIPT_NAME = "gpsd" |
diff --git a/meta-oe/recipes-security/nmap/nmap_7.80.bb b/meta-oe/recipes-security/nmap/nmap_7.80.bb index f24194da7..2ac600c78 100644 --- a/meta-oe/recipes-security/nmap/nmap_7.80.bb +++ b/meta-oe/recipes-security/nmap/nmap_7.80.bb | |||
@@ -15,7 +15,7 @@ SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \ | |||
15 | SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5" | 15 | SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5" |
16 | SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa" | 16 | SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa" |
17 | 17 | ||
18 | inherit autotools-brokensep pkgconfig pythonnative | 18 | inherit autotools-brokensep pkgconfig python3native |
19 | 19 | ||
20 | PACKAGECONFIG ?= "ncat nping ndiff pcap" | 20 | PACKAGECONFIG ?= "ncat nping ndiff pcap" |
21 | 21 | ||
diff --git a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb index ea54e7552..058117ed8 100644 --- a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb +++ b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb | |||
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/Datera/lio-utils.git \ | |||
12 | SRCREV = "0ac9091c1ff7a52d5435a4f4449e82637142e06e" | 12 | SRCREV = "0ac9091c1ff7a52d5435a4f4449e82637142e06e" |
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
15 | inherit distutils | 15 | inherit distutils3 |
16 | 16 | ||
17 | EXTRA_OEMAKE += "DESTDIR=${D}" | 17 | EXTRA_OEMAKE += "DESTDIR=${D}" |
18 | 18 | ||
diff --git a/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb b/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb index 26b4412f5..1ce3c8e44 100644 --- a/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb +++ b/meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb | |||
@@ -6,7 +6,7 @@ SRC_URI = "https://fedorahosted.org/releases/s/y/${BPN}/${BP}.tar.bz2" | |||
6 | SRC_URI[md5sum] = "c267db0ee7a2131ba418399dc17f9e72" | 6 | SRC_URI[md5sum] = "c267db0ee7a2131ba418399dc17f9e72" |
7 | SRC_URI[sha256sum] = "218c883e4e2bfcc82bfe07e785707b5c2ece28df772f2155fd044b9bb1614284" | 7 | SRC_URI[sha256sum] = "218c883e4e2bfcc82bfe07e785707b5c2ece28df772f2155fd044b9bb1614284" |
8 | 8 | ||
9 | inherit python-dir gettext | 9 | inherit python3-dir gettext |
10 | DEPENDS += "intltool-native gettext-native" | 10 | DEPENDS += "intltool-native gettext-native" |
11 | 11 | ||
12 | EXTRA_OEMAKE = " \ | 12 | EXTRA_OEMAKE = " \ |
diff --git a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb index 342fccf41..252eea366 100644 --- a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb +++ b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb | |||
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f489 | |||
10 | 10 | ||
11 | S = "${WORKDIR}/cxxtest-${PV}/python" | 11 | S = "${WORKDIR}/cxxtest-${PV}/python" |
12 | 12 | ||
13 | inherit distutils | 13 | inherit distutils3 |
14 | 14 | ||
15 | do_install_append() { | 15 | do_install_append() { |
16 | install -d ${D}${includedir} | 16 | install -d ${D}${includedir} |