summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch50
-rw-r--r--meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch24
-rw-r--r--meta-oe/recipes-graphics/spir/spirv-tools_git.bb12
3 files changed, 56 insertions, 30 deletions
diff --git a/meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch b/meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch
new file mode 100644
index 000000000..9b48cdcd0
--- /dev/null
+++ b/meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch
@@ -0,0 +1,50 @@
1From 4fffcd275b50d08b54b0411679ead98970651bad Mon Sep 17 00:00:00 2001
2From: David Neto <dneto@google.com>
3Date: Fri, 27 Dec 2019 12:05:58 -0500
4Subject: [PATCH] Avoid pessimizing std::move (#3124)
5
6Should fix a warning
7
8Upstream-Status: Backport [https://github.com/KhronosGroup/SPIRV-Tools/commit/8aa423930db37e37086665efcc55944d577c06e5]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 test/opt/pass_fixture.h | 9 +++------
12 1 file changed, 3 insertions(+), 6 deletions(-)
13
14diff --git a/test/opt/pass_fixture.h b/test/opt/pass_fixture.h
15index 53fb206f..64c089d8 100644
16--- a/test/opt/pass_fixture.h
17+++ b/test/opt/pass_fixture.h
18@@ -60,8 +60,7 @@ class PassTest : public TestT {
19 // from pass Process() function.
20 std::tuple<std::vector<uint32_t>, Pass::Status> OptimizeToBinary(
21 Pass* pass, const std::string& original, bool skip_nop) {
22- context_ =
23- std::move(BuildModule(env_, consumer_, original, assemble_options_));
24+ context_ = BuildModule(env_, consumer_, original, assemble_options_);
25 EXPECT_NE(nullptr, context()) << "Assembling failed for shader:\n"
26 << original << std::endl;
27 if (!context()) {
28@@ -197,8 +196,7 @@ class PassTest : public TestT {
29 // messages.
30 template <typename PassT, typename... Args>
31 void SinglePassRunAndFail(const std::string& original, Args&&... args) {
32- context_ =
33- std::move(BuildModule(env_, consumer_, original, assemble_options_));
34+ context_ = BuildModule(env_, consumer_, original, assemble_options_);
35 EXPECT_NE(nullptr, context()) << "Assembling failed for shader:\n"
36 << original << std::endl;
37 std::ostringstream errs;
38@@ -235,8 +233,7 @@ class PassTest : public TestT {
39 void RunAndCheck(const std::string& original, const std::string& expected) {
40 assert(manager_->NumPasses());
41
42- context_ =
43- std::move(BuildModule(env_, nullptr, original, assemble_options_));
44+ context_ = BuildModule(env_, nullptr, original, assemble_options_);
45 ASSERT_NE(nullptr, context());
46
47 context()->set_preserve_bindings(OptimizerOptions()->preserve_bindings_);
48--
492.24.1
50
diff --git a/meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch b/meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch
deleted file mode 100644
index e9a45c24f..000000000
--- a/meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1From 03127fd5a6eff5ae2ebea2e9c6c01fbf1a0a421a Mon Sep 17 00:00:00 2001
2From: Ankit Navik <ankit.tarot@gmail.com>
3Date: Tue, 25 Dec 2018 14:34:09 +0530
4Subject: [PATCH] tools/lesspipe: Allow generic shell
5
6Upstream-Status: Submitted [https://github.com/KhronosGroup/SPIRV-Tools/pull/2255]
7Signed-off-by: Ankit Navik <ankit.tarot@gmail.com>
8---
9 tools/lesspipe/spirv-lesspipe.sh | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/tools/lesspipe/spirv-lesspipe.sh b/tools/lesspipe/spirv-lesspipe.sh
13index 81e3355..f955259 100644
14--- a/tools/lesspipe/spirv-lesspipe.sh
15+++ b/tools/lesspipe/spirv-lesspipe.sh
16@@ -1,4 +1,4 @@
17-#!/bin/bash
18+#!/usr/bin/env sh
19 # Copyright (c) 2016 The Khronos Group Inc.
20
21 # Licensed under the Apache License, Version 2.0 (the "License");
22--
232.7.4
24
diff --git a/meta-oe/recipes-graphics/spir/spirv-tools_git.bb b/meta-oe/recipes-graphics/spir/spirv-tools_git.bb
index 49a91b005..c4db017e8 100644
--- a/meta-oe/recipes-graphics/spir/spirv-tools_git.bb
+++ b/meta-oe/recipes-graphics/spir/spirv-tools_git.bb
@@ -13,14 +13,14 @@ SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;name=spirv-tools \
13 git://github.com/google/effcee.git;name=effcee;destsuffix=${DEST_DIR}/effcee \ 13 git://github.com/google/effcee.git;name=effcee;destsuffix=${DEST_DIR}/effcee \
14 git://github.com/google/re2.git;name=re2;destsuffix=${DEST_DIR}/re2 \ 14 git://github.com/google/re2.git;name=re2;destsuffix=${DEST_DIR}/re2 \
15 git://github.com/google/googletest.git;name=googletest;destsuffix=${DEST_DIR}/googletest \ 15 git://github.com/google/googletest.git;name=googletest;destsuffix=${DEST_DIR}/googletest \
16 file://0001-tools-lesspipe-Allow-generic-shell.patch \
17 file://0001-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-file.patch \ 16 file://0001-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-file.patch \
17 file://0001-Avoid-pessimizing-std-move-3124.patch \
18" 18"
19SRCREV_spirv-tools = "167f1270a9ee641b17c016a545741e4aadfabe86" 19SRCREV_spirv-tools = "c413b982c316b14e784f50d941814fc737b55b4a"
20SRCREV_spirv-headers = "4618b86e9e4b027a22040732dfee35e399cd2c47" 20SRCREV_spirv-headers = "af64a9e826bf5bb5fcd2434dd71be1e41e922563"
21SRCREV_effcee = "8f0a61dc95e0df18c18e0ac56d83b3fa9d2fe90b" 21SRCREV_effcee = "cd25ec17e9382f99a895b9ef53ff3c277464d07d"
22SRCREV_re2 = "2cf86e5ab6dcfe045a1f510c2b9a8b012a4158cd" 22SRCREV_re2 = "5bd613749fd530b576b890283bfb6bc6ea6246cb"
23SRCREV_googletest = "150613166524c474a8a97df4c01d46b72050c495" 23SRCREV_googletest = "f2fb48c3b3d79a75a88a99fba6576b25d42ec528"
24 24
25inherit cmake python3native 25inherit cmake python3native
26 26