diff options
-rw-r--r-- | meta-oe/recipes-support/libssh/libssh/0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch | 10 | ||||
-rw-r--r-- | meta-oe/recipes-support/libssh/libssh/0001-tests-CMakeLists.txt-do-not-search-ssh-sshd-commands.patch | 10 | ||||
-rw-r--r-- | meta-oe/recipes-support/libssh/libssh_0.10.6.bb (renamed from meta-oe/recipes-support/libssh/libssh_0.10.5.bb) | 2 |
3 files changed, 9 insertions, 13 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh/0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch b/meta-oe/recipes-support/libssh/libssh/0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch index 19775fa52..d2d1fb595 100644 --- a/meta-oe/recipes-support/libssh/libssh/0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch +++ b/meta-oe/recipes-support/libssh/libssh/0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 0cade4573334571055127a2d4fe3641e2397948d Mon Sep 17 00:00:00 2001 | 1 | From 49a8ae4d6f77434ed9f7a601b9df488b921e4a22 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 20 Mar 2023 21:59:19 -0700 | 3 | Date: Mon, 20 Mar 2023 21:59:19 -0700 |
4 | Subject: [PATCH] libgcrypt.c: Fix prototype of des3_encrypt/des3_decrypt | 4 | Subject: [PATCH] libgcrypt.c: Fix prototype of des3_encrypt/des3_decrypt |
@@ -18,15 +18,16 @@ TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/libssh/0.10.4-r0/git/ | |||
18 | Upstream-Status: Pending | 18 | Upstream-Status: Pending |
19 | 19 | ||
20 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 20 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
21 | |||
21 | --- | 22 | --- |
22 | src/libgcrypt.c | 4 ++-- | 23 | src/libgcrypt.c | 4 ++-- |
23 | 1 file changed, 2 insertions(+), 2 deletions(-) | 24 | 1 file changed, 2 insertions(+), 2 deletions(-) |
24 | 25 | ||
25 | diff --git a/src/libgcrypt.c b/src/libgcrypt.c | 26 | diff --git a/src/libgcrypt.c b/src/libgcrypt.c |
26 | index da5588ad..e482b654 100644 | 27 | index f410d997..e3f66781 100644 |
27 | --- a/src/libgcrypt.c | 28 | --- a/src/libgcrypt.c |
28 | +++ b/src/libgcrypt.c | 29 | +++ b/src/libgcrypt.c |
29 | @@ -469,12 +469,12 @@ static int des3_set_key(struct ssh_cipher_struct *cipher, void *key, void *IV) { | 30 | @@ -416,12 +416,12 @@ static int des3_set_key(struct ssh_cipher_struct *cipher, void *key, void *IV) { |
30 | } | 31 | } |
31 | 32 | ||
32 | static void des3_encrypt(struct ssh_cipher_struct *cipher, void *in, | 33 | static void des3_encrypt(struct ssh_cipher_struct *cipher, void *in, |
@@ -41,6 +42,3 @@ index da5588ad..e482b654 100644 | |||
41 | gcry_cipher_decrypt(cipher->key[0], out, len, in, len); | 42 | gcry_cipher_decrypt(cipher->key[0], out, len, in, len); |
42 | } | 43 | } |
43 | 44 | ||
44 | -- | ||
45 | 2.40.0 | ||
46 | |||
diff --git a/meta-oe/recipes-support/libssh/libssh/0001-tests-CMakeLists.txt-do-not-search-ssh-sshd-commands.patch b/meta-oe/recipes-support/libssh/libssh/0001-tests-CMakeLists.txt-do-not-search-ssh-sshd-commands.patch index 0c7f53029..d6bc75c3a 100644 --- a/meta-oe/recipes-support/libssh/libssh/0001-tests-CMakeLists.txt-do-not-search-ssh-sshd-commands.patch +++ b/meta-oe/recipes-support/libssh/libssh/0001-tests-CMakeLists.txt-do-not-search-ssh-sshd-commands.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From d2525ba0bc7b11de12c54ea1a3d1eb862537136d Mon Sep 17 00:00:00 2001 | 1 | From 69a89e8f015802f61637fed0d3791d20a594f298 Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Wed, 15 Mar 2023 16:51:58 +0800 | 3 | Date: Wed, 15 Mar 2023 16:51:58 +0800 |
4 | Subject: [PATCH] tests/CMakeLists.txt: do not search ssh/sshd commands on host | 4 | Subject: [PATCH] tests/CMakeLists.txt: do not search ssh/sshd commands on host |
@@ -9,12 +9,13 @@ not required by unittests, we can skip the search. | |||
9 | Upstream-Status: Inappropriate [embedded specific] | 9 | Upstream-Status: Inappropriate [embedded specific] |
10 | 10 | ||
11 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | 11 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> |
12 | |||
12 | --- | 13 | --- |
13 | tests/CMakeLists.txt | 2 ++ | 14 | tests/CMakeLists.txt | 2 ++ |
14 | 1 file changed, 2 insertions(+) | 15 | 1 file changed, 2 insertions(+) |
15 | 16 | ||
16 | diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt | 17 | diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt |
17 | index 22a36f37..aa32ca2e 100644 | 18 | index f5c30061..885c926a 100644 |
18 | --- a/tests/CMakeLists.txt | 19 | --- a/tests/CMakeLists.txt |
19 | +++ b/tests/CMakeLists.txt | 20 | +++ b/tests/CMakeLists.txt |
20 | @@ -86,6 +86,7 @@ set(TEST_TARGET_LIBRARIES | 21 | @@ -86,6 +86,7 @@ set(TEST_TARGET_LIBRARIES |
@@ -25,7 +26,7 @@ index 22a36f37..aa32ca2e 100644 | |||
25 | # OpenSSH Capabilities are required for all unit tests | 26 | # OpenSSH Capabilities are required for all unit tests |
26 | find_program(SSH_EXECUTABLE NAMES ssh) | 27 | find_program(SSH_EXECUTABLE NAMES ssh) |
27 | if (SSH_EXECUTABLE) | 28 | if (SSH_EXECUTABLE) |
28 | @@ -293,6 +294,7 @@ if (CLIENT_TESTING OR SERVER_TESTING) | 29 | @@ -302,6 +303,7 @@ if (CLIENT_TESTING OR SERVER_TESTING) |
29 | 30 | ||
30 | message(STATUS "TORTURE_ENVIRONMENT=${TORTURE_ENVIRONMENT}") | 31 | message(STATUS "TORTURE_ENVIRONMENT=${TORTURE_ENVIRONMENT}") |
31 | endif () | 32 | endif () |
@@ -33,6 +34,3 @@ index 22a36f37..aa32ca2e 100644 | |||
33 | 34 | ||
34 | configure_file(tests_config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/tests_config.h) | 35 | configure_file(tests_config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/tests_config.h) |
35 | 36 | ||
36 | -- | ||
37 | 2.25.1 | ||
38 | |||
diff --git a/meta-oe/recipes-support/libssh/libssh_0.10.5.bb b/meta-oe/recipes-support/libssh/libssh_0.10.6.bb index f33987acf..31f29c1b7 100644 --- a/meta-oe/recipes-support/libssh/libssh_0.10.5.bb +++ b/meta-oe/recipes-support/libssh/libssh_0.10.6.bb | |||
@@ -11,7 +11,7 @@ SRC_URI = "git://git.libssh.org/projects/libssh.git;protocol=https;branch=stable | |||
11 | file://0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch \ | 11 | file://0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch \ |
12 | file://run-ptest \ | 12 | file://run-ptest \ |
13 | " | 13 | " |
14 | SRCREV = "479eca13aaaa46b43e68c52186e3783f06ae6f34" | 14 | SRCREV = "10e09e273f69e149389b3e0e5d44b8c221c2e7f6" |
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | 17 | ||