summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
index 340f57dc7..799cf8611 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -2,7 +2,7 @@ SUMMARY = "C++ library for client-side URL transfers"
2HOMEPAGE = "http://www.curlpp.org/" 2HOMEPAGE = "http://www.curlpp.org/"
3SECTION = "libdevel" 3SECTION = "libdevel"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 5LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=fd0c9adf285a69aa3b4faf34384e1029"
6 6
7DEPENDS = "curl" 7DEPENDS = "curl"
8DEPENDS_class-native = "curl-native" 8DEPENDS_class-native = "curl-native"
@@ -15,19 +15,4 @@ S = "${WORKDIR}/git"
15 15
16inherit cmake pkgconfig binconfig 16inherit cmake pkgconfig binconfig
17 17
18do_install_append () {
19 sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc
20}
21
22PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
23
24FILES_lib${BPN} = "${libdir}/lib*.so.*"
25
26FILES_lib${BPN}-dev = "${includedir} \
27 ${libdir}/pkgconfig \
28 ${bindir}/*-config \
29"
30
31FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
32
33BBCLASSEXTEND = "native nativesdk" 18BBCLASSEXTEND = "native nativesdk"