diff options
-rw-r--r-- | meta-oe/recipes-extended/dlt-daemon/dlt-daemon/245.patch (renamed from meta-oe/recipes-extended/dlt-daemon/dlt-daemon/238.patch) | 53 | ||||
-rw-r--r-- | meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.5.bb | 2 |
2 files changed, 47 insertions, 8 deletions
diff --git a/meta-oe/recipes-extended/dlt-daemon/dlt-daemon/238.patch b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon/245.patch index 14c44e6ed..43057489c 100644 --- a/meta-oe/recipes-extended/dlt-daemon/dlt-daemon/238.patch +++ b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon/245.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 214f8c71552fc096077f0b916dad75b31eefea3d Mon Sep 17 00:00:00 2001 | 1 | From 57fd61ea5c58a4f9fcd7140b53ac6cd6e971ef47 Mon Sep 17 00:00:00 2001 |
2 | From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> | 2 | From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> |
3 | Date: Fri, 31 Jul 2020 15:26:35 +0200 | 3 | Date: Fri, 31 Jul 2020 15:16:02 +0200 |
4 | Subject: [PATCH] dlt_offline: fix build failures with gcc-10 | 4 | Subject: [PATCH] dlt_offline: fix build failures with gcc-10 |
5 | 5 | ||
6 | see bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=957140 | 6 | see bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=957140 |
@@ -14,11 +14,26 @@ see bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=957140 | |||
14 | /usr/bin/ld: CMakeFiles/dlt-daemon.dir/dlt_daemon_event_handler.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: multiple definition of `g_logstorage_cache_max'; CMakeFiles/dlt-daemon.dir/dlt-daemon.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: first defined here | 14 | /usr/bin/ld: CMakeFiles/dlt-daemon.dir/dlt_daemon_event_handler.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: multiple definition of `g_logstorage_cache_max'; CMakeFiles/dlt-daemon.dir/dlt-daemon.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: first defined here |
15 | /usr/bin/ld: CMakeFiles/dlt-daemon.dir/dlt_daemon_offline_logstorage.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: multiple definition of `g_logstorage_cache_max'; CMakeFiles/dlt-daemon.dir/dlt-daemon.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: first defined here | 15 | /usr/bin/ld: CMakeFiles/dlt-daemon.dir/dlt_daemon_offline_logstorage.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: multiple definition of `g_logstorage_cache_max'; CMakeFiles/dlt-daemon.dir/dlt-daemon.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: first defined here |
16 | --- | 16 | --- |
17 | src/offlinelogstorage/dlt_offline_logstorage.h | 4 ++-- | 17 | src/daemon/dlt_daemon_offline_logstorage.c | 1 + |
18 | 1 file changed, 2 insertions(+), 2 deletions(-) | 18 | src/offlinelogstorage/dlt_offline_logstorage.h | 4 ++-- |
19 | src/offlinelogstorage/dlt_offline_logstorage_behavior.c | 1 + | ||
20 | tests/gtest_dlt_daemon_offline_log.cpp | 1 + | ||
21 | 4 files changed, 5 insertions(+), 2 deletions(-) | ||
19 | 22 | ||
23 | diff --git a/src/daemon/dlt_daemon_offline_logstorage.c b/src/daemon/dlt_daemon_offline_logstorage.c | ||
24 | index 0b3c14f..db9637e 100644 | ||
25 | --- a/src/daemon/dlt_daemon_offline_logstorage.c | ||
26 | +++ b/src/daemon/dlt_daemon_offline_logstorage.c | ||
27 | @@ -56,6 +56,7 @@ DLT_STATIC DltReturnValue dlt_logstorage_split_ecuid(char *key, | ||
28 | return DLT_RETURN_OK; | ||
29 | } | ||
30 | |||
31 | +unsigned int g_logstorage_cache_max; | ||
32 | /** | ||
33 | * dlt_logstorage_split_ctid | ||
34 | * | ||
20 | diff --git a/src/offlinelogstorage/dlt_offline_logstorage.h b/src/offlinelogstorage/dlt_offline_logstorage.h | 35 | diff --git a/src/offlinelogstorage/dlt_offline_logstorage.h b/src/offlinelogstorage/dlt_offline_logstorage.h |
21 | index b58da70..8ad84b8 100644 | 36 | index b58da70..c9bc93b 100644 |
22 | --- a/src/offlinelogstorage/dlt_offline_logstorage.h | 37 | --- a/src/offlinelogstorage/dlt_offline_logstorage.h |
23 | +++ b/src/offlinelogstorage/dlt_offline_logstorage.h | 38 | +++ b/src/offlinelogstorage/dlt_offline_logstorage.h |
24 | @@ -114,9 +114,9 @@ | 39 | @@ -114,9 +114,9 @@ |
@@ -26,10 +41,34 @@ index b58da70..8ad84b8 100644 | |||
26 | 41 | ||
27 | /* logstorage max cache */ | 42 | /* logstorage max cache */ |
28 | -unsigned int g_logstorage_cache_max; | 43 | -unsigned int g_logstorage_cache_max; |
29 | +static unsigned int g_logstorage_cache_max; | 44 | +extern unsigned int g_logstorage_cache_max; |
30 | /* current logstorage cache size */ | 45 | /* current logstorage cache size */ |
31 | -unsigned int g_logstorage_cache_size; | 46 | -unsigned int g_logstorage_cache_size; |
32 | +static unsigned int g_logstorage_cache_size; | 47 | +extern unsigned int g_logstorage_cache_size; |
33 | 48 | ||
34 | typedef struct | 49 | typedef struct |
35 | { | 50 | { |
51 | diff --git a/src/offlinelogstorage/dlt_offline_logstorage_behavior.c b/src/offlinelogstorage/dlt_offline_logstorage_behavior.c | ||
52 | index afbf8c4..edef482 100644 | ||
53 | --- a/src/offlinelogstorage/dlt_offline_logstorage_behavior.c | ||
54 | +++ b/src/offlinelogstorage/dlt_offline_logstorage_behavior.c | ||
55 | @@ -32,6 +32,7 @@ | ||
56 | #include "dlt_offline_logstorage_behavior.h" | ||
57 | #include "dlt_offline_logstorage_behavior_internal.h" | ||
58 | |||
59 | +unsigned int g_logstorage_cache_size; | ||
60 | /** | ||
61 | * dlt_logstorage_log_file_name | ||
62 | * | ||
63 | diff --git a/tests/gtest_dlt_daemon_offline_log.cpp b/tests/gtest_dlt_daemon_offline_log.cpp | ||
64 | index b8965de..0bd4d5e 100644 | ||
65 | --- a/tests/gtest_dlt_daemon_offline_log.cpp | ||
66 | +++ b/tests/gtest_dlt_daemon_offline_log.cpp | ||
67 | @@ -29,6 +29,7 @@ extern "C" | ||
68 | #include <fcntl.h> | ||
69 | } | ||
70 | |||
71 | +unsigned int g_logstorage_cache_max; | ||
72 | /* Begin Method: dlt_logstorage::t_dlt_logstorage_list_add*/ | ||
73 | TEST(t_dlt_logstorage_list_add, normal) | ||
74 | { | ||
diff --git a/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.5.bb b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.5.bb index af8d9fddd..c0b1750e0 100644 --- a/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.5.bb +++ b/meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.5.bb | |||
@@ -18,8 +18,8 @@ SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=https \ | |||
18 | file://0002-Don-t-execute-processes-as-a-specific-user.patch \ | 18 | file://0002-Don-t-execute-processes-as-a-specific-user.patch \ |
19 | file://0004-Modify-systemd-config-directory.patch \ | 19 | file://0004-Modify-systemd-config-directory.patch \ |
20 | file://275.patch \ | 20 | file://275.patch \ |
21 | file://238.patch \ | ||
22 | file://241.patch \ | 21 | file://241.patch \ |
22 | file://245.patch \ | ||
23 | " | 23 | " |
24 | SRCREV = "f1ac087c766827b1d0ed9c3a814b3cc052e948f2" | 24 | SRCREV = "f1ac087c766827b1d0ed9c3a814b3cc052e948f2" |
25 | 25 | ||