summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2.inc6
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0001-Replace-CPPFunction-with-rl_completion_func_t.patch33
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0001-snapshot-check-snapshot-exists.patch29
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/mlock-ignore-vectors-gate_vma.patch31
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2_2.02.125.bb4
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2_2.02.97.bb6
6 files changed, 5 insertions, 104 deletions
diff --git a/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-oe/recipes-support/lvm2/lvm2.inc
index 34fec99a6..f518884e7 100644
--- a/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -4,15 +4,11 @@ DEPENDS = "udev"
4LICENSE = "GPLv2 & LGPLv2" 4LICENSE = "GPLv2 & LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24" 6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24"
7INC_PR = "r4"
8
9 7
10S = "${WORKDIR}/LVM2.${PV}" 8S = "${WORKDIR}/LVM2.${PV}"
11SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz \ 9SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz \
12 file://0001-Replace-CPPFunction-with-rl_completion_func_t.patch \
13 file://mlock-ignore-vectors-gate_vma.patch \
14 file://lvm.conf \ 10 file://lvm.conf \
15 file://0001-snapshot-check-snapshot-exists.patch" 11 "
16 12
17PACKAGECONFIG ??= "readline" 13PACKAGECONFIG ??= "readline"
18PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline" 14PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-Replace-CPPFunction-with-rl_completion_func_t.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-Replace-CPPFunction-with-rl_completion_func_t.patch
deleted file mode 100644
index 98c21fdb3..000000000
--- a/meta-oe/recipes-support/lvm2/lvm2/0001-Replace-CPPFunction-with-rl_completion_func_t.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From e2484e179c389b98366c8b66b451d9d2ba8f35e8 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@freescale.com>
3Date: Tue, 25 Mar 2014 17:39:43 +0800
4Subject: [PATCH] Replace CPPFunction with rl_completion_func_t
5
6lvm2 depends on readline, CPPFunction has been replaced by rl_completion_func_t
7in recent readline,
8
9Upstream-Status: Inappropriate [configuration]
10The change depends on the build environment, it is required by OpenEmbedded env
11due to readline upgrade.
12
13Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
14---
15 tools/lvm.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/tools/lvm.c b/tools/lvm.c
19index e002a76..5fa35d2 100644
20--- a/tools/lvm.c
21+++ b/tools/lvm.c
22@@ -186,7 +186,7 @@ int lvm_shell(struct cmd_context *cmd, struct cmdline_context *cmdline)
23 char *input = NULL, *args[MAX_ARGS], **argv;
24
25 rl_readline_name = "lvm";
26- rl_attempted_completion_function = (CPPFunction *) _completion;
27+ rl_attempted_completion_function = (rl_completion_func_t *) _completion;
28
29 _read_history(cmd);
30
31--
321.9.1
33
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-snapshot-check-snapshot-exists.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-snapshot-check-snapshot-exists.patch
deleted file mode 100644
index 8f0da796d..000000000
--- a/meta-oe/recipes-support/lvm2/lvm2/0001-snapshot-check-snapshot-exists.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From c46d4a745dc8c5cb4cfc0c94863e555387e9af75 Mon Sep 17 00:00:00 2001
2From: Zdenek Kabelac <zkabelac@redhat.com>
3Date: Mon, 16 Jun 2014 12:41:30 +0200
4Subject: [PATCH] snapshot: check snapshot exists
5
6Return 0 if the LV is not even snapshot.
7
8Upstream-Status: backport
9Adapt the patch for backporting to an older version.
10Signed-off-by: Li Zhou <li.zhou@windriver.com>
11---
12 lib/metadata/snapshot_manip.c | 3 ++-
13 1 file changed, 2 insertions(+), 1 deletion(-)
14
15Index: LVM2.2.02.97/lib/metadata/snapshot_manip.c
16===================================================================
17--- LVM2.2.02.97.orig/lib/metadata/snapshot_manip.c
18+++ LVM2.2.02.97/lib/metadata/snapshot_manip.c
19@@ -68,8 +68,9 @@ struct lv_segment *find_merging_cow(cons
20
21 int lv_is_merging_cow(const struct logical_volume *snapshot)
22 {
23+ struct lv_segment *snap_seg = find_cow(snapshot);
24 /* checks lv_segment's status to see if cow is merging */
25- return (find_cow(snapshot)->status & MERGING) ? 1 : 0;
26+ return (snap_seg && (snap_seg->status & MERGING)) ? 1 : 0;
27 }
28
29 /* Given a cow LV, return the snapshot lv_segment that uses it */
diff --git a/meta-oe/recipes-support/lvm2/lvm2/mlock-ignore-vectors-gate_vma.patch b/meta-oe/recipes-support/lvm2/lvm2/mlock-ignore-vectors-gate_vma.patch
deleted file mode 100644
index 310513679..000000000
--- a/meta-oe/recipes-support/lvm2/lvm2/mlock-ignore-vectors-gate_vma.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1Subject: [PATCH] fix: mlock ignore [vectors] gate_vma
2
3Upstream-Status: Pending
4
5linux kernel has a new commit f9d4861f for [vectors] vma on ARM
6"ARM: 7294/1: vectors: use gate_vma for vectors user mapping".
7
8mlock()/munlock() on a gate_vma would cause NOMEM error, so add
9[vectors] to _ignore_maps[], as other gate_vmas [vdso]/[vsyscall]
10did.
11
12Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
13---
14 lib/mm/memlock.c | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/lib/mm/memlock.c b/lib/mm/memlock.c
18index 8c631bf..a6b1955 100644
19--- a/lib/mm/memlock.c
20+++ b/lib/mm/memlock.c
21@@ -84,6 +84,7 @@ static int _default_priority;
22 static const char * const _ignore_maps[] = {
23 "[vdso]",
24 "[vsyscall]",
25+ "[vectors]",
26 };
27
28 /* default blacklist for maps */
29--
301.7.9.5
31
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.02.125.bb b/meta-oe/recipes-support/lvm2/lvm2_2.02.125.bb
new file mode 100644
index 000000000..8e464d273
--- /dev/null
+++ b/meta-oe/recipes-support/lvm2/lvm2_2.02.125.bb
@@ -0,0 +1,4 @@
1require lvm2.inc
2
3SRC_URI[md5sum] = "2d24ba982c8a85e8c837210f087a6a51"
4SRC_URI[sha256sum] = "0e6da28465752cc2db7e7e6fc7b012a0146a98d717ac5dea1c900d4bc32bedb1"
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.02.97.bb b/meta-oe/recipes-support/lvm2/lvm2_2.02.97.bb
deleted file mode 100644
index 2de17cfe3..000000000
--- a/meta-oe/recipes-support/lvm2/lvm2_2.02.97.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1require lvm2.inc
2
3PR = "${INC_PR}.0"
4
5SRC_URI[md5sum] = "d18bd01334309db1c422b9bf6b181057"
6SRC_URI[sha256sum] = "edda82012e8a9e1f0b00ba5a331468d3e0201992be14c0dbea71bf564a51fc2b"