summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-bcrypt.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-bcrypt_3.1.3.bb2
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-bcrypt.inc b/meta-python/recipes-devtools/python/python-bcrypt.inc
new file mode 100644
index 000000000..667a3fb6e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-bcrypt.inc
@@ -0,0 +1,15 @@
1DESCRIPTION = "Modern password hashing for your software and your servers."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4
5DEPENDS += "${PYTHON_PN}-cffi-native"
6
7SRC_URI[md5sum] = "20da8b40790caad99c4086dba533154b"
8SRC_URI[sha256sum] = "6645c8d0ad845308de3eb9be98b6fd22a46ec5412bfc664a423e411cdd8f5488"
9
10inherit pypi
11
12RDEPENDS_${PN}_class-target += "\
13 ${PYTHON_PN}-cffi \
14 ${PYTHON_PN}-six \
15"
diff --git a/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb b/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb
index c690f0dfd..24333540b 100644
--- a/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb
+++ b/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb
@@ -1,15 +1,2 @@
1DESCRIPTION = "Modern password hashing for your software and your servers." 1inherit setuptools
2LICENSE = "Apache-2.0" 2require python-bcrypt.inc
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4
5DEPENDS = "python-cffi-native"
6
7SRC_URI[md5sum] = "20da8b40790caad99c4086dba533154b"
8SRC_URI[sha256sum] = "6645c8d0ad845308de3eb9be98b6fd22a46ec5412bfc664a423e411cdd8f5488"
9
10inherit pypi setuptools
11
12RDEPENDS_${PN}_class-target += "\
13 ${PYTHON_PN}-cffi \
14 ${PYTHON_PN}-six \
15"
diff --git a/meta-python/recipes-devtools/python/python3-bcrypt_3.1.3.bb b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.3.bb
new file mode 100644
index 000000000..d2ec9e386
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.3.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-bcrypt.inc