summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-psutil.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-psutil_4.2.0.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb6
3 files changed, 19 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-psutil.inc b/meta-python/recipes-devtools/python/python-psutil.inc
new file mode 100644
index 000000000..33573fca9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-psutil.inc
@@ -0,0 +1,10 @@
1SUMMARY = "A cross-platform process and system utilities module for Python"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=0f02e99f7f3c9a7fe8ecfc5d44c2be62"
4
5SRC_URI[md5sum] = "713f259f917a0c26acfbb7e6ae632ef7"
6SRC_URI[sha256sum] = "544f013a0aea7199e07e3efe5627f5d4165179a04c66050b234cc3be2eca1ace"
7
8RDEPENDS_${PN} += " \
9 python-subprocess \
10"
diff --git a/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb b/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb
index a5703dade..d718011e4 100644
--- a/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb
@@ -1,12 +1,6 @@
1SUMMARY = "A cross-platform process and system utilities module for Python" 1inherit pypi setuptools
2LICENSE = "BSD" 2require python-psutil.inc
3LIC_FILES_CHKSUM = "file://LICENSE;md5=0f02e99f7f3c9a7fe8ecfc5d44c2be62"
4
5SRC_URI[md5sum] = "713f259f917a0c26acfbb7e6ae632ef7"
6SRC_URI[sha256sum] = "544f013a0aea7199e07e3efe5627f5d4165179a04c66050b234cc3be2eca1ace"
7 3
8RDEPENDS_${PN} += " \ 4RDEPENDS_${PN} += " \
9 python-subprocess \ 5 python-subprocess \
10 " 6"
11
12inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb b/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb
new file mode 100644
index 000000000..d95332cdc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb
@@ -0,0 +1,6 @@
1inherit pypi setuptools3
2require python-psutil.inc
3
4RDEPENDS_${PN} += " \
5 python3-subprocess \
6"