summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-filesystems/recipes-support/fuse/files/aarch64.patch33
-rw-r--r--meta-filesystems/recipes-support/fuse/files/gold-unversioned-symbol.patch92
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb (renamed from meta-oe/recipes-support/fuse/fuse_2.9.2.bb)13
-rw-r--r--meta-oe/recipes-support/fuse/fuse-2.9.2/aarch64.patch20
-rw-r--r--meta-oe/recipes-support/fuse/fuse-2.9.2/gold-unversioned-symbol.patch60
5 files changed, 133 insertions, 85 deletions
diff --git a/meta-filesystems/recipes-support/fuse/files/aarch64.patch b/meta-filesystems/recipes-support/fuse/files/aarch64.patch
new file mode 100644
index 000000000..050d1146a
--- /dev/null
+++ b/meta-filesystems/recipes-support/fuse/files/aarch64.patch
@@ -0,0 +1,33 @@
1fuse: add aarch64 support
2
3u64/u32 is not defined in sys/types.h, include linux/types.h like
4the kernel version of fuse.h does. Patch sent to upstream mailing list.
5
6Upstream-Status: Submitted
7Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9---
10 include/fuse_kernel.h | 7 +------
11 1 file changed, 1 insertion(+), 6 deletions(-)
12
13diff --git a/include/fuse_kernel.h b/include/fuse_kernel.h
14index c632b58..e804278 100644
15--- a/include/fuse_kernel.h
16+++ b/include/fuse_kernel.h
17@@ -88,12 +88,7 @@
18 #ifndef _LINUX_FUSE_H
19 #define _LINUX_FUSE_H
20
21-#include <sys/types.h>
22-#define __u64 uint64_t
23-#define __s64 int64_t
24-#define __u32 uint32_t
25-#define __s32 int32_t
26-#define __u16 uint16_t
27+#include <linux/types.h>
28
29 /*
30 * Version negotiation:
31--
321.8.1.2
33
diff --git a/meta-filesystems/recipes-support/fuse/files/gold-unversioned-symbol.patch b/meta-filesystems/recipes-support/fuse/files/gold-unversioned-symbol.patch
new file mode 100644
index 000000000..d47f692c0
--- /dev/null
+++ b/meta-filesystems/recipes-support/fuse/files/gold-unversioned-symbol.patch
@@ -0,0 +1,92 @@
1fuse: Fix linking issues with gold linker
2
3fuse has problems when linking with gold since it uses version
4scripts in a way thats so perticular to bfd ld
5
6/home/kraj/work/angstrom/build/tmp-angstrom_2010_x-eglibc/sysroots/x86_64-linux/usr/libexec/armv5te-angstrom-linux-gnueabi/gcc/arm-angstro
7error: symbol __fuse_exited has undefined version
8| collect2: ld returned 1 exit status
9| make[1]: *** [libfuse.la] Error 1
10| make[1]: *** Waiting for unfinished jobs....
11
12For more details
13
14http://blog.flameeyes.eu/2011/06/01/gold-readiness-obstacle-2-base-versioning
15http://sources.redhat.com/bugzilla/show_bug.cgi?id=10861
16http://comments.gmane.org/gmane.comp.file-systems.fuse.devel/9524
17http://www.airs.com/blog/archives/300
18
19Upstream-Status: Pending
20Signed-off-by: Khem Raj <raj.khem@gmail.com>
21Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
22Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
23---
24 lib/fuse.c | 10 +++++-----
25 lib/fuse_mt.c | 2 +-
26 lib/fuse_versionscript | 3 +++
27 lib/helper.c | 6 +++---
28 4 files changed, 12 insertions(+), 9 deletions(-)
29
30diff --git a/lib/fuse.c b/lib/fuse.c
31index 067d0dc..6d27711 100644
32--- a/lib/fuse.c
33+++ b/lib/fuse.c
34@@ -4873,11 +4873,11 @@ struct fuse *fuse_new_compat1(int fd, int flags,
35 11);
36 }
37
38-FUSE_SYMVER(".symver fuse_exited,__fuse_exited@");
39-FUSE_SYMVER(".symver fuse_process_cmd,__fuse_process_cmd@");
40-FUSE_SYMVER(".symver fuse_read_cmd,__fuse_read_cmd@");
41-FUSE_SYMVER(".symver fuse_set_getcontext_func,__fuse_set_getcontext_func@");
42-FUSE_SYMVER(".symver fuse_new_compat2,fuse_new@");
43+FUSE_SYMVER(".symver fuse_exited,__fuse_exited@FUSE_UNVERSIONED");
44+FUSE_SYMVER(".symver fuse_process_cmd,__fuse_process_cmd@FUSE_UNVERSIONED");
45+FUSE_SYMVER(".symver fuse_read_cmd,__fuse_read_cmd@FUSE_UNVERSIONED");
46+FUSE_SYMVER(".symver fuse_set_getcontext_func,__fuse_set_getcontext_func@FUSE_UNVERSIONED");
47+FUSE_SYMVER(".symver fuse_new_compat2,fuse_new@FUSE_UNVERSIONED");
48 FUSE_SYMVER(".symver fuse_new_compat22,fuse_new@FUSE_2.2");
49
50 #endif /* __FreeBSD__ || __NetBSD__ */
51diff --git a/lib/fuse_mt.c b/lib/fuse_mt.c
52index f6dbe71..fd5ac23 100644
53--- a/lib/fuse_mt.c
54+++ b/lib/fuse_mt.c
55@@ -119,4 +119,4 @@ int fuse_loop_mt(struct fuse *f)
56 return res;
57 }
58
59-FUSE_SYMVER(".symver fuse_loop_mt_proc,__fuse_loop_mt@");
60+FUSE_SYMVER(".symver fuse_loop_mt_proc,__fuse_loop_mt@FUSE_UNVERSIONED");
61diff --git a/lib/fuse_versionscript b/lib/fuse_versionscript
62index 8d91887..de16ab2 100644
63--- a/lib/fuse_versionscript
64+++ b/lib/fuse_versionscript
65@@ -1,3 +1,6 @@
66+FUSE_UNVERSIONED {
67+};
68+
69 FUSE_2.2 {
70 global:
71 fuse_destroy;
72diff --git a/lib/helper.c b/lib/helper.c
73index b644012..c5349bf 100644
74--- a/lib/helper.c
75+++ b/lib/helper.c
76@@ -436,10 +436,10 @@ int fuse_mount_compat1(const char *mountpoint, const char *args[])
77 return fuse_mount_compat22(mountpoint, NULL);
78 }
79
80-FUSE_SYMVER(".symver fuse_setup_compat2,__fuse_setup@");
81+FUSE_SYMVER(".symver fuse_setup_compat2,__fuse_setup@FUSE_UNVERSIONED");
82 FUSE_SYMVER(".symver fuse_setup_compat22,fuse_setup@FUSE_2.2");
83-FUSE_SYMVER(".symver fuse_teardown,__fuse_teardown@");
84-FUSE_SYMVER(".symver fuse_main_compat2,fuse_main@");
85+FUSE_SYMVER(".symver fuse_teardown,__fuse_teardown@FUSE_UNVERSIONED");
86+FUSE_SYMVER(".symver fuse_main_compat2,fuse_main@FUSE_UNVERSIONED");
87 FUSE_SYMVER(".symver fuse_main_real_compat22,fuse_main_real@FUSE_2.2");
88
89 #endif /* __FreeBSD__ || __NetBSD__ */
90--
911.8.1.2
92
diff --git a/meta-oe/recipes-support/fuse/fuse_2.9.2.bb b/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb
index b6c2a9e53..358b58eb5 100644
--- a/meta-oe/recipes-support/fuse/fuse_2.9.2.bb
+++ b/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb
@@ -1,18 +1,21 @@
1DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program" 1SUMMARY = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3programs to export a virtual filesystem to the Linux kernel. FUSE \
4also aims to provide a secure method for non privileged users to \
5create and mount their own filesystem implementations. \
6"
2HOMEPAGE = "http://fuse.sf.net" 7HOMEPAGE = "http://fuse.sf.net"
3SECTION = "libs" 8SECTION = "libs"
4LICENSE = "GPLv2 & LGPLv2" 9LICENSE = "GPLv2 & LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" 11 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7 12
8PR = "r1"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz \ 13SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz \
11 file://gold-unversioned-symbol.patch \ 14 file://gold-unversioned-symbol.patch \
12 file://aarch64.patch \ 15 file://aarch64.patch \
13" 16"
14SRC_URI[md5sum] = "7d80d0dc9cc2b9199a0c53787c151205" 17SRC_URI[md5sum] = "33cae22ca50311446400daf8a6255c6a"
15SRC_URI[sha256sum] = "81a728fb3f87da33063068735e2fb7e2cd89df207d32687d3d3278385279cefc" 18SRC_URI[sha256sum] = "0beb83eaf2c5e50730fc553406ef124d77bc02c64854631bdfc86bfd6437391c"
16 19
17inherit autotools pkgconfig 20inherit autotools pkgconfig
18 21
diff --git a/meta-oe/recipes-support/fuse/fuse-2.9.2/aarch64.patch b/meta-oe/recipes-support/fuse/fuse-2.9.2/aarch64.patch
deleted file mode 100644
index 180f544f4..000000000
--- a/meta-oe/recipes-support/fuse/fuse-2.9.2/aarch64.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1Upstream-Status: Submitted
2
3Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
4
5--- a/include/fuse_kernel.h
6+++ b/include/fuse_kernel.h
7@@ -88,12 +88,7 @@
8 #ifndef _LINUX_FUSE_H
9 #define _LINUX_FUSE_H
10
11-#include <sys/types.h>
12-#define __u64 uint64_t
13-#define __s64 int64_t
14-#define __u32 uint32_t
15-#define __s32 int32_t
16-#define __u16 uint16_t
17+#include <linux/types.h>
18
19 /*
20 * Version negotiation:
diff --git a/meta-oe/recipes-support/fuse/fuse-2.9.2/gold-unversioned-symbol.patch b/meta-oe/recipes-support/fuse/fuse-2.9.2/gold-unversioned-symbol.patch
deleted file mode 100644
index 8ee97dff0..000000000
--- a/meta-oe/recipes-support/fuse/fuse-2.9.2/gold-unversioned-symbol.patch
+++ /dev/null
@@ -1,60 +0,0 @@
1Index: fuse-2.8.6/lib/fuse.c
2===================================================================
3--- fuse-2.8.6.orig/lib/fuse.c 2011-09-13 00:23:14.000000000 -0700
4+++ fuse-2.8.6/lib/fuse.c 2011-10-19 09:20:27.537099939 -0700
5@@ -3947,11 +3947,11 @@
6 11);
7 }
8
9-FUSE_SYMVER(".symver fuse_exited,__fuse_exited@");
10-FUSE_SYMVER(".symver fuse_process_cmd,__fuse_process_cmd@");
11-FUSE_SYMVER(".symver fuse_read_cmd,__fuse_read_cmd@");
12-FUSE_SYMVER(".symver fuse_set_getcontext_func,__fuse_set_getcontext_func@");
13-FUSE_SYMVER(".symver fuse_new_compat2,fuse_new@");
14+FUSE_SYMVER(".symver fuse_exited,__fuse_exited@FUSE_UNVERSIONED");
15+FUSE_SYMVER(".symver fuse_process_cmd,__fuse_process_cmd@FUSE_UNVERSIONED");
16+FUSE_SYMVER(".symver fuse_read_cmd,__fuse_read_cmd@FUSE_UNVERSIONED");
17+FUSE_SYMVER(".symver fuse_set_getcontext_func,__fuse_set_getcontext_func@FUSE_UNVERSIONED");
18+FUSE_SYMVER(".symver fuse_new_compat2,fuse_new@FUSE_UNVERSIONED");
19 FUSE_SYMVER(".symver fuse_new_compat22,fuse_new@FUSE_2.2");
20
21 #endif /* __FreeBSD__ */
22Index: fuse-2.8.6/lib/fuse_mt.c
23===================================================================
24--- fuse-2.8.6.orig/lib/fuse_mt.c 2011-09-13 00:23:14.000000000 -0700
25+++ fuse-2.8.6/lib/fuse_mt.c 2011-10-19 09:20:27.537099939 -0700
26@@ -113,4 +113,4 @@
27 return fuse_session_loop_mt(fuse_get_session(f));
28 }
29
30-FUSE_SYMVER(".symver fuse_loop_mt_proc,__fuse_loop_mt@");
31+FUSE_SYMVER(".symver fuse_loop_mt_proc,__fuse_loop_mt@FUSE_UNVERSIONED");
32Index: fuse-2.8.6/lib/fuse_versionscript
33===================================================================
34--- fuse-2.8.6.orig/lib/fuse_versionscript 2011-09-13 00:23:14.000000000 -0700
35+++ fuse-2.8.6/lib/fuse_versionscript 2011-10-19 09:20:27.541099939 -0700
36@@ -1,3 +1,6 @@
37+FUSE_UNVERSIONED {
38+};
39+
40 FUSE_2.2 {
41 global:
42 fuse_destroy;
43Index: fuse-2.8.6/lib/helper.c
44===================================================================
45--- fuse-2.8.6.orig/lib/helper.c 2011-09-13 00:23:14.000000000 -0700
46+++ fuse-2.8.6/lib/helper.c 2011-10-19 09:20:27.541099939 -0700
47@@ -409,10 +409,10 @@
48 return fuse_mount_compat22(mountpoint, NULL);
49 }
50
51-FUSE_SYMVER(".symver fuse_setup_compat2,__fuse_setup@");
52+FUSE_SYMVER(".symver fuse_setup_compat2,__fuse_setup@FUSE_UNVERSIONED");
53 FUSE_SYMVER(".symver fuse_setup_compat22,fuse_setup@FUSE_2.2");
54-FUSE_SYMVER(".symver fuse_teardown,__fuse_teardown@");
55-FUSE_SYMVER(".symver fuse_main_compat2,fuse_main@");
56+FUSE_SYMVER(".symver fuse_teardown,__fuse_teardown@FUSE_UNVERSIONED");
57+FUSE_SYMVER(".symver fuse_main_compat2,fuse_main@FUSE_UNVERSIONED");
58 FUSE_SYMVER(".symver fuse_main_real_compat22,fuse_main_real@FUSE_2.2");
59
60 #endif /* __FreeBSD__ */