summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/opencv/opencv-samples_2.4.bb2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.4.bb3
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.0.bb3
3 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
index 9d862fe91..ecaae4c08 100644
--- a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
@@ -37,3 +37,5 @@ do_install() {
37 37
38FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*" 38FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*"
39FILES_${PN} += "${bindir} ${datadir}/opencv" 39FILES_${PN} += "${bindir} ${datadir}/opencv"
40
41PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv"
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb
index a74853ce3..eb38a5a6a 100644
--- a/meta-oe/recipes-support/opencv/opencv_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb
@@ -103,3 +103,6 @@ do_install_append() {
103 rm -rf ${D}/usr/lib 103 rm -rf ${D}/usr/lib
104 fi 104 fi
105} 105}
106
107# http://errors.yoctoproject.org/Errors/Details/40660/
108PNBLACKLIST[opencv] ?= "Not compatible with currently used ffmpeg 3"
diff --git a/meta-oe/recipes-support/opencv/opencv_3.0.bb b/meta-oe/recipes-support/opencv/opencv_3.0.bb
index 1948a1656..99ca8b357 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.0.bb
@@ -131,3 +131,6 @@ do_install_append() {
131 install -d ${D}${datadir}/OpenCV/samples/bin/ 131 install -d ${D}${datadir}/OpenCV/samples/bin/
132 cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/ 132 cp -f bin/*-tutorial-* bin/*-example-* ${D}${datadir}/OpenCV/samples/bin/
133} 133}
134
135# http://errors.yoctoproject.org/Errors/Details/40660/
136PNBLACKLIST[opencv] ?= "Not compatible with currently used ffmpeg 3"